Z axis doesn't move

I posted about this a couple of months ago but I can’t find it. I built the mpcnc using the Rambo v1.4 board. Using the V1cnc Display, x & y axis work fine but when I try to move z the Nema 17 stepper just rattles in both directions. I thought the stepper was bad so I ordered a new one from V1. It did the same thing. It was suggested that the solder joints on the Rambo sometimes would go bad so I re-soldered the joints on that connector. It didn’t fix the problem. I cut the shrink tube and checked connections where I spliced the stepper wires but they were fine. I also replaced the crimp pins on the connector. I even checked continuity from the splice back to the connector. I can only assume that the something on the Rambo is bad. V1 is no longer selling them and they are nowhere to be found online. After this, I really wouldn’t trust one anyway.
I use this cnc mostly to cut and drill holes in acrylic to make cockpit simulator panels and also for engraving text. Can someone suggest a good replacement board and software that will work with the mpcnc? I also had issues with Estlcam making the text too thick. If there is a better software for text I would really like to switch.
I just saw the Jackpot CNC Controller and the SKR Pro1.2 on V1 shop. I would much appreciate some help with this.

Jerry

Hello there!

I’ve had the rambo 1.4 for many years, and it works like a charm. I don’t know what’s the issue for you - you could try to reflash it? If not the Jackpot is the new king in town. You’ll get plenty of guidance reading the docs and here on the forum.

Estlcam might not be super intuitive at times, but there’s usually something on the user side when it doesn’t turn out as expected. Estlcam v12 is in beta and has many improvements, you might give it a try - it’s said to have better text tools.

1 Like

Absolutely the Jackpot is awesome.
No need for a screen, it has a built in gcode sender that, when connected to your phone via Wi-Fi, it opens up on your phone or tablet. you can use a computer as well.

its also really easy to adjust for square when using endstops. There are probably a lot of other easy to adjust features too, but the squaring is what I use.

Would there be anything else I would need to order with the Jackpot board? Will the V1cnc display work with it?

I saw that the Jackpot has drivers that plug in to the board but the Rambo does not. Are they built into the board? Maybe the one for z axis is bad.

How do I reflash the Rambo?

I do not think so. Since it uses your mobile device or computer via Wi-fi there is not way to connect a scree - Basically it doesn’t need a separate screen.

Unsure. I have the rambo mini which the drivers are built in. So the Rambo might be the same.

Here’s some documentation on flashing via PlatformIO. I"m about to flash my Rambo mini for the first time and looks pretty straight forward, but have not done it yet. There are links to find the correct firmware tool.
https://docs.v1e.com/learn/platformio/

There is no video out from the jackpot. But I’d start with simple trouble shooting. Can you move the Z by hand with the machine powered down? It should be fairly easy to rotate the coupling and raise/lower the tool. If under power it’s “rattling”, sounds like the stepper is trying to move through a physical obstructions.

Leaving the stepper connected electrically, disconnect the lead screw. Does it work?

You can also switch the leads between steppers. From an X to the Y and vice-versa. If the issue is with the board you should get the same problem no matter what axis it’s attached to. So if it thinks it’s moving Z but it’s attached to X, that stepper should fail. If it steps cleanly, it’s not a board issue.

I’m not trying to dissuade you from the jackpot, it’s what I’m running. But I’m a big fan of not spending money that doesn’t need to be spent :slight_smile:

Yes, z moves freely by hand. I loosened the lead screws and disconnected the threaded rod. The stepper still just rattles. I tried swapping the wires around on the z axis connector several different combinations but that didn’t make any difference. (The wire colors on the new stepper were a little different from the old ones) I reconnected the threaded rod, unplugged all the connectors and plugged the z axis into a y axis connector but it still rattled. Then I tried plugging just a y axis into the z connector and it worked so maybe the board is ok. When I first had this problem I thought the original z stepper was bad so I ordered a new one from V1. I can’t believe this new stepper is bad. Is it possible that a board problem can cause a new stepper to fail? I’m not sure where to go from here!

You’ve extended the wires on the z steppers?

I’d start with lots of photos. The wiring on a stepper motor, afaik, isn’t something that can just be switched around and assume that it will work correctly. Steppers work differently than a regular electric motor. So lots of pics from motor, every connection all the way to the board would be where I would start.

The odds of getting 2 new motors that both have an identical issue isn’t 0. but it’s really really low. And unless you found a way to let all the smoke out, motors are fairly difficult to damage.

I’m not running your board so I’m not able to walk you through the wiring but others are. I used the jackpot with the installed plugs, no soldering etc. Worst case the stepper just goes the wrong way and you switch the plug 180 and it’s in business. If you were soldering connections you need the diagram to troubleshoot.

1 Like

I built this cnc in January of 2021 so the original z stepper worked for almost 3 years. The wires weren’t quite long enough on the z axis to reach the board. The wire colors on the original motor were red, green, yellow, blue. The new stepper was red, green, black, blue so I just spliced a yellow on to the black and kept the same order on the connector.

Yeah, you’re probably best served by following as Nathan added after my question, assuming you switched the steppers at the controller, it would appear (or sounds like) the pairing of stepper wires is somehow off, maybe by trying to match the colors.

Either way it sounds like a wiring issue at this point to me.

I know my splices are good. I thought I tried every wire order that I could but I’ll try that one more time. If I can’t get it to work this time I’ll just order a new stepper.

I’m glad you guys kept insisting it was a wire order problem. I looked at the order coming out of the stepper and it was red, green, blue, black. I put them in that order on the connector and it worked. I think I put them in that order originally but there must have been a bad connection somewhere. Anyway, thanks for all your help!

No worries Jerry!
It’s one of the best things about the V1 forum, the collaboration of minds, that are able to solve so many problems together without creating friction.

(Not that we are a collective, and starting to resemble the Borg or anything)

Glad you got it figured out, and it wasn’t a bad controller or hardware. Plus/minus, you now have a spare stepper for future troubleshooting/use.

1 Like

The biggest plus, I don’t have to spend any more money, at least for now. Now I have another issue with homing. All axis move fine using the V1 display and Repetier-Host but when I try to home y, the left and right steppers move forward in sequence but the left stepper doesn’t move back against the end stop. If I home it again left stepper just keeps getting farther from the end stop. x axis homes fine.

I’m by no means the expert, and others with more knowledge should respond as I feel my opinion has room for error.

With expectations set on my opinion, it sounds like the left limit switch is in constant read of being pushed, and backing off by the 10 mm. There’s a M command that shows the status of the limited switches, but me not being knowledgeable, I don’t remember the command.

I know I see it for people troubleshooting the SKR boards, and I’m wanting to think it applies to the RAMBo as well, being it’s a Marlin thing (I think), but again that’s why I need someone more knowledgeable to voice an opinion.

Might have been better if I kept my opinion to myself.

Good chance one of your end stops is triggered. I had one come loose between the wiring and the extension so it always registered as triggering. So it would back off just like immediately after it actually trips until it threw an error that it was unable to back off. The board just thought it was against the endstop and couldn’t move off it. Re-connected and back and business.

Jerry just found this thread, looks like M119 is the terminal command.
Hopefully it’s applicable to the RAMBo.