SKR esp-01 help

I’m trying to add the Wifi to my CNC. I’ve sucessufully flash the ESP01S, I can access and configure the web interface.

In the “files panel”, I’m able to upload files. But I’m not able to access the SD, TFT SD, TFT USB. I can access these storage from my TFT… But not from the web page. I’m always getting a message “error” in the botom of the panel. I can see a “M20 U:/”, “M20 SD:/” or “M20 M21” in the terminal panel, butting nothing other…

Some one has been able to use it? Any idea how to fix it?

Are you using the SD card in the TFT for the files? You should be.

Also wireless transfers are very shaky, it is best to still transfer them directly to the card. The interface is best just for control, not file transfers. It is very slow.

Yes, I’m using the SD card in the TFT. I have tried with an SD card in the TFT, a micro SD in the main board and a USB key in the TFT. All of them separatly

No one is working through the web server. But all of them are working through the TFT screen when I click on print.

I have tried to insert the SD card or USB key before or after the board has been powered up.

Oh…If you did it yourself and didn’t use my files try renaming one of your files to “test.gcode” See if that works.

There is a very strict naming thing on that esp if I remember right.

I have use the firmware files for the board and the TFT from your GitHub repository (I’ve take the link in the wiki).

I’ve just tried with only a file named “test.gcode” on the TFT SD… and same behavior. :frowning:

Does any of it work?

I am really not sure what could be wrong. You used my esp-01 files?

I have use the firmware for the esp01 available in this thread “Add Wifi to SKR Pro step by step”.

For the other, I have use these from GitHub foud in the wiki.

I will tried to flash again all the devices (board, tft and esp01)…

I really do not know of any troubleshooting. If all the setting seem right to you maybe you got a bad ESP chip.

Everything works except seeing any files…Do you have the gray and black cables attached to your TFT screen and the SKR? Do both the marlin and the touch side of the tft see the files on the SD card? If they do I assume the esp is bad.

ok… Flashing all parts has change nothing… :frowning:

I have tried with 2 esp01…

My board was not coming from you Ryan. I have reuse a board from an other project. Is there any jumper that need to be set?

Can you control and move the machine, everything else works, you just can’t see files?

No jumpers.

Do you have the esp plugged into the skr pro, not the screen?

All is working great. Just the files that can’t be navigated on any device other than the “flash” one.

All the cables all properly connected and I can switch from both mode from the tft.

The ESP is connected on the skr pro. Not on the screen.


Where is that file, Can you show screenshots? Pictures are worth a thousand words.

What board and tft are you using, the exact models I sell?

Ok. So, first, I have tried to flash all the 3 component. No change.

This is the version of my boards:

This the connections on the main board (You can see the connection on the TFT on the previous picture):

This is what I got from the TFT in Touch Mode:
Micro SD on the main board

USB Key on the TFT (you can seen it on the right)

SD Card on the TFT (You can seen it on the right)

In Marlin Mode, With a Micro SD card on the main board:

And with a SD Card or USB on the TFT: