Flash Memory Size

I’m showing as having 192KB of Flash in FluidNC. Is it possible to increase this with a different ESP32? I’m not quite sure what this correlates to on ESP32 specs.

image

As I work on WebUI v3 extensions and themes, I’m running out of space. It’s still a manageable amount. You can do things like compress the files and minify HTML/CSS, but it would still be nice to have more.

It technically works to store these files on the SD, but I’m not sure if that has limitations.

Thoughts?

The V1 ESP32 has more storage.

I was able to compile the firmware to take advantage of it myself at one point. Takes it up to more than 1Mb of free space if I remember correctly

There’s a thread around here somewhere where someone else did too.

It’s not terribly difficult, you just have to make a couple changes to get the partitions right.

Doubling the flash doesn’t give you as much extra storage as you would think because of the way OTA updates work, it needs to be split somewhat evenly amongst the partitions

1 Like

Ah, found it. I tried searching before but didn’t have the right search terms.
8MB FluidNC build on V1E ESP32 - Software / Firmware / Jackpot Board / FluidNC - V1 Engineering Forum

That would be more than enough.

I’ve been looking for a reason to buy one of these…

Thanks!

Well, the originals were 8MB I believe, not sure if that’s changed.

Maybe confirm with @vicious1

According to the item in the store, they are 8 MB.

V1 Engineering ESP32 Devkit – V1 Engineering Inc

* This build features a genuine Espressif ESP32-Wroom-32E-N8 (8MB), as well as a genuine CP2102.

To directly compare with an Espressif direct DevKitC, those have half the memory (4MB) of ours, no extra UARTS, and a boring red LED.

2 Likes

I have one with the green LED that can be used to signal an airplane if you need to

3 Likes

Confirmed the 8mb is still there, and the special edition alien signaling boards are now sold out on the boring dim LED’s

I just learned I say addition and edition the same…English is hard sometimes.

1 Like

Did you get one that was coated with black nail polish? That’s helped me in the past when I had crazy bright LEDs.

I did put some on it, and it softened the glow, but was still twice as bright as the “normal” ones lol

with nothing on it, it feels blinding to look at

I’ve been wanting for a while to play around with using the additional flash space. The deployed system seems to be a bit tight to me, and this is one of the reasons I bought several of the V1 esp-32s to play with.

I’m glad you started this thread Jason. I changed these lines in the platformio.ini file and was able to update my V1E ESP32. I now have Total:1.77MB. Fluidnc seems to run smoother now too.

; board_build.partitions = min_littlefs.csv ; For 4M ESP32
board_build.partitions = FluidNC/ld/esp32/app3M_spiffs1M_8MB.csv  ; For 8Meg ESP32
; board_build.partitions = FluidNC/ld/esp32/app3M_spiffs9M_16MB.csv ; For 16Meg ESP32
board_upload.maximum_size = 8388608 ; For 8Meg ESP32
board_upload.flash_size = 8MB ; For 8Meg ESP32
board_build.filesystem = littlefs

1 Like

Are you guys using the pendant? I tried this, and then had trouble adding the pendant. I actually think it was unrelated, and the pendant (and everything else) is currently working with the standard build on the ESP32.

But going back and re-flashing the ESP32 could turn my fully functional machine back into a paperweight. So I’ve been reluctant. But if you guys are using the pendant with it, then perhaps I’ll revisit the project.

I don’t have a pendant but stuff like this is why I ordered 2 ESP32s. Try stuff out on a spare but can fall back to a known working one.

I have spares- and a pendant- and hopefully in less than a week a working LR3 to test with.

So I’ll give it a go as soon as I can.

Yes, I am using the pendant. The pendant worked after the update. I am currently using the ‘FluidDial-CYD’ branch on my pendant. Mitch made some updates for it on that branch.
Be sure and download all your settings files. It erased mine and I had to upload all of them using Fluidterm.
config.yaml, index.html.gz, theme-V1E(Dark).gz, preferences.json

Ahh, this is great. That was my first venture into PlatformIO and was easier than I expected.

image

3 Likes

Spoke too soon. Can’t connect to WebUI when it’s plugged into the Jackpot. Works fine connecting over wifi when connected to USB on my PC.

I do have a v1.1 Jackpot. Do you think this is related to the resistor issue resolved with v1.2?

yes, you need the resistor with the genuine ESP32s, including the V1 boards, with the v1.1 Jackpot

4.7k from 3.3 to pin 0.

You can test it. Just wait a few seconds after boot, then hit the reset button on the ESP32, and then you should be able to get it connected

2 Likes

Ok, I can do that. I saw that I can put that on the bottom of the Jackpot. I wouldn’t want to Frankenstein one of these fancy V1E ESP32s.

Yep, that works.

Thanks!

1 Like

Added the resistor and it now works as expected. Haven’t seen a photo with it under the Jackpot so here it is.

1 Like