Z probe not stopping Z axis

Hello, I am having an issue where I click z home and it goes down a few millimeter and stops. nothing I do seems to change this. x and y homing works awesome.

Ramps 1.4

I did use M119 to test and it is open and when I touch the probe it says triggered. I tried swapping the pins for the clip and the plate.

Right now I am trying to move z axis down and stop it using z min plug by triggering the probe by hand. it just ignores the signal.

I am sure this is an easy fix but I have been trying for several days and have reached the point of asking.

Ramps 1.4…with my firmware? Dual or regular? How are you “homing” Z. LCD, reptier, or Gcode?

I found it very tricky to get Z homing to work correctly. I also wanted G38 to work at the same time (for probing).

I don’t know the exact combination of settings that makes it work (or not work). Some settings do not really seem to work as advertised or in the way you would expect from the comments in the config file.

You can look at my configuration here, and maybe check what is different in yours. It is based on Ryan’s settings, but I changed a bunch of things (also things unrelated to probing). I also use RAMPS and I have connected the probe to the Z endstop. Everything works for me with this config.


Ramps 1.4 with your firmware dual endstops
Homing z axis using LCD, also tried using repieter. Last night I used the post processor for fusion and the z kept going down after touching plate. Stopped it before any damage.

I’ll check out your code to see what is different, thanks

I’m not quite clear on the combination of things you’re seeing, but when not homing the machine ignores the endstops. This behavior can be changed in firmware.

As for moving a few mm and stopping when trying to home, that is certainly strange. As if the pin were randomly falsely triggering. Is the movement the same every time?


What part of code is allowing it to be ignored? This may seem like a dumb question but why would we want it to ignore it when not homing?

It seems to be the same distance everytime. I have it wired to the com and signal connection with its logic as true (NO) as the firmware is previously designed.

When I use the custom commands for xy home it does move the z axis down some as well, is this normal

Im my experience with setting up Marlin for this, it is not a dumb question. I don’t know why it does some things the way it does…

When you do M119, you should see a line starting with “z_min”, which is open or triggered depending on whether your probe is touching or not. In some cases you also get a line starting with “z_probe”, which can also be triggered by a probe wired to the Z endstop. But for homing you need z_min, not z_probe.

No, I don’t think so. When the Z stepper is turned on but not moving, can you easily turn the threaded rod by hand? It should be quite hard. If not, your Z stepper is not working properly and you should check all the wires. It is possible that a stepper still kind of works with a loose wire or a wire that loses contact sometimes. Another possibility is that the stepper driver overheats.

There is a setting to enable them all the time. Something like “hardstops”. I am guessing the reason is that if you’re 43 hours into a print job and your endstop wiring comes loose, you don’t want it to destroy your print. In a CNC, you might argue it is less likely, but still, if there is any noise on your line, it will be a terrible gremlin to find. Feel free to experiment and enable it though, this is your machine. :slight_smile:

So I did m119 again just incase I missed it. So it says z_min_endstop: open when the probe is not touching. And triggered when touching. I have never seen the z probe one pop up though, I do have it wired to z min pins.

I checked the wires and if I manually level the z axis to its 0 position and set that as home without a z probe the machine works great. It’s just this dang z probe for homing and probing using fusion that’s causing me such problems. I need to reprint the pen holder because last night it went to far when i used the post processor in fusion 360 for a probe.

That does make since about if a wire comes loose it would mess up the print. I will probably try changing that until I get better. I would rather mess up my print then the machine.

Thanks for all the support. I am trying all the ideas but haven’t hit that gremlin yet. This community is amazing for support!

Sorry forgot to answer this question: when the z motor is on that axis is rock solid. When it goes down during the xy home it literally is moving it down. I cannot figure out why though. My first thought is maybe I wired it wrong. I will take pictures in a few (no judging the cord management, it’s being fixed once the drag chain finishes printing)

In your first post you said XY homing works great. Is that still the case? Did the Z always move during an XY home? Even when you explicitly home a single axis?

If you can post (a link to) your Configuration.h and Configuration_adv.h I can take a look if I see something wrong.

Hey, from the start when I home XY it always moved the z down and then homed. I used


With no changes but bed size to 550 and 520. Is homing supposed to maybe move z axis up out of the way and my motor is wired backward? still problem of z home moving a few inches and just stopping.

So I have been out here for a couple hours. I just flipped my cable for the z axis and it now moves up when + and down when negative, is this right? Still no freaken luck with z probe but I did break another pen mount before I stopped it.:thinking:



Awesome, fixed one part but it will only move about 1 inch when I click a home or type g28 z. I really would love to solve this stupid code! Now with flipping the plug it moves up when i click home…

Try a manual command, G28 Z

Is it moving up one inch when you hit the button? That means it thinks it is already home.

m119 still says open on all and when you trigger Z it says closed?

Something is missing what you describe should not be happening.

When i type G28 Z it moves up ~1 inch and when i do m119 it says open (unless i am touching probe to plate). I could make a video and post it with a link (youtube?), it doesnt make since because it should have to find home at least once right? i did a test and it is working great again with just xy homing but z homing/ z probe doesnt seem to work (lets be honest, probably something easy i am doing wrong)

Pretty stumped on this one. Try homing without your Z probe connected to the board at all , kill the power before it crashes. Another option is to switch the polarity of your probe you could be picking up a stray voltage from the tool or something.

You could, that may help, especially if you can do a screen capture of your interface when you do the commands. Close ups on wiring and the plate and clip.

Or just post screen shots here of everything. Maybe someone will spot something.