Z axis diving

I’ve seen this issue with other people on the forums but none of their solutions work for mine.

On the MPCNC primo running on the Rambo board and Fusion 360 as the CAM software, I run a program and for the most part the program runs fine, but randomly the Z axis will dive down and ruin the part.

My first guess was a programming error, but the issue happens randomly using the same code - never happens at the same line twice.

Second guess was maybe interference with the z axis motor wire and the spindle wire (using a 2.2Kw CNC spindle). Separated the wires from each other as good as is possible with no better results.

Third guess was rapid movements. I changed this down to 40mm/minute from the previous 300mm/min. No luck.

Next I found that my Z axis motor was actually busted and I got really excited thinking I had a simple fix. Swapped the motor out to a new one, and it still does it! The new motor is definitely not busted, but it does run really hot to the touch so I think I need to get a different one still.

This one has got me scratching my head. Any suggestions?

Maybe too much current? When the stepper drivers get too hot they skip steps. Could also be the grub screw.

1 Like

How do you adjust the current?

I don’t know, I use different hardware. Maybe you don’t even have to do it any more, but someone here should know. :sweat_smile:

Sounds like a connection problem. Make sure your crimps, connections and solder joints are all in good shape.

The RAMBo has digipots, and current settings can be checked and adjusted from the 12864 LCD controller, or by gcode.

The motor getting hot is likely a clue. Breakijg a motor is unusual.

Also worth checking are the grub screws for the Z axis.

I believe this is set with M907 then you use M500 to save the setting. I believe that the LCD menu can read the current setting, too.

1 Like

On temperature, the rule I’ve seen tossed around on the forum is to keep the motors below 50C. Temperatures above 50C start to risk the PLA plastic. An IR thermometer can be inexpensive and give you a real reading of the temperature of your stepper. If you have the current at the default V1 setting, and reasonable steppers, you should not see temperatures above 50C.

It is exceedingly rare for a stepper motor to go bad. In the hundreds of posts where a bad stepper was a possibility for an issue, I can only remember two bad steppers. So, if you’ve had a stepper go bad, you need to carefully consider the current setting and stepper you are using.

A 2.2Kw spindle has to be heavy. If you have not already done it, consider going with a 1-start or 2-start lead screw. The V1 specified 4-start lead screw moves at 8mm per turn. A 2-start lead screw moves at 4mm per turn, so it doubles the torque. A 1-start lead screw moves at 2 mm a turn, so it quadruples the torque. Going to an alternate lead screw with reduce your max feedrate and requires you to adjust steps/mm. Also, if there is some other underlying issue causing your problem, an alternate lead screw could hide the problem, rather than just fix the issue.

The behavior you are experiencing is similar to what happened when Fusion 360 removed the rapids for non-paid users, so if you are using the personal/free version, limiting rapids does nothing. The recommended post processor for Fusion 360 can be found here, and it makes provisions for no rapids.

If you have not done so already, I recommend limiting the feedrate for Z in the firmware. You can use M203 to set the value, followed by an M500 to save the setting. *Note that this setting is in mm/sec, not mm/min. The V1 recommendation for Z on the Primo is 480 mm/min, so that would be 8 mm/sec.

Two things I haven’t seen mentioned:

  • The grub screws on the Z coupler. Make sure those aren’t loose.
  • The driver may be overheating. These drivers will shut down if they get over temp, and they will be disabled until they cool down. Which could be 30s. In the meantime, the driver is just off, and the rambo has no idea. The solution is to drop the current (with M907 and M500 to save it) or to cool the rambo with some forced air. If this was the problem, you wouldn’t hear any crunching (skipping steps sounds like crunching). And it would be loose for more than 2s.

Yo Jeff… As if I was going to miss the opportunity to say it. :yum: I admit that I said skipped steps which is technically wrong, but it was both said. :smile:

1 Like

Well I found the culprit- it actually was the stepper motor this time. Both of the motors actually. The first motor that went bad had something burnt out on the inside and had an insane amount of up and downward play in it. I tried another random stepper I had laying around but it had the wrong ratings and was getting very hot. Finally tried one that was rated correctly and it ran with no issues. Unfortunately it does not have enough torque for lifting and lowering the spindle but I used a long stiff spring which will tide me over until I swap out the lead screw or get a better motor.

Thanks for the help!


Well, we were both wrong then. :stuck_out_tongue:

1 Like