Unable to CNC via SDCARD or Repetier

My MPCNC is now finished, I am able to control all the axis using the LCD display, however I have 2 issues.

  1. When attempting to use an SD Card it tells me it is inserted but doesn't show up any files on the card (GCODE)
  2. When attempting to use Repetier Host, which I know very well as have been 3d Printing for years, it handshakes correctly as when you make the connection the software reloads as per normal, however I am unable to remotely control the movement?
Any ideas appreciated



  1. Make sure you have .gcode, not .nc.
  2. double check the baud rate we use 250000, some printers do not. If that is not it the error screen should give some clues.

If that doesn’t work more details on your stuff is needed.

SD card size is also a big player. Try putting your files onto a smaller FAT32 formatted SD card or put them into a sub-directory (not the root directory) on the SD card.

1 Like

Hi All, thanks for your replies so far.

Lets start with SD card issues.

When I put the SD card in the slot the display states that the SD card is inserted and shows the SD Card image.

When I go into the menu, the bottom option says No SD Card Inserted, when you go into that option you just get Return to Main Menu and the Directory Level icon.

So now what have a I tried

Tried 16GB Card with and without Subfolder - Nothing shows

Tried 2 x 8GB Cards again with and without folder and exactly the same issue

They have all been re-format as FAT32

Any more thoughts


Make sure they are .gcode files, when it shows a card is inserted, reboot the board. If that doesn’t work pull it out a tiny tiny bit and see if it catches it.

Hi there.

Ok I have managed to solve the issue with connecting to the laptop and using repetier. It was the baud rate, in fact it was set low, after setting it to 250000 all works fine.

Just the SD card still playing now.

At least I can now begin to play with the machine


Hopefully this will be a thread that I can hop on and maybe see what’s going on with mine. As mentioned before I am so unfamiliar with the pi deal that I wanna be able to just use the post processor and drop g code onto a sd card or usb and load the code and go.
However my desk top I ordered a usb to sd card reader/writer.
So this morning I made a simple ring in fusion 360 and used flyfishers (post processor) and was able to generate g code for that ring.
I simply took the file from word pad and exported it to my usb.
Then took the lap top and transferred that file to a 16 gb sd card and formatted it to the fat32. Via before dropping the file from usb to the card.
Then ejected it from the lap top and brought out to the controller and put it in while the board was off. Powered it up and on the bottom instead of no sd as it said before it says change media ???

Am I doing this process wrong and if so any good threads to correct it?
As mentioned sure the pi is easier via all that but I don’t have the knowledge on that stuff to support messing with it.
Just wanna be able to use the router

Another thing I thought of after the fact is the usb cord was still plugged in so powered down and then unplugged it

Then powered back up and went down after homing the machine and I see below change media > it says print from media > clicked that and it goes to next screen that just says main


Do you just create a subdirectory folder within the sd card and put g code files in there ?

You can create a sub-directory, but it is not necessary. The files in the root directory will appear. The display/Marlin is seeing the card, just not displaying any files. The most common reason, as mention above, is that you have the wrong file extension on the files. It must .gcode. Can you show us the contents of the card in Windows?

1 Like

I can I just looked at the usb file. It was saved 1001.gcode I’ll get a pic in a minute and show ya.
It should normally show the code there on that display? Would there be any other connections to look for on the board as he was running this via pi >octoprint before

Here is the note pad file from the desk top

Here is the Sd card E:

The files on the card look fine. Here are some failure points. Not sure what ones would give this behavior.

  • Size of the SD card. I know that larger capacity SD cards have issues. I use cards in the 2GB to 8GB range.
  • Bad SD card reader in the display…you can test a replacement for $15.
  • Bad connection between display and control board. Look for bent pens and cables that are not seated. Swap the two cables to see if the behavior changes.

The card reader on my 3D printer has issues. I have to sometimes insert and remove the card a couple of times to get the printer to read the card. I keep thinking I’ll have to replace the display, but the problem is not getting any worse.

This is a brand new San disk 16gb and formatted it fat32.

If the Sd card reader was bad wouldn’t it not pick it up maybe ? When it was inserted does it matter if you insert the card while the display is on or off

On my 3D printer with the SD reader going bad, the card is found but the files are not listed. The display being on or off does not matter. I do it both ways with my MPCNC. I know someone mentioned it above, but the card must be formatted FAT32.

Man this thing is stressful I ain’t gonna lie.
So I reformatted another San disk card and created a sub file. Added it in the sd card. Made sure it had the .gcode and added the program.
Put it in the back of the display.
Here’s what I see.
Another thing how does one change out the reader without the whole board being replaced?
Wish it was easier than this to load code

Try the test crown premade gcode. That has to work.

Try it with an empty folder next to it.

Try it inside a folder in the main folder. Don’t use spaces in the folder name.

It is a very simple file system reader. I wouldn’t be surprised if just 1001 is the problem. Change it to carve.gcode and see if that works better.

Just spit balling here, not sure what the issue is. But there is some goofy thing that will be easy to work around once you figure it out.

I hope so as I was super stoked when I got this based on the size and capabilities it would have. However it’s led to bashing my head against the wall. Luckily I’m hopeful with you guys that understands these much more than I.
Thanks. I’ll see if that’ll help