SKR PRO V1.2 with TFT35-E3 V3.0.1 Incomplete Functions

I am near completion of my Lowrider V3 with SKR PRO V1.2 and TFT35 E3 V3. I originally started this build with a smoothieboard that I acquired a while back to upgrade a laser cutter, the smoothieboard never made it out of the box. The smoothieboard wasn’t making me happy so, I purchased the afore mentioned hardware from BTT (V1 did not have them in stock at the time I wanted to order). I have the new electronics installed and have been able to overcome all challenges so far by reading info on the V1 Engineering site, YouTube etc. I like to believe that in most cases I can trouble shoot my way through these issues by using my head and the experience of those that have more experience than I do - [read first then ask]. After reading posts in this forum I have been very impressed with the volume, quality, quick responses and clarity of the answers to questions - great place to be. I feel like there is a group of inteligent people here that I want to be part of. Hope I don’t embarrass myself. . .

Here is what I am working with:

-SKR PRO V1.2 (removed the plugs on connectors for stepper motors and end stops. Leds are on for 3.3V, 5V and 12V.

-2209 drivers (bent the correct pin on drivers)

-Dual end stops

-TFT35-E3 V3.0.1

-12 VDC connected to Power and Motor Power on the SKR PRO from a 20A 0 - 24 VDC power supply connected with proper grounds. Jumper connected between IN and VCC on J2.

Here is what works:

-All connections

-All end stops

-I have flashed/updated the firmware on both BTT boards to current firmware from V1 for the CNC Lowrider build (downloaded from GitHub with links found on V1’s site.

-I have tested basic movement, homing, sending gcodes and getting an expected response with usb cable connection to ponterface successfully.

Where the rubber is not meeting the road:

-I have not been able to communicate with the SKR PRO via the touchscreen using the terminal [nothing in return when I send M119 for example]

-I have not been able to get any movement from any axis for any distance from the touchscreen

-the screen displays ‘No Printer Attached!’ and has since the very first time I powered up [before and after the first firmware update to V1’s build]

*However, I am able to move X Y Z in both directions and home X Y Z from the touchscreen using Marlin mode.

I have checked wiring/connections many times. So, Today I re-flashed the firmware for the TFT35 because I felt that the problem must be the firmware or the TFT35 board (especially with the Marlin mode working and successful testing through ponterface). I watched the entire process and had the following errors [two attempts]- see pictures:

Update screen progress messages:
Updating Icons

Updating Configuration...

I looked in the \TFT35\bmp\ directory on my computer for the PID.bmp file, it was not there:

Files on SD card after update:

Outside of dates on the files I followed this instruction from V1’s site:

I have no Idea if this happened the first time I updated the firmware because I did not watch the entire process like I did today.
I downloaded the current zip file and used that today to attempt my fix described here. After these errors and without any intervention from me the process completed and now I’m back to where I stared the day - what worked before the update, still works and what didn’t work, still doesn’t.

Additional info that may be helpful:
Link used for firmware:

Info Screen after update:
System Unknown system

Post boot up screen:
No printer attached!

Your time and help is greatly appreciated!

Could be similar to, or different from, issues on this thread:

I’m not the pro, rather @jeffeb3 and others are.

Some things to check: baud rates must match. Wiring.

In the event it might help, here’s my TFT firmware that I’ve been asked for several times and which I have shared: As posted over there:

I have received several prior requests for my TFT firmware, and I had forgotten that late last year I uploaded it to my website to make it easier to share. Here’s the link!

Thank you. I will look at this and let you know what I discover.

1 Like

I have just been through this and that is definatly a baudrate issue.
Check the setting on the actual TFT, under settings/ info (see the comment on my thread form Jeff) and that will give you the true baudrate, as @jeffeb3 says the default is 250000.

Once I got that sorted, the no printer message went away.

But remember i was playing with an unsupported board, so i was dicking with the actual firmware file and rebuilding them.

Thank you, very much appreciate the info.

Screenshot 2023-03-09 095822
You have the GD version of the screen, my default firmware only has the file for the non-GD screen in the zip package but it is there in the repo the Zip comes from.

I will need to test it but I think I can package them both and make a new zip. This has happened a few times now.

I will test it on a few hours. If the zip is not updated by this evening please remind me.


Here you go, Release 3/9/23 Roll up · V1EngineeringInc/BIGTREETECH-TouchScreenFirmware · GitHub Unzip the file and dump all the files on an SD card and reboot your screen. The right files will be automatically selected.

1 Like

Thank you!
However, I did as you instructed:

  • unzipped file
  • copied them all to my SD card and ran the update.

The Post update screen still shows ‘GD’ in the name:


  • I recopied all the files to my SD and ran the update again.
    Here is the result:

I have the same results attempting to move any axis or use the terminal.

Sorry, I failed to realize I did not tell you that on the 2nd attempt that I deleted all files with ‘GD’ in the name.

It always will because it has a GD processor, that is to be expected.

Nope, unzip a fresh set of files and do it again. It needs the GD file, that was the whole point of me updating the files.

That means you have other issues. The board is set to 250000 baud, and my firmware should be as well. If it is not talking, I can only suspect you are not plugged in correctly.

1 Like

Make sure to include this file to try and wipe your screen all the way. Unzip it first. (152 Bytes)

Your screen should now ask you to calibrate it after flashing, it should also go through three distinct phases of flashing. Small font file list flashing, large font file flashing, then pictures coming through. There should be no red warnings.

If you are still having issues we need to see how you have this all plugged in.

1 Like

Followed your instructions.

  • The screen did have me calibrate it after flashing. [no issues doing that]
  • Three distinct phases were observed as you describe without exception or warnings.
  • Still have the same issues [terminal does not work & can’t move any axis].

I’m attaching pics so that you can see what I have.



Connection Pics:


Thank you for your time!

That leaves your SKR pro. Did you flash it?

You can test it using the USB cable and something like repetier host.

(it is odd that it has feb15 2023 as the build date…That is not my date. For now I will ignore that part)

1 Like

Yes I did flash it with Firmware from links at V1 Engineering’s site.

I have tested it with Pronterface, I am able to connect and move all motors, home all axis and send gcode with expected results returned.

It is actually showing connected. If it had an issue it would say it here.

So that comes back to the odd date. Dig through the menus on the screen and verify the baudrate is 250000

1 Like

Actually, that is not my TFT firmware, I disabled the status box in the middle

Your screen is still not flashing right. Try it a few more times. I had a sticky one before. Try just the bin, just the ini, then the whole package,.

And I use different icons.

1 Like

We used to have trouble flashing it if the gray cables were attached. You can try disconnecting those.

The middle status still says no printer attached. But we do usually see that in red along the top. I like the guess that the skr pro isn’t flashed with v1 firmware.

1 Like

I have flashed both the SKR PRO and the TFT35 multiple times - today. :white_check_mark:

Does this confirm one way or the other that the SKR PRO has/has not been updated as you expected?
Here is the output from Pronterface for the firmware:

FIRMWARE_NAME:Marlin 515DL 2.1.1 (Sep 25 2022 17:41:34) PROTOCOL_VERSION:1.0 MACHINE_TYPE:V1CNC 515DL EXTRUDER_COUNT:0 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff

Github is/was my source: [from link on V1Enineering ]

1 Like

Yep. Looks good.

1 Like