Screen lights up - no text

I’ve just finished building my MPCNC.
Rambo 1.4
Bigtree Tech Smart Controller
All wiring, motors, Rambo, and screen purchased from V1 Engineering.

The screen lights up when plugged in as shown, but I can’t get any text to show up. I’ve tried all the different plug arrangements.

I’ve reviewed this thread:
Rambo 1.4 and LCD issues - Mostly Printed CNC - MPCNC / Troubleshooting - V1 Engineering Forum

Is it possible my Rambo did not get flashed prior to shipping? I bought it earlier this year (2021), maybe 3 months ago?

The potentiometer right above your thumb in that picture adjusts the screen contrast, try giving it a twiddle.

1 Like

Have you checked the orientation of the connectors? They must be flipped the right way. I’ve marked mine, I always tended to get them wrong…


The potentiometer doesn’t seem to make a difference…I mean, I can see a difference in he screen, but still no text.

I’ve tried flipping connectors around, flipping cables around, and even switching the cables. Nothing seems to matter,

I was hesitant to reflash until I knew for sure it wasn’t flashed initially, in case I do it wrong. Is there any way to know if it has and software on it?

In the only picture where I can see power, the power is disconnected. You need 12V for the rambo to do anything.

You can connect with repetier host or cncjs to send and receive gcode from a computer. If you can do that, then sending M115 will respond with a version string and it will say Ryan, V1Engineering and v510 or v513. Connect at 250k, not 115200.

Your gray cables are wrong. On the screen they are facing different ways (flip one to get the connects the same), and on the board they are facing the same way. The instructions show a shot of the board and the gray cables carefully laid out so you can follow the orientation of them.

1 Like

Thank you to everyone who offered suggestions. I apologize for the delay in responding.
I think I’ve tried every plug orientation possible and still all I get is the lit-up blue screen. Ryan, I’ve taken a picture of the plug orientation combination I think you’re suggesting.
The red stripes are always on the left. I’m orienting the fuse on the top of the Rambo and the EXP connectors at the top of the LCD.

Cable 1 goes (red wire tie) from the lower 10 pin connector (unshrouded) on the Rambo to the EXP1 on the LCD.
Cable 2 (black wire tie) goes from the upper 10 pin connector on the Rambo to the EXP2 on the LCD.

Failure points are the display, the cable, the control board, and the firmware.

In each configuration you tried, did you run the potentiometer up and down as suggested by Dreyfus? With power connected to the board and USB cabled up to the computer, can you talk to your board using Repetier-Host or something similar? You can send M115 to query the board. Setup instruction here. Note the 250000 baud rate, which is a common reason that Repetier-Host does not connect to the control board. If you have a couple of Dupont connectors or similar, you can check the continuity in each line of the cable (though I don’t remember seeing a bad continuity in a display cable come across the forum since I’ve been following).

Your wires are correct, up out of the screen means down/away from the power ports on the Rambo.

That means your board is probably not flashed. You can check by connecting over usb to the rambo with repetier host like Robert is suggesting and connecting. it will display all sorts of info at the bottom.

The boards do come with firmware on them so it should tell you something. but only our firmware enables the LCD.

To the best of my knowledge all boards have left here flashed, if it was opened it should have been flashed, if not, no big deal there are several ways to flash…and there has been a recent update anyway.

Screen shot from Repetier after the M115 command. It seems to connect (the connect icon in the upper left change to disconnect and I get the rest of the message scrolling), but it doesn’t recognize that command, I think?

I’ve now downloaded and installed XLoader so I can install the firmware on the board. I downloaded the firmware labeled V1CNC_Rambo from this page:
Marlin Firmware - V1 Engineering Documentation

and now I have this. Not sure how long I shoudl expect it to take to upload the firmware. I left all the defaults in the menus the same except for the file loacation. Can I change the baud rate here too? It shows “uploading” so I take that to mean it’s connected and working, but just slowly.

1 Like

Cc01 isn’t the right device. Look at step 4 here: Xloader

1 Like

It is not connected. The icon changes no matter what. Are you set to fully auto in the settings to connect, the stock board would be at 115500 (or something similar) and our firmware is at 250000 buad rate.

Make sure the board is powered as well as the USB when you want to connect, and or, flash.

I see what Jeffeb3 is saying, but I only have two options for the device:
When I try on CR03 (not sure what this device is) it indicates it is uploading, but never finishes. I have to start task manager to force close XLoader.

If it’s not recognizing the device as you showed in that link, then I think that’s the first problem I need to solve. I think that means my Win10 PC is not recognizing the device or doesn’t have a driver for it. Right?

This was reported before. I think there is a file missing or something. I don’t use windows, but I am going to try to invoke the knowledge of @robertbu.

I read the post and did not pick up that it was something we’ve seen before. The issue is that one of two places that XLoader can be downloaded from does not have a fully populated devices.txt file. If it is this problem: find the XLoader directory, open devices.txt with a text editor (notepad will work), and add the following line:


Hot dawg!!! that was it.
Seems like this was a series of things.

  1. ME! This is all new to me so I wasn’t sure what right looked like on several things.
  2. Somehow my Rambo made it to me without being flashed.
  3. I downloaded the Xloader with the devices.txt file that did not include the line that it should.

Thank you to everyone who contributed. I’m sure I will have more questions, but at least I’m able to move past this hurdle now.


Awesome, sorry it was a rough start but you were a great sport about it and hopefully a bit more comfortable with it all.

I am trying to find out how rambo’s get out not flashed. I am looking into that. I flashed and verify them…well most of them apparently.

1 Like

No worries. I’d rather deal with someone who makes a few mistakes, but owns them and tries to make them right than someone who is nearly perfect but can’t admit they might ever be wrong.

I sincerely appreciate the help from you and others who posted in this thread.


Haven’t really done anything with the Mpcnc yet but I plugged it in a couple days ago and it had the same problem …the screen lit up, but no text or graphics. I reflashed it again and it came right up.
I thought once it was flashed, it stayed flashed even if power was removed. Am I wrong?
I wanted you to know because you accepted responsibility for letting one get shipped out without getting flashed. Maybe you did flash it, but it lost it between the time you had it and the time I powered it for the first time. My point is that this is a different technical problem, not a logistical SNAFU.