Repetier-Host V2.2.4 gcode visualization bug

Hi all, I followed the instructions on EstlCAM Setup - V1 Engineering Documentation. Some of the settings in Estlcam V11 are different, but I followed the instructions as close I as I can. However, when I open the gcode generated by Estlcam V11 in Repetier-Host, there are many extra curved lines in it (please refer to the attached picture). The gcode downloaded directly from that link is correct. I also tried to load a simple DXF file such as a rectangle and the generated gcode is also correct. Did I miss something here? Thanks!

1 Like

you aren’t the only one who has that problem with Repetier, but usually the machine itself is fine.



Thanks. It looks good in ncviewer. Do you use Repetier, or is there a better software that you use to run the gcode?

I do not use Repetier, I’ve just seen that before.

I run my CNC machines headless ising their SD cards. My machines have a web interface to set up the jobs and upload gcode files.

In the past I’ve used Octoprint, or cnc.js


Just to be clear, Repetier-Host does not run g-code. For the most part all it is doing is sending g-code to your control board created in EstlCAM. It can send additional g-code commands depending on your settings. For example, if you have the feature checked, it will send a g-code command after your file is finished sending to turn the steppers off.

The point is that the wild display you see on the Repetier-Host screen in no way impacts what actually gets cut. In addition, this problem is a recent one that I fully expect will be fixed in the next update of Repetier-Host.


Thanks for the info. I downgraded to version 2.2.2 and it doesn’t have this bug.


Weird, must be an arcs things?

Yeah. It has come up a few times. I think Repetier is drawing arcs the wrong way around (G2 vs G3, clockwise vs anticlockwise).


Ive got the same issues. What did youvdo to fix this. Due to the circles being outside my build it will not even cut. The dileni got off the v1 forum for the crown test worked fine but when i did the crown it gave these same circles and wouldnt run it. My first cut i did the other day had snall circles but mothing that went outside the bounds so it was able to cut it.

Id really like to know what you did to fix. Sounds like you went to a different version of repetier host. I cannot use my sd card currently or I would print from there.

Ive thought about trying to use pronterface which is something i use on my cnc machines.

I downgraded to v2.2.2 and it doesn’t have this problem.


I just removed the 02/03 thing as a selection. In the setup, CNC Program you will see "Use arc commands G02/G03 and unselect it.

1 Like