RAMBo marlin ino problem

Hi I need some help from anyone that can help I am new to cnc and programming I am building a mpcnc and trying to program Rambo board (not mini) I have managed to program up until I need to install the marlin ino but when I try and open it in Arduino ide there don’t seem to be anything there if you hit upload you get progress bar and then you get error unable to compile if anyone can help me with this you would make me very happy spent all weekend trying to sort it out. Thank you to all

What’s the error?

The firmware I downloaded from GitHub is supposed to be preconfigured but when you try to open the marlin.ino file in the Arduino ide there is nothing there

  1. Did you buy the board from Ryan? If so, it is already flashed. No need to mess with arduino.

  2. Someone just had a similar issue because they had not extracted the zip.

No I didn’t I have extracted all files

Also I saw something about opening the marlin ino file in not pad to see if anything was there but still nothing

If Marlin.ino is empty, then you did something wrong when downloading it. What version did you download?

I’m using Rambo with lcd no end stops the file is there but the error I get is unable to compile for Rambo board

Can you post a screen shot of arduino after you try to upload?

Will do at work at the minute when I get the error it says too many library’s for u8gib.h and sul.h I tried deleting everything uninstall Arduino and reinstall but still get same error computers and programming is not my thing I try and learn but still don’t make sense

ok just figured out how to screenshot

ok this is the error message I am getting now I tried using the other Rambo firmware from GitHub and all do the same thing so I down loaded marlin from the main site clicked verify and it compiled so tried mpcnc firmware from GitHub again and still getting same error

Screenshot the very first error, scroll all the way up. Anything after that doesn’t say much

It looks like you don’t have u8glib installed. There are a couple with similar names, so follow the instructions on the marlin firmware page of the docs.

ok u8glib is installed when I downloaded marlin from marlin site it compiled first time I also tried three different firmware from GitHub for the mpcnc and I get same error this is screenshot from the top

ok turned on verbose and when trying to verify it comes out with this don’t know if this help sort it out but ill put it on anyway

I think we’re still missing the top few lines. Could you try the ‘Copy error messages’ button, and paste them here please?

Would it be possible for someone else to try the firmware in Arduino because it seems strange that three of the rambo firmwares don’t work but if I install marlin straight from marlin website it verifies and compiled first time

Sorry if I am being a pain but I looked through the configuration h file yesterday and I didn’t see any u8glib in the text should it be in there

The default firmware has the LCD off. So it will compile without u8glib.

Ryan tests it before publishing it.