Off the wall issue

After finishing a client’s piece this evening, I set my machine to rest, just as I have always done. I homed the machine, went to load the next project. And bam, my screen stopped working. I’m using the tft 28, which has worked with no issues as at all. All the functions are still present, menus I’m still able to scroll through, I am just unable to move the machine. Anyone want to take a shot at this one ?

You’ve tried the obvious turning it off and back on again? I have found microcontrollers just glitch sometimes and need a hard reset to recover.

Sure have. Even tried reinstalling the firmware.

Is it possible the cable came loose? Not enough to lose power but enough to block communication.

Replaced the cable. Same outcome.

Can you hook up a computer via usb and try repeater host?

Edit. I am trying to isolate the problem to the LCD or the board/motor.

Certainly. Repeater works just fine. Its rather slower moving then it used too, but controls just fine.

1 Like

Maybe a shock broke something. What kind of controller is it? It talks over uart, right? Maybe connect another uart to sneak a peek and see what is happening on the line?

I switched boards as well. Both Skr 1.3’s are doing the same thing. With that being said, I also traded tft’s as well. Same results.

I can still home with rep, which is fine, but I really enjoyed having my handy screen by my side.

Are there any commonality between the setups. Something is odd.

Something is very odd indeed. Everything is the same. (component wise)

Well now this is odd. My heater shut off in the shop and now I can hear all the motors, making a very light sting/humming sound.

That’s normal. They do that with A4988/DRV8825 drivers when the motors are engaged.


And now a kill operation…

Not sure how a nut got underneath the board, but… it did… Now the fun part begins. . What did it kill ?

Aww, nuts. You might have gotten lucky and just shorted something out that kept it from working, as opposed to making it never work again.

I was hoping the same thing, but normally my position was displaying on my screen and now, all it does is disappear. :frowning: I’m fairly sure something has died.

which board?