"No Printer attached" and endstops (maybe) not working MPCNC

Touch screen of TFT35

TMC2209 Drivers
SKR PRO V1.2 board
(I didnt get these from the V1 store)

I’ve been looking through the forums to see if I can find an answer for my problem, but I’m having trouble solving my issue.

-UART speed set to 250.000
-I had trouble wiring the TFT35 screen, at first the screen send some beeps, then re-started, until I figured out how the pins worked (before flashing the firmware on anything)
-Marlin mode is working all fine, endstops doesn’t seem to work (unless this behavior is intended, but homing doesn’t send to the supposed 0,0, where the End stops are), the touchscreen works, but sends the “printer not found”
(when pressing an endstop, the light goes out on the appropriate [I guess] place in the board, otherwise I have no idea if the endstops are workings properly)

(Marlin works, touchscreen mode sends “No printer attached”)

I flashed the board with the “V1CNC_SkrPro_Dual_2209-2.1.1” as suggested and the screen with the “BIGTREE_TFT35_V3.0_E3.27.x”, both files changed the extension signaling they where flashed successfully, I disconnected the gray cables from the screen while flashing the board, and when flashing the screen it got updated, I guess correctly…

I might start by re-flashing the screen, then the board, because there is something fishy going around…

Have you verified that the grey cables are connected properly (they cross over between the screen and the SKR board)

I did because I read it was a fix somewhere in the forum, but I’ll try again now just to be sure.

(re-flashed the firmware on both the screen and the board, same result

just switched the board position of the grey cables, and the screen bleeps in black and then it shuts down.

so I assume the og position was right…, right?

(my screen also has EXP3 unused just like the pic)

found a topic from 2023 that had this as an answer in Help with board connection

No Printer Attached is the error message that the TFT gives put when its queries on the serial port are not answered in the expected format.

This can stem from several problems.

  1. The black serial connection cable is incorrectly installed. This is a 5 pin cable and must attach to the correct UART on the screen PCB and on the SKR Pro board in the correct places (see docs.) One simplistic and incomplete test is to see if the reset button on the TFT resets the SKR. This is the 5th wire on the black ribbon cable that is separate from the other main 4.
  2. The connection speed is incorrect. This is determined on the TFT side in the config file. It is determined on the SKR Pro in the Marlin configuration.h file. V1 firmware sets this to 250000 baud.
  3. Firmware is incorrect. The V1 firmware enables the TFT serial UART in the Marlin cinfiguration, and the TFT comfiguration file.must also enable that serial communication. Note that Marlin Mode on the TFT does nkt even need this connected in order to work. Also only the matching Marlin firmware will respond in a manner that the TFT will tecognize. For example, RepRap Firmware can be installed on the SKR Pro, but will end up with the “No Printer Attached” error because the reaponse format for the status query is different.

if we go with this answer, the proper behavior of of my machine would go with 3, it might be the TFT screen firmware

(I’ve tried multiple connection ways and my current one is the only one that works, and Marlin mode works as well, touchscreen gives the No printer attached problem)

edit: thought it was firmware, decided to flash the screen with BigTree latest firmware, still same problem.

Pics on connection, so far I can’t seem to think there is something wrong in the connections…, the RESET button on the board resets the screen, and the board is clearly the TFT connection.

edit 2:

found this post as well

tried Ryan suggested fix

Unplug everything except power and the black TFT cable (unplug the gray ones). Try it again. These files have been used and tested for a very long time so it is not the file. we need to figure out why yours will not use it.

still same problem, I’ll keep doing research and figuring how what’s the issue here, I really don’t want to make a custom firmware or buy another board “just in case” the board or the screen is defective…

There is a really solid chance your screen is bad. I have had plenty that one side works and the other does not, it is one of the things I actually test every single screen for.

If you flashed my skr pro firmware and used all of my TFT files it should work. The tft files should be universal, unzip the folder put every file and folder on your SD and at that point you said you tried all the ports on the TFT for the black cable. I would return or exchange it.

it might be, I’ve tried quite a few fixes (as you saw in the post)

I even tried flashing the latest official firmware just in case I could get it work, but bad luck

I’ll contact the seller and see if I can get a return or something.

That is a bummer. Hope the return is quick and easy for you.

No expert, but the screen looks like my old one that was claimed to be tft35, but looks different from the standard tft35 one most people are using. When I tried it before with that screen i had to use a different firmware, was a few years ago now so don’t quite remember what I had to do to get it working. I think it was a difference of tft3.5 vs tft35. Please correct me anyone if I am wrong

mine is the [BIGTREETECH_GD_TFT35_V3.0] (as the system information says, it actually doesn’t say exactly on the shop place), the firmware it uses is [BIGTREE_GD_TFT35_V2.0.27.x.bin], from what I’ve read, you can just copy and paste the entire firmware section into the SD card and the hardware will detect the firmware it should get…, and I’ve already flashed it like that.

1 Like

Right you should just be able copy and paste the firmware on the SD, but what I’m saying is the screen isn’t a TFT35 it’s a 3.5. I’m not sure if there is a huge difference in firmware, would need someone much smarter than me to get some input. As for what the firmware is saying, is that just what’s flashed on the board isn’t it, opposed to what it actually is? I’d look into it a bit more just currently not at home

The V1 Firmware should work for all BTT TFT screens.

1 Like

got an answer from the seller and gave me some feedback on how to fix the screen,

Regarding the problem that the display shows that the printer is not connected. You can check these three items:

  1. Make sure that the wiring of the touch mode is correct and connected;
  2. Make sure that the firmware has opened the TFT serial port, which needs to be set to 1;
  3. Please make sure that the baud rate of the display is consistent with the baud rate of the motherboard firmware.
    The firmware baud rate of the motherboard is 115200, and the baud rate of the display needs to be 115200.
    If it is 250,000, the baud rate of the display also needs to be set to 250,000.

as we’ve discussed in this thread (and other threads on v1 forums),.
1.- might be, will cover it later on
2.- V1 firmware seems to properly work since it’s tested, and I’ve flashed the firmware correctly (extension changes on the SD card)
3.- baud rate is also setup by the V1 firmware, even then, I can check and it’s set up to 250000 so it’s correct



and in fact, the screen worked!!!, the screen recognized the board! (this means, no baud rate, no port problem, cables are in the right place, maybe it was the cables connection?)

-tested the black cable continuity, it’s perfect, no issue there

tried moving the Axis in touchscreen mode, and THIS HAPPENS

-the screen flashes “no printer attached” message
-me moving the X axis to test, and suddenly the screen glitches with the previous message and starts to loop the same inputs over and over (move the X axis 10mm [+] and [-] over and over)

this rant is mostly to check on anyone who might have seen this, and also to vent a bit and have a laugh, but I’m 90% with Ryan that the screen is faulty (10% is that I’m incredibly stupid and I missed something obvious)

OH, AND MARLIN MODE STOPPED WORKING (gray cables, something that has always worked from the start, even without firmware)

(10% is that I’m incredibly stupid and I missed something obvious)


I either missread the labels on my screen board or I was misslead by the diagram since my tft35 isn’t the exact same as the one from the documentation…

I wired them as EXP 1, EXP2 and EXP3 (in that order, EXP3 wasn’t used)

and then I realized my board where actually EXP3, EXP2 and EXP1 instead

so I had EXP3 wired to EXP1…

I feel very dumb, but I have a working screen!

now to the next step of the project, to figure out how to “home” my machine and make use of the endstops.


I’m glad it’s all working for you!