motors not responding


can you or a member transcribe this for me The last line is in question:

Printer is now online.
echo:Marlin bugfix-2.0.x
echo: Last Updated: 2018-01-20 | Author: (none, default config)
echo:Compiled: Nov 19 2018
echo: Free Memory: 3788 PlannerBufferBytes: 1296
echo:Hardcoded Default Settings Loaded
echo: G21 ; Units in mm (mm)
echo: M149 C ; Units in Celsius
echo:Filament settings: Disabled
echo: M200 D3.00
echo: M200 D0
echo:Steps per unit:
echo: M92 X100.00 Y100.00 Z400.00 E100.00
echo:Maximum feedrates (units/s):
echo: M203 X120.00 Y120.00 Z30.00 E25.00
echo:Maximum Acceleration (units/s2):
echo: M201 X400 Y400 Z400 E8000
echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
echo: M204 P400.00 R3000.00 T400.00
echo:Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> X<max_x_jerk> Y<max_y_jerk> Z<max_z_jerk> E<max_e_jerk>
echo: M205 B20000 S0.00 T0.00 X3.00 Y3.00 Z0.20 E5.00
echo:Home offset:
echo: M206 X0.00 Y0.00 Z0.00
echo:Material heatup parameters:
echo: M145 S0 H196 B92 F0
echo: M145 S1 H240 B110 F0
echo:PID settings:
echo: M301 P17.98 I0.98 D83.62
echo:SD card ok
>>> m119
Reporting endstop status
x_min: open
y_min: open
z_min: open
>>> m119
Reporting endstop status
x_min: open
z_min: open
echo:busy: processing

I just received my board from v1 yesterday. during set up and testing everything seems fine but the steppers are not responding.

while using ponterface i tried moving the z axis and got the the last line in the code (busy processing)

i have no clue what it is trying to tell me


Elmer P.

Can you use repetier host for testing?

Follow this page and tell me where things go wrong,


I have no idea what defaults are for pronterface or if it has even been update in a very long time. I will more easily be able to help if you stick with the suggested path until we get you going.


Also some details on what you have would help, Board, steppers ect? Pictures also tell me more than you could imagine.

ok i tried repetier no. change. 1 command waiting when i try z move. i have tronxy nema 17 steppers, a full size rambo with discount lcd, a 12v 360w psu. the board and motor wire i purchased from v1

the steppers and psu i got from bangood.

the endstops register the lcd has flashing ? at the axis locations see pics

i’m lost thanks for the help on a holiday

Does it move on all three axis okay with the LCD controls?

Did you install arduino and it’s drivers before Repetier?

You need more power, you only have the drivers plugged in not the control board.



so your saying i need 12v to input c to move the steppers?


Just like the picture. one port is for the board logics, the other is for the stepper drivers, and the third is for the mosfets.

well i added 12v to the input c still no power to the motors and ? on the lcd repetier still saying 1 command waiting im going to do a reboot of my pc and a cold start on the board just to see what happens. i did a continuity check on the small fuses i got a tone

thanks again

ok is it possible that the steppers handle power and signal differently than a typical nema 17 stepper weird if it did

Does it work from the LCD controls?

no lcd control it does show how much you intended to move it with a ? but no resistance on the motors

The is nothing abnormal about the question marks.

Let me see how your end stops are wired.

the endstop connections:

Pull the fuses out of the board and check for continuity. Everything seems to be correct and the LCD should work if you try to move in the positive direction or select home all.

i did do some testing with these motors on an makerbase sbase untill it stopped flashing for some reason and i did get motor response during those test if that helps

ok i hit all home and things can to life but i have to change some wire i didn’t get movement but it tried.

thank you Ryan

Bless You and Your on this holiday season

on further in investigation of motors it seems x1 and y1 are responding to the home axis command but not x2 or y2 and if i switch the leads around i can make the other motor turn i have not got a response from z at all.

i believe i need to re-flash the board. i have yet to successfully configure a board. i have ide 1.9 installed and a fresh copy of marlin mpcnc downloaded. is this the next logical move

i just tried to home z and i feel a faint vibration from the motor. it appears there is not enough strength to turn the lead screw. they are 76 oz steppers. i checked for binding and it turns easy enough

im doing a rough look over marlin 2.0 and in config. adv. h. i see this:

//#define PWM_MOTOR_CURRENT { 900, 900, 900 } // Values in milliamps
#define DIGIPOT_MOTOR_CURRENT { 95, 95, 95, 95, 95, 95 } // Values 0-255 (RAMBO 135 = ~0.75A, 185 = ~1A)
//#define DAC_MOTOR_CURRENT_DEFAULT { 70, 80, 90, 80 } // Default drive percent - X, Y, Z, E axis

i don’t know what is or is not on the board but these values of 95 on motor current look low should i assume 170 to 180 is more to where i want to be on current?

i don’t have a clue i guess it’s time to do the heavy reading.

thanks for any help y’all can give me