motors not responding

I would start w/o endstop firmware first to ensure, that endstop has no affect.

have you parallel or serial wiring of the steppers? Have you checked/measured your wiring harness?

I’m wired in parallel, the endstops are seen by the firmware . I got movement on the z axis i found some slight binding, i replaced the pineapple couppler for a metal one that helped. the motor is just not strong enough to lift the carrier.

i will watch the old guy coding video to see what some of the settings should be, before messing with the code to much.

thanks y’all

Arduino: 1.9.0-beta (Windows 8.1), Board: “RAMBo”

Bootloader file specified but missing: C:\Users\epark_000\Downloads\arduino 1.9\arduino-PR-beta1.9-BUILD-88\hardware\rambo\avr\bootloaders\stk500boot_v2_mega2560.hex
Sketch uses 108922 bytes (42%) of program storage space. Maximum is 258048 bytes.
Global variables use 4426 bytes of dynamic memory.
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
An error occurred while uploading the sketch

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

well i tried compiling a hex file to no luck. something about a bootloader missing.

any ideas anyone has a duel endstop hex file to share

 

wrong com port…

Where are you getting a hex file? My firmware should work.

sorry Ryan,

though I’m not 100 percent sure but the board was flashed (i believe) with motors in series and i needed parallel. so in my attempts to solve the problem i put a bad file on the board. i can’t seen to be able to compile firmware from the arduino 1.9 or platformio for rambo using any files.

i’m sorry again, my ignorance is getting in the way of a sweet build. i could not get x2 and y2 to respond to inputs. x1 and y1 did fine.

anyways your firmware install is dead and i’m stuck.

i saw where you said there would be little help for duel end stops but i need help

On this page it gives a step by step walk through on flashing the board with a windows machine.

https://www.v1engineering.com/marlin-firmware/

At what point do you run into issues?

For a full sized Rambo you should be using this file, unzipped, and arduino 1.9.

well right after last night when i did the home test and got my first jerk out of the machine and started looking closer at the motors did i see z was just a very light twitch and only x1 and y1 where responding and lightly at that.

so looking at my 3d printer and the strength of the motors i have on it. i deduced that maybe i needed more volts so i needed to recompile a new firmware and i jacked it up.

so i downloaded the duel endstop file off of v1 with lcd and parallel motors. and nothing i saw or tried would let me compile with out the rambo addons and they wouldn’t get recognized properly in ide 1.9 hardware file.

Like I said Follow my instructions, including the addons, that you 100% have to have. Tell me where it does not work for you.

ok it’s back, i swear to god i did this a thousand times and the addons wouldn’t go in… wooooow!!!

thank you Ryan let me do some quick checks

1 Like

ok some quick checks all axis move i just need too find out why z is sticky. doesn’t want to lift i think it may still be tight for some reason.

so if i want to play around with voltages i shouldn’t have any more compiling problems?

Thanks Some more

Elmer P.

No, everything should work as is, for now change nothing in the firmware.

Lube, adjust, rebuild whatever.

this is what i’m thinking:

#define DIGIPOT_MOTOR_CURRENT { 95, 95, 95, 95, 95, 95 } // Values 0-255 (RAMBO 135 = ~0.75A, 185 = ~1A)

should i be considering bumping up the values: 95 to closer too 180

ok lube adjust and rebuild.

i’ll do thanks