Loosing Z Steps, but only with aluminium

Hi Guys,

you are my last Hope. Sounds like Star Wars lol…
My Z Axis will go down a bit in Aluminium (Wood is fine). Not Straight in 1 Motion. Just a bit. Some Seconds, sometimes after 1-2 minutes later again and again and again.

My Specs:
24V Power Supply from an old 3D Printer gets converted to 12V on the Tillboard
0,8 KW Spindle Watercooled
1,5KW Frequency Converter
Tillboard (from uncle Phil) as Controller with DRV8825 Driver
GX16 Connectors
X and Y Cable is 4x0,75mm² without shielding
Nema 17 59ncm

What i did so far:
Tried other Driver (still 8825)
Tried another Arduino
Changed the Z Stepper Motor to a Longer and Bigger one.
Changed the Cuppler (Wellenkupplung Shaft Coupler D14 D18 Alu starr 3D Druck Modellbau Welle | eBay)
Changed the Cable for Z Motor and Spindle with better one with better shielding (Geschirmte Leitung 809 CY - 4 x 0,75 mm²)
Took the Z Motor out of the Cable Chain and it now hangs from the Ceiling
Tried other Milling bits.
Made sure that the bit fits and doesnt get pulled down.

I really dont know what else i can or should do.
Im so close to packing and selling everything :frowning:
I hope you can help me.


P.S. Sorry for my bad English, im from Germany.

Hey Stefan,
your English is fine, don’t worry. :slight_smile:

If you are using the Tillboard and Estlcam as the controller, like I do, you might want to check the “Schrittpause” and set it to 1. That’s what messed up my inlays before, 0 didn’t work with my drivers.

Thanks for your Tip but it didnt helped.
The opposite is the Case. I couldnt even move the Spindle up.
The Problem even occurs when i just let the spindle run and touch the aluminium with it.
You can barely hear that i touch it and after that it goes down from time to time.
In Wood no Problem.

Just a wild guess, is static maybe contributing? Can you somehow ground work piece and try?

Are you trying to run dust collection, if so can you leave it turned off?

I have no Dust Collection At the Moment.
When i Ground the Aluminium does the Problem get even worst.
The Z Goes down even Faster.

Okay, this is above my understanding of electronics and interference and stuff, sorry. :frowning: Couldn’t do that even in German. :smiley:

Wow. Not sure. I am going to tqke a back seat. Static made sense to me as you said it quits upon touching, but grounding should not have made it faster at all. Do you have any pictures of your set up?

Thx for your Help. I will make you pictures from everything.
It looks a bit rough at the moment because im ripping everything apart in Hope the find my Problem :slight_smile:

Hi Stefan,
I had Problems similar to your’s in the past, my z-axis was moving without g-code to move the z-axis.
This post from @jeffeb3 helped me to find the issue: Z-Axis moving up when in contact with material - #9 by jeffeb3 put a piece of paper on your leadscrew and make a video.
Cheers from Heidelberg :slight_smile: and good luck with your problem solving attempts!

1 Like

i can check that.
But i can see my Cuppler turning when the z goes down.

At 0:44 you can see the step it makes.
The Black wire you see in the Video goes directly to PE.
In the video i touch the Aluminium and after that the Spindel Housing.
When i touch the Spindle, something happens and i dont know why.
I used the 4th Contact on Top of the Spindle to ground it.
I can Check with a multimeter between PE and the Spindle and i have contact.

Sorry for my Shaky Hands.

By doing a search I see we have a few people on here with a Tillboard. I am not so sure about that board. I cannot be of much help. You definitely have something odd going on there.

I think it is a communication issue. Somehow the ground wire is communicating to the board.
(Just my GUESS.) I think you need someone familiar with that board!

Do you have a router or something to try to see if it is the spindle causing the interference?

I also am not sure, but are all tools grounded in Germany?

Sady i have nothing else to test it with.
Normally everything should be grounded in germany with a metall case.
Its Strange that giving the spindle “More” PE does anything…

so I do I.t. for a living. One thing I can think of. The communication between pc and the board, is it away from anything it might get interference from?

The only things that are running when i do this tests are:
The Frequenz converter
My Laptop (tested it with another tablet and a 3. pc)
The Tillboard
The Waterpump
and the 24v power supply.

No. :slightly_smiling_face: Only brown and blue cables as well. It does make sense to ground some things like a spindle though.

I cannot tell, but it looks like the aluminum is on aluminum or metal. Put the part you are machining on something that will insulate it. Rubber, wood, anything non conductive, and does it still do it?

Most of the mpcnc’s have wood as the base.

Sadly its a wood table.
And the Plate its on, is wood too.

Here a pictures of Everything.
I thougt of turn off the Waterpump to see if it maks a difference.
When i put the cable from the pump back in the wallet. The Spindle moves a bit.
I dont know what to do. It doesnt look that great at the moment. Its Just to test.
Some cable changed in testing and soldered back on.
After everything works, it gets in a nice enclosure where no dust or anything can come near it.
And no the chunks from testing are not the Problem. It was before :frowning:
Are my cables not thick enough?
Should i buy new cables and build the clean enclosure before?

I can make a picture how everything is connect in photoshop. maybe i did somethin wrong?

I really need help, please :frowning: