Jackpot cnc wiring

That’s only flipping the homing direction. It won’t have any impact on the machine’s actual sense of direction regarding which way is X-min versus X-max. That’s why I looked up the direction_invert setting. Did you try the direction_invert setting? Or only the positive_direction homing switch?

Consider that there are potentially plausible, legitimate scenarios in which someone wants their machine to not flip direction (not swap X-min and X-max) but just change which side the machine homes to. That (mere homing switch) is not what you need.

I opened the config.yaml file in a text editor and searched for the direction_invert setting, it is not in my config file. I downloaded the lastest config file from github recommended by V1.

Re. the “it homes here” image… Did it home that way before the positive_direction homing switch? Or afterward?

If it was homing to the other side before you did the “positive_direction” homing switch code change, then the axis seems to indeed have its X-min and X-max wired backwards.

I explained above exactly where to put it. I thought it was clear I was suggesting that you add it at that location. It won’t be in your config file until you add it. At this point no change to your config file has instructed for a switch of X-min and X-max direction.

Let me again suggest what I did above. This is a copy and paste, with the part about adding it bolded.

There are probably quite a few legitimate FluidNC config settings/options that are not present in the stock V1E LR config file. It would certainly be presumed that a backwards wired motor could be corrected with a wiring flip, but since that’s not working, there’s nothing wrong with adding that setting to try to correct the backwards running motor with a config edit.

I’ll give that a whirl, I didn’t understand that I could add it to the config, just so I understand correctly, add it here (below)

x:
steps_per_mm: 50.000
max_rate_mm_per_min: 9000.000
acceleration_mm_per_sec2: 200.000
max_travel_mm: 1220
soft_limits: false
homing:
cycle: 3
positive_direction: true
mpos_mm: 0
feed_mm_per_min: 300.000
seek_mm_per_min: 1500.000
settle_ms: 500
seek_scaler: 1.100
feed_scaler: 1.100
#X
motor0:
limit_neg_pin: gpio.25:high
limit_pos_pin: NO_PIN
limit_all_pin: NO_PIN
hard_limits: false
pulloff_mm: 4.000
tmc_2209:
uart_num: 1
addr: 0
cs_pin: NO_PIN
r_sense_ohms: 0.110
run_amps: 0.800
hold_amps: 0.500
microsteps: 8
stallguard: 0
stallguard_debug: false
toff_disable: 0
toff_stealthchop: 5
toff_coolstep: 3
run_mode: StealthChop
homing_mode: StealthChop
use_enable: false
direction_pin: I2SO.1
step_pin: I2SO.2
direction_invert: true (HERE)

My understanding is that it would be inserted into the “motor0” section as shown here in the screen shot image I posted for you previously (pasted again for convenience), which has it in a different place than where you have it. You seem to have it placed incorrectly in a “tmc_2209” subsection.

It didn’t do anything. :thinking: I wonder why when I flip the x plugs around, the right y motor stops working, any ideas?

I tried this one too, it’s on the same page…

    • Details: This is used to control the direction. You can invert the direction by changing the active state attribute (:high or :low)
  • disable_pin:
    • Type: Pin
    • Range: gpio or i2so
    • Default: NO_PIN
    • Details: This is used if your controller uses individual disable pins for each driver. Most basic controllers use a common disable pin for all drivers and that is set elsewhere in the config file. You can invert the direction by changing the active state attribute (:high or :low)

OK, did you also try “false”?

I’m sorry I have not been able to help you succeed yet, and I’m kind of grasping at straws. Just as a sanity check, your axis wires are connected according to this from the docs right?

Also, regarding your efforts to flip, this (shown highlighted) is what you’re flipping right? Not the driver, right?

Doug, don’t be angry, I flipped the x plug around and it works right, I thought that was the first thing I tried, nope I guess not. I do thank you for your patience and help with this, if you ever down south georgia way, stop by and see me, we’ll talk wood.

1 Like

I’m not angry at all, just relieved! So glad you got it!!

Now that you have the X-min and X-max right on the axis direction, if it’s not homing the right way, you know how to edit the config to fix that!

From your image X is homing in the correct place - to the left - but Y isn’t. it should usually be homing to the opposite ‘end’ - closest to you in that photo.