Guffy Post Processor

Hello, I am using Mac, MKS GenL V1.4 Board, Display MKS TFT28, Marlin-DualEndStop from Ryan , It is working and the Gcode is been generated correctly, but does not run, I think it stops in “M0” waiting for the Zprobe measure.
I can not make any input in the Display to inform the machine to execute the ZProbe command,
the Gcode generated has these lines:

1

In the LCD, the only button available is “STOP”.

@guffy tried to read and change the .js file to add the high of the probeThickness (mine is 19.2mm) instead of 0.8. but when the gcode generates the value still the original as below.

I have no idea how to enforce tft28 to pause on m0. Guys have similar problems with m600 and it seems that the issue still not fixed.


I heard that there is exists special version of mks tft displays designed for their grbl-compatible cnc board. May be firmware for this tft display works properly, i dunno.

  1. You don’t need to change sources. Thikness of probing plate can be specified in generation properties in fusion ui dialog.
2 Likes

If Marlin has a “traditional” lcd, then it will use that for resuming. It will do that if it is configured or not. Otherwise, AFAIK, it will ignore it. The tft displays aren’t as tightly coupled as the lcd screens. They act more like completely independent controllers, like octoprint, just communicating over serial. I don’t remember a resume command in gcode. Other senders will read the pause command an keep it themselves, and only send future gcode after the user resumes in that interface.

Here’s the easy workaround. Just open the file in a text editor and save everything before the M0 in one file, and everything else in another file. You may need to break it into more files if there are more M0 commands. Then just run each file one after the other.

1 Like

There is another firmware for the TFTs very interesting for CNC I am using it right now, but still does not give the ability to resume after M0;
[https://www.makerfr.com/en/cnc/rs-cnc/firmwares-rs-cnc/]
I am using the Beta V0.6 nice visual

yes but then it will be 3 codes to run, I am old… and lazy :slight_smile:

ZProbe question- what is the retract value command for the z probe after it touches the touch plate? I am making slight contact with my airline after it zero’s the z axis. It raises 35mm.
Thanks!

IMG_1569

Figured it out, the setting can be set in the the post processor page in Fusion 360.

1 Like

I have same problem. After touchdown it raises 40mm… my max is 34mm. I see no way to control this in the post processor settings. Is there a way that i’m missing?

The current active development of the guffy post processor is being done by Don Gamble. See this topic for the latest version. Looking at the code, the retract height for probing uses the “Tool Change: Z” property, so this is the value to change in Don’s version of the post processor. I don’t have a guffy version of the post processor to see if that property exists, nor verify that is the value used for probing in that version.

I just discovered that.

After setting Change: Z to 23, that changed the M0 40 to M0 23.

It doesn’t seem logical to me that tool change stuff would be used for initial z-probe… we would already have the first tool installed and the probe needs that tool installed.

I’m open to suggestions. It needs to retract to some height - I think - to ensure the first move is safe.

I don’t think I can use a f360 predefined height as I believe they only exist once I start processing cutting operations.

Thoughts?

I have not looked at the details of making a post processor so don’t know what fusion info you have available.

Without the z-probe code the workflow is…
Make the gcode.
Home the machine.
Manually jog the machine to a x=0,y=0,0.
Use z-probe on the V1Engineering menu to make z=0.5 above stock.
Start the print.

So far this has been working, but it would be nice to know that the first move would go to a fusion-known safe height.