Fluid Dial (Fluid NC dial pendant by Bart Dring, using M5 Stack's M5 Dial)

G’day all, I’ve lurked around in the shadows seeing some awesome and innovative designs (Ryan and Doug you guys are inspirational!). Attached is an image of my rig - sized for a full sheet 2.4mx1.2m utilising Doug’s hidden rail.

I’ve used a coiled 3m telephone cable for the pendant (about 75cm when not stretched out); it’s a bit fiddley getting the connectors crimped, but I can easily unplug the controller if I decide not to use it. I found using the coiled cable makes it easy to work across the full table without having a long cable dragging around when not in use.

Once again bit thanks to V1 and Doug’s work.


Great setup.
The cable chin is tidy, is that your own or where is it from?

G’day and thanks. I bought it on ebay (Towline Cable Carrier Drag Chain Plastic Machine Tool Nested 1M 7/10/20/18/37mm). There are heaps of designs on Printables and Doug Joseph (design8studio) may also have designed some. I was too lazy to print and went with the ebay option.


@Bruce386 - Nice! Thanks for sharing your machine and tips on your coiled phone cable idea! Thanks for the kind words!

@ DougJoseph not wanting this to sound like a mutual appreciation society; but seriously, the efforts from you, Ryan, V1 Team the forum and all of the other contributors is amazing and inspirational. It’s a fantastic community. Cheers

1 Like

Thanks for the kind words!

I have exactly the same error :frowning:
Can you please explain your solution a bit.
What is the PIO terminal?

Greetings and thanks

PlatformIO. Not in front of a computer at the minute but I think it’s at the bottom of the workspace

Hello! Technically, there’s a difference between not having gotten the file system included (so that you don’t have icons), and an “error” which would indicate something not compiling right or not building right.

If you’re saying that you have the same issue he did, which is that he had no icons, it simply means that you need to get the file structure put onto your M5 dial.

PIO is short for PlatformIO, an extension that helps people use Visual Studio Code to build and deploy things. In particular PlatformIO is used when we use VSCode to build and deploy the firmware for the M5 dial for this pendant.

Within the PlatformIO options for this build there’s not only an option to build and upload the firmware, but in the list of options further down, there are options for building the file system and uploading the file system. I use these. I’ve mentioned this carefully in probably more than one place in my documentation/comments in this thread.

There are at least three ways I know of to do the file system upload. One is the shortcuts I just talked about, another one is a shortcut icon/button somewhere else in the interface that I’m not sure about. And finally, it can be done in the project terminal by typing a command. I think that the command line referenced in the post you replied to is the terminal command in focus.

Regarding “what is the PIO terminal?“

When you are in VSCode, and you have a project open that makes use of the PlatformIO extension, then there is a terminal within VSCode, and that is the project terminal/PlatformIO terminal.


Doug, I’ve looked for other branches on github for the M5 Dial, but I haven’t been able to find any. What branch are you on and where can I find it?

From the M5Dial wiki:

Do one of the following to install the littefs and files, and repeat any time the files change:

  • Option 1: Send pio run -t uploadfs at the PIO terminal
  • Option 2: In VS Code, click on the PlatformIO icon on the left side menu (as you would to “build” and “upload” to the M5Dial), and under the “Platform” section, tap on “Build File System Image” and “Upload File System Image.”

To add a new Terminal and ‘pio run -t uploadfs’ :

Or you can build and upload the file system:


In the screenshots below, is (first) a click for firmware from the wiki, and then (second), on the firmware page there’s a button to access all the branches. Is this what you were looking for?

So I am aware that some progress has been made since the last time I messed with it, and I’m gonna check that information out before I try another branch. I don’t even remember which one I’m on now.

As far as I can tell, the latest progress is reflected in the branch names below, in this quote from dev guy Mitch:

New branch WMBWIP with the DRO-based homing scene. For best results, use with the HomedReport branch of FluidNC. It will work without HomedReport, but you will lose the indication of which axes have completed homing.

So, I will be trying out these:

FluidNC: HomedReport
FluidDial: WMBWIP

Thank you Doug. I finally found where it lists those Branches.
Now I have to figure out how to install them.
I’m not sure how to create the POSIX version of install-wifi.sh.

Super thank you,
In option 1 he said that he couldn’t find “PIO”.
With option 2 everything worked and the symbols are all displayed correctly (now I have also understood the instructions in the wiki correctly).
I was hoping that this would also solve my “N/C” problem, but it persists.
But I believe that the UART connection is fundamentally correct, at least with the pendant connected I keep getting the message “[MSG:DBG: UTF8 decoding error]” in the FluidNC terminal window.
Do you also have an idea for this?

Thank you very much and greetings

1 Like

Did you edit your config.yaml like this?

txd_pin: gpio.14
rxd_pin: gpio.13
rts_pin: NO_PIN
cts_pin: NO_PIN
baud: 115200
mode: 8N1

uart_num: 2
report_interval_ms: 75

1 Like

In addition to the nice help given by @Britt about the config.YAML file needing edited, you also have to make sure your FluidNC firmware on the Jackpot is newer than a certain version number. That’s spelled out in the Wiki, and above. I don’t remember the minimal version number off the top of my head.

If anyone else decides to upgrade to the new version of FluidDial, you will need to change your config.yaml. The new baud rate for the dial is 1000000.

  txd_pin: gpio.14
  rxd_pin: gpio.13
  rts_pin: NO_PIN
  cts_pin: NO_PIN
  baud: 1000000
  mode: 8N1

You will need to ‘Erase Flash’ on the dial and then Build and Upload Filesystem Image. Finally install the Fluid Dial firmware.

Be sure and upload the new graphics to the dial too:

I also upgraded FluidNC to the latest version.


@Britt Thanks for the info and heads up!!

1 Like


Retract after Probing was going the wrong direction. Bart fixed it in the main branch.

1 Like