Flashing TFT screen

Were can i get the firmware that came on the screen from v1 engineering somehow i reset the screen and need to re flash it all the ones i found on the webside have a blue v1 engineering and a language idk i need the one that is red v1 engineering when i turn it on and English

I do believe it is this one, https://github.com/V1EngineeringInc/BIGTREETECH-TouchScreenFirmware/releases/tag/nov-2021. We are kind of in the middle of testing the new release, so let me know if you have any issues.

If you do this will certainly work,
current tft.zip (1.6 MB)

i did the one that said will certianly work and display reads
found outdated data
fonts update required
config update required
language update required optional
icons update required

insert the sd card with the required updates and press the reset button to update

All of that is in the tft zipped folder you need to unzip and include.

1 Like


i solved that problem now it says no printer attached

im using the skr pro 1.2 board as well

baud rate is set to 250 k like its supposed to be

Is the SKR Pro flashed?

Does the Marlin side work?

It goes into marlin mode and btt mode fine but im having problems re flashing the skr board and my laptop dosent recognized when its connected

Did you see the instructions from the previous posts? What isn’t working, what are you doing?

You should just be dropping our precompiled bin on a card, inserting it into the pro and restarting.

Ive tried flashing the precompiled firmware.bin and inserting the card with power off then power on the board usually after flashing when you re insert the card into a computer it will say firmware.cur but its not flashing because it stays as a .bin when i plug card back into laptop unless I’m not flashing the board correctly

Unplug everything from the board except power, reformat the MicroSD, and try again.

1 Like

I unplugged everything from everything from the board except power re formatted micro sd card put the card in and powed it on and it still did not flash i tried this with and without the 5 jumpers in the board both did not work im using a 32 gb micro sd card is that too big to try this with? it worked for the screen

They have to be there, they are power. I know something like this has happened before, I can not remember what solved it. Let me do some searching.

1 Like

I did order a st link if i need to do it that way it will be here Wednesday

No I have never had to do that. I had a couple that didn’t seem to flash then I did something and they worked again. I am searching and can’t find the solution.

Try changing the power to USB and try it that way. unplug the regular power move the jumper and use the usb cable.

1 Like

Do you have another microsd to use, if you are using one that came with it they are no good and seem to die more than most.

I bought the 32gb one from walmart its the only one ive used i didnt see one in any of the boxes

hmmm, try formatting it to fat 32 and see if it reads it better. I have only tried small cards.