Dual Endstops - Problem homing the Y axis

Hey guys!

I’m trying to fix this homing issue on my Y axis. I’ve read a few posts off the forum but can’t seem to figure it out on my own. It reaches the switch on left (I’ll post a video link down below) and keeps going.

The board reads the switches being pressed, both manually and when the machines does the homing. I’ve also tried the following:

  • Changing both Y1 and Y2 stop switch cables with the other port
  • Hitting Home Y and manually pressing the switches myself. It works and homes every time using this method
  • Tried moving the switch location around so the trucks press the levers more evenly but the issue remains.

Here’s a video of the issue:

Not the best quality but you can see what I mean. The sound seems to always come from the left truck and not the other one, at least its what it sounds to me.

I’m running an SKR PRO 1.2 with 2209 drivers if that matters. I followed the setup guide on the v1eng site.

Any help is highly appreciated. I’m step behind of the pen test so I’m eager to get this up and running!
Thanks in advance!

The most common reason we see for this behavior is that you have reversed the endstops on the control board, so the Y2 endstop plug is reading the Y1 limit switch, and the Y1 endstop plug is reading the Y2 limit switch.

In troubleshooting the problem, M119 g-code is a great tool since it shows exactly what the firmware is seeing. You can send an M119 from the Manual Control tab of Repetier-Host or from the console area of your TFT display. Note that “Open” means untriggered not an open connection.

If the endstops are not switched, look for 1) a bad limit switch (very rare), or 2) a short in your wiring of that endstop. There can also be a mechanical issue where the endstop is not getting pressed by the stop block, but that looks okay in your video.


Awesome, thanks for the quick reply!

I’ll give Repetier another look. I tried before but I couldn’t find where to insert GCode manually. But you pointed me in the right direction.

I’ll let you know later when/if I figure this out. Thank you!

Hello again!

Just checked with the M119 and that switch is indeed not getting recognized when pressing it and issuing the code.

However, whenever I press it, the SKR board lights up an LED.

Any ideas what it could be? Bad switch? Wrong connection?

Could it be Bad Board or Firmware Maybe? - #6 by robertbu

Long story short you might need to add a resistor to the endstop wire if it is that issue.

I don’t know enough about electronics sadly :cry:

The good news is it’s easy to add a resistor to the wire you don’t have to mess with the board at all.

But why just this stop switch? What will the resistor do? If you could explain

Could I just replace the switch? I have a few extra on the way

In basic terms I believe the board is not seeing a big enough voltage change to register the stop has been triggered. Adding a resister makes the change more distinct to resolve it.

Oh now that you mention it. I did lengthen the cables a bit more on this switch, than the other ones.

Maybe reducing it back to what it was will fix it?

Another thing, when I home it and press each switch manually and one at a time, I can see each truck stopping briefly. Which is why I don’t understand what could be the cause of this issue.

I think I know what you’re saying now.

I remembered there was a potential problem on the SKR setup page. It’s a board problem, apparently.

Guess I need the resistors

The SKR board problem is indicated by when the switch is pressed 1) the LED light for the endstop coming on and 2) the M119 g-code indicating the endstop is “Open.” If your situation doesn’t match both of these criteria, you need to look elsewhere for your problem. If your problem matches, your choices are:

  • Exchange the board (only a very few boards seem to exhibit this problem).
  • Disable or remove the LED light for the endstop(s). This can be done by unsoldering the LED or by cutting the trace to the LED with a sharp knife.
  • Adding pullup resistors to increase the voltage when the switch is high:

Most people who have this issue elect to add pullup resistors. These can be added by soldering the resistor directly to the SKR Pro board, or by adding the resistor to the wiring connection.

Here is the first topic where the issue was identified.

Here is a topic where the resistors are soldered to the board.

Here is a topic where the resistors are added to the wiring.

1 Like


It may be simpler to remove the LED.

What happens is that the switch grounds the signal pin when it is not triggered. This means that when the CPU looks at that pin, it reads as low voltage, which is not triggered.

We want it to read as logic high voltage when we trigger the switch (which actually turns it off) so there is a resistor on the board already to connect the +5V voltage to the signal. The switch is a short circuit to ground.when not triggered.

The problem is that the LED is there between the signal pin and ground as well. Most boards this isn’t a problem, but some of them allow too much current to go through the LED, which means that the voltage on the signal.side.drops a bit too much and still looks low when the CPU reads it. Then you get a problem where the LED lights up, but the pin reads not triggered.

Two solutions work for this.

  1. Remove the LED. Just snap it off with needle nosed pliers, and the problem is fixes. The pin will read as triggered because the other path to lower the voltage is gone.

  2. Add in a resistor (1.5k is good, but anything from 720 ohm to 2k will do the trick. I did it by using a 3 pin connector on the control board end, and connecting the resistor to the +5V line and the signal pin wire. The signal pin wire and ground wire go to the switch as normal. Done.

Adding the resistor actually reduces the amount of resistance gping between +5V and signal by adding another path for voltage/current to travel. This increases the amount available, so the loss through the LED no longer causes a problem.

Yeah, seems like this is exactly my issue.

Thank for the links. I’ll try looking into the pullpup resistor fix!

Thank you for the explanation, it was very well put.

The LED method seems the easiest. I have never wired/soldered a resistor before, so I might consider doing this one.

I’ll take a look later tomorrow at the links posted above your comment.

Hopefully, I can fix this fast enough so I can have the machine up and running soon!

Thanks for the help!

FWIW, if you have done any wire crimping for the board plugs, just do it that way. Treat the leads on the resistor as wires.

If you have not had to do any wire crimping… I think I’m jealous…

1 Like


Sadly, I did. I had to extend all most every cable :sweat_smile:

1 Like

Hey, guys!

Just wanted to say a quick thank you for the help.

I added the pullup resistors to the problematic switch wire and it is now 100% working.

Moving on to the next part of the setting up. Have a great one and thank you!

1 Like