Carveco Maker post processor

OK, not a big Fusion360 person. I have used Vectric Aspire, Estlcam, and Easel. In digging around on the forums, and in a lot of places, and here, ArtCAM used to be popular with a lot of people, but was discontinued.

Some people had asked about Carveco Maker and its related products, but alas no Marlin Post Processor. At $15/mo. cheaper than Easel Pro.

After doing some digging about in various sites, forums, and my rear areas, I believe I have found the solution. Took some effort, editing, and other fun.

I Posted the file to the Facebook group, mm format. I have used this in Carveco Maker as the post processor. The resulting file can be read by Estlcam and Repetier as valid gcode. Still have to try it with some foam in the next few days.

Paste it into C:\Program Files\Carveco\postp. It will probably say you need admin permission. You can figure out that yourself.

Test away, I guess those years maintaining Netware servers, Linux beta testing, and just playing around has came in handy after all.


Re-edited the original Marlin.con PostP for Carveco for some minor issues found during testing. The one on the Facebook group should be deleted by the Admins. The edited PostP is named marlinCC.con

Can you post the post processor? Thank you, I didn’t see it in your post

Would you mind crossposting the file here? I don’t have Facebook. Thank you and understand if you are not able.

1 Like (1.0 KB)

1 Like

There you go

Awesome, very much appreciated.

1 Like

Hello everyone!
In testing the new Lowrider2 build I ran into an issue with the MarlinCC.con PostP I had uploaded that is for CarveCo/Artcam.
As I mostly cut reliefs it hasn’t came to the front to show me its warts until I tried a profile toolpath. G2/G3 Arc commands.
There is a workaround, that I tested. Open MarlinCC.con in notepad or the text editor you choose.
Near the bottom are the lines:
FIRST_CW_ARC_MOVE = “G2 [X] [Y] [I] [J] [F]”
CW_ARC_MOVE = “G2 [X] [Y] [I] [J]”
FIRST_CCW_ARC_MOVE = “G3 [X] [Y] [I] [J] [F]”
CCW_ARC_MOVE = “G3 [X] [Y] [I] [J]”

Just delete them/then save and you are golden.


Hi John, I came upon your post for the Marlin post file and need to know what to do with it after downloading it? I have been using GBRL mm post thru Carveco with very little luck! I just built a MPCNC Primo and having nothing but grief. Thanks Rob

Put it in the PostP folder: \Program Files\Carveco\postp

It will then show up as a choice of post processor when you save the toolpath

Hi John,
There is a problem with the marlinCC post processor at line 78:
RAPID_RATE_MOVE = “G0 F2400 [Y] F2400 [Z] 480”

The Z feed rate should have a “F” in front of it:

RAPID_RATE_MOVE = “G0 F2400 [Y] F2400 [Z] F480”

It kept trying to drive my Z axis at 2400

Does anyone know a fix to the G2/G3 issue with the marlinCC post processor that John mentioned earlier. The workaround just prevents G2/G3 commands being generated.

That was fixed on the speed, can 't remember if I uploaded it.

Been using the 515 firmware here. That was created as a workaround for the older firmware. The newest ones should run it, but I haven’t tested that here

Open the post processor in a text editor. After the line FIRST_FEEDRATE_MOVE, add an empty line space, then paste in:

FIRST_CW_ARC_MOVE = “G2 [Y] [I] [J] [F]”
CW_ARC_MOVE = “G2 [Y] [I] [J]”
FIRST_CCW_ARC_MOVE = “G3 [Y] [I] [J] [F]”
CCW_ARC_MOVE = “G3 [Y] [I] [J]”

Save it and restart Carveco. That will reactivate the arc moves.

NOTE: for some unknown reason the forum added black box check marks, they should be deleted and a space put in its place