Boy did I screw up !

I could use a little help please.

Last week I started looking at Estlcam. Today I decided to see if Estlcam could talk to my build. I have a Rambo with dual end stops and a full LCD. I also have a raspberry Pi hooked up running CNCjs.

Yesterday EVERYTHING was working just fine. After my adventures today during which I tried to run the Estlcam setup I bricked it all. Where it all went wrong was when I tried to run “Setup/CNC Controller/Program Controller”. Everything “seemed” to work but there was no machine movement. So I did a booboo and shut it all down rather than using the “Restore Controller” button in Estlcam. Now I have no LCD and no machine movement either from the LCD knob or through CNCjs even though CNCjs appears to be working without error.

Once I realized I shouldn’t have shut it down I figured it was too late and Id have to re-flash the Rambo. I tried the following firmware files:



by following this guide

The first one compiles and uploads but I still don't have functionality with the LCD or CNCjs.

The second one won’t compile and I get the following error:

Multiple libraries were found for "U8glib.h"

Used: C:\Users\ronmillsap\Documents\Arduino\libraries\U8glib

Not used: C:\Users\ronmillsap\AppData\Local\Arduino15\packages\rambo\hardware\avr\1.0.1\libraries\U8glib

fork/exec C:\Users\ronmillsap\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.4-arduino2/bin/avr-gcc.exe: The filename or extension is too long.

Error compiling for board RAMBo.

Anybody have any ideas what I’m doing wrong?

Just before the actual how to flash part of the firmware page there is a very important set of instructions for Marlin 2.0 firmware.

Beta Pre-Release Firmware

If you like to be more up to date with the Newest Marlin features, I have all my most recent updates here.

Github pre-configured.

Right now flashing Marlin 2.0 requires an Arduino IDE edit, when this is fixed I will update this.

You can use the nightly (1.8.6), the beta does not work now 3/20/18.

  • Open arduino
  • File/Preferences
  • Make note of the directory at the bottom, “more preferences”
  • Open that file with notepad
  • 3rd line down, “build.path=c:\tmp” works for me…
  • Todd posted some pics – in the forums.
1 Like

Thanks Ryan! Which firmware version should I be using?

I remember seeing “Bugfix” when I would start it up before, is that the right one ?

Oh, I get it, the “Marlin” vs “Bugfix” names screwed me up. Sorry

Ok, I did that, still not working.

Same thing. Bugfix2.0 compiles and uploads but doesnt fix the problem.

Marlin-MPCNC_Rambo_T8_16T_LCD_DualEndstop gives me this when trying to compile.

Archiving built core (caching) in: C:\Users\RONMIL~1\AppData\Local\Temp\arduino_cache_117660\core\core_rambo_avr_rambo_3ad5e6b5a02ffa124c7188ad46be603b.a sketch\src\backtrace\backtrace.cpp.o (symbol from plugin): In function `backtrace()':</h6> <h6>(.text+0x0): multiple definition of `backtrace()'
sketch\src\HAL\backtrace\backtrace.cpp.o (symbol from plugin):(.text+0x0): first defined here
c:/users/ronmillsap/appdata/local/arduino15/packages/arduino/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/../lib/gcc/avr/4.9.2/../../../../avr/bin/ld.exe: Disabling relaxation: it will not work with multiple definitions
collect2.exe: error: ld returned 1 exit status
Multiple libraries were found for "U8glib.h" Used: C:\Users\ronmillsap\Documents\Arduino\libraries\U8glib Not used: C:\Users\ronmillsap\AppData\Local\Arduino15\packages\rambo\hardware\avr\1.0.1\libraries\U8glib exit status 1 Error compiling for board RAMBo.

You are using the “Hourly” build of arduino and changed the directory to c:\TMP?

Yes, I couldn’t remember the last time I updated so before i answered you I went back, uninstalled Arduino, then downloaded the build thats out there right now (June 18, 9:13:39 GMT).

And yes I edited the preferences file to add “build.path=c:\tmp”. Then for the eighth time today I uploaded “bugfix_2.0”. No errors this time but still no machine movement and still no LCD.

CNCjs on my raspberry pi thinks everything is hunky-dory to I’m quite convinced that I bricked my Rambo.

Can I buy another one from you?

Hourly, not the current,

Double check that it is there. It only sticks if you do it while arduino is closed.


Lets leave the raspberry pi out of it, way too much about this that I can not understand… Use repetier or an lcd to test.


Highly doubt it. To verify just flash the regular not dual endstop Marlin v1…


1 Like

Yes, the most recent HOURLY. if you look at the Arduino download site theres an orange box showing “June 18 etc”

Yes again, just like the instructions say, it must be done with arduino NOT running.

I have been ignoring the Pi. I know because I have to use the Rambo USB port for both the Pi and Arduino. I only plugged up the Pi after flashing to see if its connecting to the Rambo. it does connect and the terminal window in CNCjs shows the communications. I can send commands to the Rambo from the Pi and the Rambo responds but the commands dont result in stepper movement at all. Also, no matter what i do the LCD is blank. Its lit but theres no info displayed.


Ill go try the v1.0 now.

The arduino ide flashes with no errors now, and your LCD worked before?

Yes, 2.0 flashed with no errors however, the LCD has NOT worked throughout this whole mess and still doesn’t.

By the way when I looked at the terminal in Arduino IDE it showed that “bug fix 2.0” was running.

Swap your LCD cables, as in turn them around, a few went out backwards.

I went into IDE and sent a few commands in the IDE terminal and got the results below. It shows 3 end stops (bugfix 2.0) AND it shows they are triggered when physically they are NOT.

echo:Marlin bugfix-2.0.x

echo: Last Updated: 2018-01-20 | Author: (none, default config)
echo:Compiled: Jun 19 2018
echo: Free Memory: 5548 PlannerBufferBytes: 1232
echo:Hardcoded Default Settings Loaded
echo: G21 ; Units in mm (mm)

echo:Filament settings: Disabled
echo: M200 D3.00
echo: M200 D0
echo:Steps per unit:
echo: M92 X80.00 Y80.00 Z4000.00 E500.00
echo:Maximum feedrates (units/s):
echo: M203 X300.00 Y300.00 Z5.00 E25.00
echo:Maximum Acceleration (units/s2):
echo: M201 X3000 Y3000 Z100 E10000
echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
echo: M204 P3000.00 R3000.00 T3000.00
echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_us> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
echo: M205 S0.00 T0.00 B20000 X10.00 Y10.00 Z0.30 E5.00
echo:Home offset:
echo: M206 X0.00 Y0.00 Z0.00
echo:PID settings:
echo: M301 P22.20 I1.08 D114.00
Reporting endstop status

Already did that and yes mine WERE backwards and worked fine once I turned them around. but that was yesterday. Haven’t moved them in a week.

That means you have Marlin 2.0 on your board but not the Dual end stop version and I’m assuming you have end stops plugged in. The logic is reversed for the non dual end stop version.

Dual will show 5 endstops, adding an x2 and a y2.

Swapped them just now just for kicks, LCD was dark. Put them back the way they were, LCD lights, no text.

I have a stupid question. When I download a zip from your “git” do I unzip and use the files just as they are unzipped or am I missing something. I ask because I notice that the number of tabs in Arduino IDE have been decreasing with every new release to the point where now there’s just a “configuration.h” and a “configuration.adv” no other files. Is that how it’s supposed to be ?

One last question then I’m giving up. I see this echoed in the IDE terminal when I start the RAMBO. What does it mean and what if the “default hardcoded” settings have been screwed up by Estlcam?

echo:Hardcoded Default Settings Loaded

Unzip and use as is, This is the change in Marlin 2…better file organization. You still need all teh files so use the entire folder as is when unzipped, you would get errors if you did it wrong.


Not sure, I have not seen this. anything you did by flashing estlcam , should have been reversed. Again you can make sure by flashing a 1.0 version and then back to 2.0, this swill clear the eeprom for sure.


Nope. Not going to let you do that. Just an hour ago you were convinced it was broken…we already saved more than $130, and I am sure you have learned a few things. Take a break if you need to but we will get you there.


Cool, so orientation is correct, and we have proof it worked previously. It has to be loaded correctly or my firmware would not flash. Try physically swapping the cables. They do different things and there are different wires used. If there was all of the sudden a bad wire this might fix it.


1 Like