Bartman's LR3 build thread - A New(bie) Adventure!

Well looks like your well on your way !!
Also a fellow Canuck too
Good luck

1 Like

So I have almost all of the non-printed parts here. Shipment arrived from Ryan (haven’t opened it yet, so no pics).

I purchased a knockoff Makita router - Vevor 1.25HP. VEVOR 6.5Amp 1-1/4 HP Wood Router Tool Kit Max Torque 30,000RPM Variable Speed Compact Router Kit With Fixed Base, Plunge Base, Tilt Base and Offset Base (kit w/4 bases) | VEVOR CA It came with 4 bases (tilt, plunge, offset, standard) for an extra $14 CDN (about $10 in real money), plus vacuum port and a bunch of spare bits and bobs. I won’t need them for the LR3, but I will probably use the router for hand-finishing a few projects, so for the extra few bucks, it seemed like a reasonable idea.

I found a few additional pieces of 1" x 0.120 Stainless Steel tubing (37" long), which I can use to build the smaller version to cut parts as I’m building the full size version, so I won’t have to print and discard the smaller diameter braces as originally planned…

I also found several pieces of 1/4" aluminum plate, so I think that I have most everything I need to start putting it together once I print all of the plastic parts.

On the printing front, I’m making progress dialing in the new Ender 3. I checked the e-steps for the extruder, X, Y & Z axis. The three axis were all within 0.08 mm over 100 mm of travel, so no adjustments necessary. The extruder only pushed 94mm of filament on a 100mm command, so I adjusted the settings and now it pushes 100.07mm (pretty darn close).

I had already leveled the bed, set the Z Offset, created a bed mesh, and tuned the PID for the nozzle and bed. I then printed a single layer bed adhesion test file, and it came out pretty good, as far as I can tell:

Sorry for the crappy pics - photography is not my strong suit.

The rectangles look like there are no voids or gaps, and they were sticking really well to the bed in each location.

Next was a skew test.

The adhesion of these to the bed was through the roof! I literally had to remove the glass plate and use a scraper as a chisel to remove them.

The XY test was within 0.05 mm (100mm rectangle, 140mm diagonal), so that was pretty good.

The XZ test was also pretty close (0.02mm difference), but there is a lot of stringing, along with a bit of elephant foot. Not sure if that is because of the filament (the white stuff came with the printer, and has been exposed to the air for several weeks), or because I still need to dial in the temperature and retraction settings. Now that I have used up the old filament, I’m going to load up the shiny new red Hatchbox PLA and do those tests next.

The YZ test was a little bit less where I was hoping, with about 0.70mm difference, and again lots of stringing and elephant foot issues. Not sure if this is a reasonable amount, or if I need to compensate in Cura or in Marlin. Once I dial in the temperature and retraction settings a bit better, I plan to re-print that test and see how it looks. I should hopefully also be able to do some of the shorter pieces (pretty much everything but the core, I’m thinking) as is, and maybe try to fine tune it a bit more before tackling that one.

I’m getting a bit more knowledgeable about the 3D printing process, so once I get rid of the stringing and pachyderm appendages, I can hopefully start printing my first parts for the LR3 by early next week!

.Comments and suggestions welcome!!!


Oh yeah, also bought several heavy duty vacuum bags and a 50 count bag of 5g desiccant packets to keep my filament dry when not in use. I saw someone online using the heated bed and a cardboard box as a dryer, so maybe I’ll give that a try as well.


I’m a strong advocate for the Teaching Tech 3D Printer calibration guide here: I followed that to really dial in my printer after I made a lot of modifications to it (it’s basically not at all stock except for the frame and wiring, I’ll show it in my thread tomorrow). Lots of good tips on that site, and he walks you through things like step adjustments and such using both videos and text. Really well done.

Re: bed adhesion, Elmer’s glue sticks are my go-to. Enough adhesion that filament doesn’t try to escape the bed, but not so much that it’s impossible to remove parts. I do keep a very sharp chisel by the printer to carefully aid in part removal, but I don’t always need it. Kind of depends on how much glue I laid down. :melting_face:

Re: elephant’s foot, there’s a setting in Cura - Initial Layer Horizontal Expansion - to reduce the first layer outer width by some small fraction to help keep the plastic from squishing out as much. I set mine to -0.1. Also, getting the bed temp and fan settings right will help.

Re: stringing, you’ll get that sorted via the calibration website. You will do a temp test to find the best temp for your filament (it can vary from brand to brand), and then a retraction test which is likely a factor in the stringing.

The process is fairly involved, but worth the time to nail your settings. I’m going to be upgrading my machine with linear rails soon (the wheels on the X and Y axes are wearing out and linear rails are overkill but awesome), so I’ll be going through the whole process again to get my rig tuned back up.


I had that too on my Ender 3 V2. In the end I swapped the glass plate for a pie plate as I was unable to remove some printed parts without nearly damaging the glass one :melting_face:
Had a small learning curve on the Pei one though, as I had 0 adhesion after installing. Since I cleaned it before each print with 100% IPA that was solved (except for prints with very small footprint, there I need some additional support).

Regarding the stringing, I would suggest to print a temperature tower with your PLA you will use most of the times. Nearly all guide I’ve read mention around 200 degrees for PLA but found out that my setup works better with 190 degrees. So use guides loosely

1 Like

All right, I’m happy to report progress! After dialing in the Ender 3 (New to 3D Printing - Advice for LR3 Print Settings), I just printed my first LR3 part!

More pics soon.


Thanks for that. I’ll give it a try on my next print!

1 Like

Well, those last 18 days have flown by!!!

So I’ve made some progress with printing (some of) the parts, and then ran into a whole bunch of headaches with the printer.

The good news is that I managed to print off all of the Y Rail Brackets, inner X Rail Brackets (50% infill ones not done yet) and the Y Belt Holders/Endstops (not sure if the terminology is 100% correct, but hopefully you can tell from the picture what I mean…)

Things were going along pretty well, and I was feeling pretty good about the quality of the prints. Until I noticed that the last few X Rail Brackets were showing some weird lines (layer shifts?) in the middle of the prints

I spent a LOT of time trying to figure out what was happening. I had noticed that the nozzle was contacting the infill during travel moves, so I had made some setting changes in Cura to add Combing and Z Hop, so I wasn’t sure if the lines were a result of the nozzle contact, or from the setting changes.

I started to look at the first layer setup, so I re-leveled and trammed the bed (several times), and I noticed that the bed had some fairly serious warping when measuring with a dial indicator. The waviness seemed to be most noticeable near the edges, with the corners raised up and the clip locations (x2) lower than the rest of the bed. The center of the bed also had a noticeable dip.

Creality units ship with only two clips, so I bought/installed several more clips (3 on each edge).

The units also use only 16 points (4x4) for the bed leveling mesh (Bi-Linear), so I went down the rabbit hole of configuring Marlin to use UBL bed leveling with 100 points (10x10). That took way longer than it should have, mostly because Creality has not provided the source code for the newer models of the Ender 3, and the only “example” for my model that I found on Github (Marlin Firmware) had a few obvious errors and was not set up at all to use UBL.

I spent MANY hours learning all about G29 codes and how to edit and compile .h files. After repeated mistakes and failures, I finally got the configuration pretty close to how it needed to be.

I tried a few test prints, and the results were HORRIBLE! Blobs, stringing, gaps in the first layer, you name it!

I found a bunch of issues:

I found a bunch of scraping marks on the plastic piece at the base of the Power Supply

It seems that the Power Supply doesn’t sit straight on the vertical gantry beam, and was twisting into the path of the bed, where it was getting scraped every time the bed got near the Min Y position. I had to shim the Power Supply on one side with aluminum foil to straighten it out so that it was parallel with the bed.

I also found that the PLA had become moisture soaked from sitting on the printer too long, so I had to set up a makeshift dryer using the heated printer bed and a cardboard box with some vent holes. That and cleaning out the nozzle/extruder seemed to make things a bit better.

I also found that the bed adjuster springs weren’t tight enough, so they were spinning loose during printing, or whenever my hand brushed against them when changing the SD card. So I tightened them up so that they were about 90% compressed and printed some parts that attach to the adjuster wheels that I can use as a visual reference to see if they moved

(Once I get the printer working correctly again, I’m going to print and install some locks to prevent the adjusters from moving at all).

Lastly I noticed that the nozzle moved around when I touched the Bowden Tube/wires at the top of the nozzle assembly. I took of the fan cover and found that the two screws that hold the nozzle/heat sink to the assembly had come completely loose! I tightened them up, and I’ll check them every couple of weeks going forward (there may be some Loc-tite in their future).

So after all of that, I’m getting closer to having the printer back to working condition. I’m still dialing in the bed mesh using G26 mesh validation test print. Parts of the bed are adhering well, but some other parts aren’t there yet, so I need to manually adjust the mesh points until it is consistent across the entire bed.

Kind of challenging when I only have an hour or so in the evenings to work through all of these issues, but so far the challenge has been fairly rewarding. I’m learning lots about 3D printers, Marlin configuration, g-code, and a bunch of other stuff that will hopefully help me down the raod when I start to build and operate the LR3.

Ciao for now!

That’s really frustrating… but all part of the hobby journey we’re on! I have gone through plenty of 3D printer headaches too, so I feel ya. Glad you’re learning and making progress again.

Yes., if it was easy, everybody would be doing it! LOL. As you say, it’s all part of the hobby journey, and in my case it is really all about the road trip, and not really much about the destination.

1 Like

The appearance of that issue seems to indicate that the Z axis did not advance upward as it should, causing a squishing of layers on top prior layers. Chief suspect would be a loose grub screw on the Z axis coupler (where the lead screw and the stepper motor connect to each other).

If you have not personally insured the grub screw has some thread locker on it, it’s a good thing to make sure. Loctite brand is popular. I use Loctite 243 (blue):

PS: there could be other possible causes, such as friction / lack of lubrication where the lead screw passes through the lead screw nut/block.

Perhaps you could print a small calibration cube? (To see if the problem is there always)

I do not think ot is coincidence that those showed up where the M5 screw holes start and stop.

So what changes there?


  • This is where the slicer goes from one large part to 6 smaller ones, and it disrupts infill.
  • Interior perimeters become exterior ones (around the center triangular holes) which reverses the print head direction there, and it’s pushing other stuff out of whack.
  • The corner immediately before the problem area goes from being a right-hand curve to a left-hand curve, and there is something allowing backlash in the mechanism.

Any/all of these would have a root cause of some backlash or slop in your printer’s movement, and this is just the point where it shows.

I would check the X and Y drives of the Ender 3 for any play in the belts. This really looks like the kind of crap that my first printer used to do when the drives got sloppy (which they did constantly because it was a particularly crappy I3 clone.) In particular, check the drive perpendicular to the worst face of the part as it prints.


Nail head, meet hammer!

The fact that it goes back to correct when the layers with the holes are finished made me question whether it might be something in the slicer settings.

Just before this appeared, I printed Ryan’s XZ/YZ Skew test, and the nozzle was contacting the infill quite a bit on the upper layers, to the point that I was thinking that it might knock the print right off the bed.

I was fiddling around with some Cura settings for combing and bridging and Z-hop to correct that, so my first thoughts were in that direction, but I figured that I should start with the basics and re-dial in the first layer before anything else.

When I tried a first layer test print I found a lot of problems (gaps in the lines, sections with excessive squish, sections perfect, sections with the filament not even contacting the bed), so that’s when I started down the UBL rabbit hole, which I am just finding my way out of now.

Grub screws were/are quite tight. I checked them previously, and again just now, because, well, they are grub screws. I’ll lube the threads, but given the way that the issue is just a few layers corresponding with the screw holes, there is probably something else afoot here.

If it’s not in the slicer settings, then this seems to be the most likely. I did find two possible sources of inaccurate movement, with the rubbing of the bed on the power supply, and the very loose hot-end screws. The belts seem tight, but I’ll recheck the rollers and adjust the cams if needed.

1 Like

Just to be certain you are not using more than 70% infill correct? This could easily be over extrusion pushing on your nozzle.

A good quick test is the 100/110mm extrusion length test. If you have not done this I can provide a link.

(This used to happen when people tried to use 100% infill)

1 Like

Nope, 35% infill on the parts shown above.

If you’re talking about e-steps, I’ve done that test. It was initially under by about 4mm, I adjusted and now it is 99.5mm actual on 100 mm expected.

1 Like

OK, I’m happy to report some (minor) progress!

I went back and checked a bunch of different things on the Ender 3. I found that the X rail was “catching” at a couple of locations. When I moved it by hand, it would “click” into a position, and it would take a bit of extra pressure to move it again. It turns out that I had over-tightened the roller wheel cams. Once I loosened it a bit, things moved smoothly along the whole axis. I also loosened the Z and Y axis a bit, and things are moving more smoothly than before.

I also checked the belts, and found that I had probably over-tightened them as well, so I backed them off so that they are tight, but not tuned quite as high a pitch when strummed.

I found that some of my G26 print failures were due to the underside of the print head assembly fan catching on the side clips. Even though I had decreased the print bed size in Marlin, the side fan housing was still hitting whenever the nozzle got near the right edge of the bed, causing the X axis to lose steps. I flipped the clips upside down, and everything is good!
After several edits to the mesh values, I was finally able to print a G26 Mesh Validation Test Pattern that looks pretty good (IMO)

(Ignore the missing line in the bottom left of the picture, the nozzle had a blob on it that I couldn’t clean before it started printing)

So I’m going to re-start the LR3 printing again soon (celebrating birthday #65 this weekend, so it may have to wait for a day or two). I’ll post pics and keep my fingers crossed that the layer shift issues have all gone away.


Nice work!

Making headway (slowly slowly).

Now that the printer is behaving a bit better, I’ve printed a bunch more small parts, including the temporary struts, bearing wheel brackets (F&R), supports, Z Stop (& M), X tensioner, Y tension block/base (L&R), and Y belt holder/base (L & R):

I’m not sure if it was good luck, or good planning, but the latest part finished printing with less than 2’ of filament left on the spool:

Some of the prints coming up on the next spool are pretty long (12-35 hours), and I’m still noticing the occasional gap in the first layer lines, in one or two specific areas, so I’m going to use up the last of this spool to print a single layer on the full bed, and then use that to fine tune the UBL bed mesh.


There wasn’t quite enough left on the roll to complete the full bed single layer, but rhe portion that did print shows pretty clearly some areas where the lines aren’t adhering to the bed.

I’m going to edit the mesh and reprint with a new spool tomorrow, so hopefully that will bring me closer to being fully dialed in.

1 Like