Z is off by 1/2

Howdy howdy howdy, I actually cut wood for the first time tonight. Test cuts in crappy plywood, but making a mess all the same. I’m just doing a simple rectangle, prepping to actually cut the bed for T tracks. My 19.1mm wide cut came in at 19’ish and with the wood I’m using, calling that pretty good. It looks nice and straight. I’ll tweak a bit as we go. And I need to measure the Y but to my eye, it looks about right, which is good enough for tonight.

Big issue on the Z though and I’m guessing there’s somewhere in the config that isn’t set right. I have a 15mm thick touch plate. I set the thickness in the fluidnc at 15mm, and it was definitely cutting air. I found that to actually be at 0, I have to set the thickness to 30mm. Not the end of the world. But my test cut was supposed to be 10mm deep and it came it at 5. So again 1/2 of where it should be. I verified the design and measurement in estlcam and the cut is indeed set for 10. I ran the file again, same result. Since I’m seeing the same error in both the cut and the pre-gcode, I don’t think it’s an issue with the design/gcode. I’m skittish to just fiddle in the configuration on the board but I’m guessing that’s where the fix is.

Skimming down the configuration I see that soft limits are an option I can turn on. If I do so is there an actual setting so I can keep the machine from bouncing on the back rails if I mess up a design?

Thanks for the help.

Double your steps/mm on the Z. That should give you the proper movement distance.


This is the spot in config.yaml to make that change. (Ignore the letter Z. My fingers are not working well this morning.)

1 Like

Spending a few moments looking at the hardware I have and the stuff being sold in the shop. It looks like the shop lead screw is a 2mm pitch with a lead of 8.

What I might have bought is 2mm pitch with a lead of 4. If so, the machine thinks it’s moving 1mm, but it’s only moving .5mm. So doubling the steps per mm will just make the machine do twice as many steps so it will be moving the correct distance? And no need to replace the lead screw with the proper one, just fix it in the settings?

I ebay’d that part so that’s on me for ordering the wrong thing. I’ll go make some changes and try again.

thanks for the assist.

No need to replace the hardware. Just update the firmware.


The firmware only “knows” that if commanded to move 1mm, it should trigger the step pin 400 times (200 steps / revolution × 16 microsteps ÷ 8mm / revolution = 400 steps / mm)

Change the 8mm / revolution to 4mm / revolution and you get 800 steps / mm.

The shorter movement helps keep the Z axis from falling when powered off, but you may need to move slower. Honestly if the 4mm lead screws weren’t so much more expensive, I would probably have done it.

If gou are recompiling the firmware, I suppose you could also change the 16× microstepping to 8×, and leave the steps at 400, but you still need to slow down the travel speeds.

Edit: check your lead screws though, because the other possibility getting 1/2 the movement is 400 step/revolution motors. In this case, you still double the steps/mm but do not have to worry about reducing travel speed. The loss of torque is mostly due to motor RPM which doesn’t change even if the number of steps.do.

1 Like

Switching the steps per mm did the trick.

Next ?, how so I make the board save the settings? The default touchplate thickness is .5, the default steps is 200. I change the plate to 15, I change the steps to 400. Everything works well until the board powers down and at the next startup it’s back to .5 and 200. I don’t see a separate save button anywhere. Do I have to download the config file and edit it separately?

On the jackpot, you update the config.yaml and re-upload it.

Go into Settings. There is a save button in there for after changing the probe thickness… And you have to run $CD=config.yaml after making changes to the config.yaml in order for it to save.

Found the stepper setting in the config file, edited and it’s now gtg. The touchplate I found in preferences.json. I really wasn’t expecting everything to be plain text. I’m having flash backs to the days when I could actually make computers work :laugh:

Thanks again.


I am having the same problem. My z axis is moving 1/2 the distance expected. I doubled my steps to 800. Nothing changed. What am I missing?

Are your microsteps set the same?

Hello, Colin. Even with what appears to be the same symptom, you almost certainly have a different build. The best way to get help would be to create a new topic in the correct subforum.

You should select by what machine you built (MPCNC or LowRider), then give details.
What controller board are you using, with what firmware?
Where did you source your parts from?
What pitch are your Z axis lead screws?

Since you say you doubled the Z steps and nothing changed, list that in your new topic.

I figured it out… I have lead screws that are 2mm pitch 2mm lead. I quadrupled the steps per mm. I am moving very close to what I expect now…

What’s with the weird answer? Got hacked? :sweat_smile: