Z homing

I’m currently using RC7 without lcd for my arduino. I would like for my mpcnc to be able to home itself on the z axis. X and Y homing is working fine. Only z homing doesn’t work. It moves upwards for several mm. What should i change in the marlin coding? i need this so i can use opencncpilot to do pcb. When no connector connected to z endstop pin, the machine goes down just fine. When connected going down return echo:endstops hit when check with m119 it is not triggered.

You have wired the endstop wrong or the pin is shorted. It thinks the endstop is triggered.

You have not given any hardware information so that is all I can offer as advice.

i want to mill pcb with my mpcnc, but the sacrificial board is a little uneven. i replace the limit switch usually for z axis with two crocodile clip. 1 connected to the pcb and other to the engraving bit. I’m using ramps 1.4.

What are you using to control the cnc? Repetier or Estlcam?


That should work if you are using my firmware, if you altered it double check the endstop settings.

You said your bed is a little uneven. If you are trying to do auto level on the pcb for milling it will not work well enough. You need to physically level the board. The easiest way is to mill a pocket into anything for the pcb and set it in the pocket. it will be very level.

1 Like