Z home halt error

I looked this up and the advice was this, but there wasn’t confirmation that it corrected the problem. Is this what I should do to fix the touch plate issue?



May '19

You can edit the pins file and reflash your firmware. Try swapping Zmin and Z max.

What is the issue you are having? What are you ding exactly and what are you expecting to happen?

same as the guy in the other thread.

I can even home Z and it seems to operate correctly. Touches the plate, retracts and touches again. All seems normal…

However, a few moments after homing the Z axis I get a printer halted kill called, please reset error!

If I need to update firmware, do i use this version V1CNC_Rambo-, I’m using your Rambo 1.4 no endstops

I swapped z min and max pins and the problem is in fact gone.


Also having the problem that after z homing I get the printer killed message.

Not exactly sure what swapping the z min and max pins means but I changed these lines in the file pins_BTT_SKR_PRO_common.h:
#define Z_MIN_PIN PG8 // Z-
#define Z_MAX_PIN PG5 // E2
#define Z_MIN_PIN PG5 // Z-
#define Z_MAX_PIN PG8 // E2

Then I did not get the error message any longer but it would not stop when hitting the touch plate.

Is this the correct changes that you are referring too?

I bought the combo from v1 engineering with this board SKR Pro1.2, 5x 2209 drivers, TFT35 E3 V3 × 1.

Besides this it is working perfectly and I have milled some MD5. I want to do finnishing pass with another tool so need to be able to z home.

Best Regards

Which firmware did you start with? The ones at MarlinBuilder releases should be ok.


I unzipped this one and followed the instructions to build it with the platform io stuff.


Best Regards

That firmware should be good and tested. I am pretty sure I even double checked that version and the endstops.

If you swapped the pins, you will need to move the plug to zmax.

Check with M119 before trying the homing sequence.


Yes first when I didn’t move it from zmin to zmax it didn’t stop when hitting the touch plate. After moving it to zmax it was like before:

When I do the z homing it does lower the z axis until it hits the touch plate and then backs of a few mm’s pause and after 1-2 seconds I get the printer killed message and then it lowers the z axis again (I think by gravity).

I also tried increasing ENDSTOP_NOISE_THRESHOLD to 2 but didn’t notice any difference.

I will try to swap the display cables as suggested in another thread.

Do you have any more suggestions I can try?


Do you have an import “spindle” and power supply plugged in?

No I have the makita RT0700CX5J.

I just milled some more mdf so it seems to work very good except for homing.

Have you tried swapping the polarity of the touch plate. Some routers make too much noise.


Yes I tried swaping polarity on the touch plate. I also removed the power coord from the makita and it stills fails with printer killed. Even if I just touch the clip to the plate in the air I get the same thing.

Maybe I should go back to the original firmware and try swaping the polarity.

Best Regards

1 Like

Same problem with original firmware as already built in the file from you.

This is the output from cncjs:

CNCjs 1.9.22 [Marlin]
Connected to /dev/ttyACM0 with a baud rate of 250000
FIRMWARE_NAME:Marlin 510D (Mar 4 2021 04:38:08) SOURCE_CODE_URL:https://github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:V1CNC 510D EXTRUDER_COUNT:0 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff

G28 Z
echo:busy: processing
echo:busy: processing
Error:Printer halted. kill() called!

Going to try to lower the baudrate and see if there is any difference.

If you have anything else I can try I am all ears.

Best Regards

I also switched the polarity of the touch plate with the same behaviour.

What does M119 say? How exactly are you trying to probe the surface, I do not recognize the "CAP:"As in what program? What does the LCD say?

I have tested this firmware recently works on my end.

M119 says z_min TRIGGERED when the touchplate is in contact with the clip, when it is not in contact is says open.

I have tried probing it several ways.

  1. touch screen on the home button and then the Z button.
  2. send G28 Z through the terminal on the display.
  3. Through cncjs (With your prebuilt image on a rpi 4).

The pasted output is from the console part of cncjs.

From the Screen, either method, What happens when you home Z only?

That is what I have been doing. G28 Z only homes Z right?
Also in the buttons on the touch screen there is a home Z only button. I have only tried homing z separately.

Since I hadn’t tried it I issued a G28 to home all axis at once and it homes X and Y correctly and when homing Z it is the same problem. Busy proccessing and then printer killed.

Do you actually trigger it after you issues G28 Z?

Home Z, then you actually have to trigger it twice. Once, then it backs up 5mm, then slowly moves back down. If it is too far off the second time you will get an error.