Z axis random digs

Whats up all,

I am all the sudden randomly having an issue with z axis. So i made a new cutting table over the weekend for the machine itself. I changed nothing other than the table itself. Now that its on the new table whenever i try to make cuts the z axis just randonly digs down to deep. For example instead of doing .25mm per pass it will just out of no where drive all the way through the boad. I have attempted multiple times on same file and it does it in different spots each time. Sometimes as soon as it starts , sometimes will start like it is supposed to then out of no where will just drive down all the way again. Any ideas of what may be causing this issue? Machine is Original MPCNC with no endstops.

Edit: just shooting out a random thought here. If at some point i mistakenly hit the reset button on the arduino board itself (not while running of coarse) would i need to reflash? However i have had a few successful runs after i hit that reset before this z axis issue started.

Of the many reasons for lost steps, the ones I can think of that would cause a catastrophic drop are:

  • Intermittent wiring issue to the Z stepper

  • Z stepper driver overheating

  • Issue with the collet causing the bit to drop

  • Maybe a power supply issue, though other steppers would also be affected.

  • Maybe (remotely) a grub screw or connector issue.

  • Electronic noise

If at some point i mistakenly hit the reset button on the arduino board itself (not while running of coarse) would i need to reflash?

No, and this does not sound like it could be related to firmware.

Thanks for the reply could you elbaroate more of what you mean by electronic noise? and i did consider the driver, i do not believe i have a spare on hand, however i do have a fan blowing directly on the drivers which i have had since first building. I also did ensure collet was tight. I may have overtightned the bolts (is that what you are referring to as grub screw?) to much when putting back together on new table but i dont think that would cause the z to be plunging in the manner it is. Also i have considered the router itself being an issue as its the same one i been using for years and def has had its work put in thinking maybe the bearings inside the router are shot but not sure that would be causeing my plunge issue. I also checked all my wiring to make sure there was no lose connection or frays anywhere.

A bad stepper driver is another possible reason. I suggest you swap the Z stepper driver with another one on the control board, and see if the problem stays with the Z axis or moves to another stepper.

As for electronic noise, I’ve seen on the forum a couple of cases with electronic noise has corrupted the g-code being sent to the control board, resulting in the router taking off in an unexpected direction. Typically, this would occur when the g-code was being sent using an SD card from a display. IIRC, it seemed to happen with long display wires that are sometimes used for LowRider builds. Jeff pointed out in a recent post that the USB protocol has error detection/correction, so it is far less likely if you are running your jobs using a g-code sender and a USB cable. As I think about it, the fact the issue only happens on the Z axis makes electronic noise very unlikely to be the root of your issue.

So i do use the sd card method for my machine however it is a pretty small cable from the display screen to the board itself and it is the only way i have used the machine since the day i built it.

Would the bolts on the z axis being to tight cause this issue? (I think this is what you’re reffering to as grub screw, is that correct?)

Also what about the router internals, possible causing this issue?

Grub screws are tiny screws in the connector between the lead screw and the stepper motor. Typically, loose grub screws don’t cause a catastrophic drop, more of a gradual loss of steps over time, but anything is possible.

what about the router internals

I’ve never read about such a problem on the forum. If it is an issue, you should be able to, when the router is not moving, physically move the shaft up and down in the router housing.

Ok thanks for the help I greatly appreciate it. Im going to have to go with bad driver then. I will test out when i get home and respond back on here with an update.

The nut that hold the center and into which the lead screw is screwed from the Z-axis stepper motor, it is better to attach two screws and not tighten too much, so that there would not be a lot of backlash. I had such a problem, I fixed it on all for screws and tightened it even more. Therefore, the Z axis began to lose steps when climbing, respectively, when descending, it deepened lower and spoiled the workpiece. And I also lubricated the lead screw after that, the problems with losing step along the Z axis disappeared.

Problem solved.

So the issue was when i changed the table and retightened all bolts it appears i tightned the bolts that hold the skate bearings on the z carriage to much. After losening the bolts back up some it works again

1 Like