Z axis problem

I finished everything on the MPCNC and I have been testing it and the Z axis will be going up and down fine but then every so often the threaded rod stop turning and it sounds like the z motor wants to turn but can’t because something is blocking it from turning. To temporarily fix this I have been unscrewing the pineapple cuppler from the threaded rod and putting it back on again. I have tried buying a new rod thinking that the one I was using was bent somehow. This worked for a while until I found another little problem and I had to take the z axis off to fix that then when I put the z axis back on it started doing the same thing as with the old rod. Would anyone be able to help me?

If the rod is not bent, it could be a simple alignment issue. Also, I have found that sometimes you need to break it in a bit but running it up and down a few times from min to max. Also, a bit of white lithium grease on the threaded rod while doing this helps. On my last Z rebuild, I had the exact same issue with the rod binding. Bring it all the way up, swipe some grease (do not need a ton) along the length of the rod and then use Repetier (or whatever control sw you use) to run it up and down several times. Unless there is a gross misalignment, it should smooth out.

1 Like

Can you turn it very easily by hand all the way up and down? The most common problem is bearings to tight, followed by coupling nut out of line, you also could just have a bad threaded rod. connect it all up and run the entire length up and down with your fingers turning it and check for any slight dragging.


After that tell us how you are telling it to move and how fast?

I can turn it by hand when the motor is able to turn if that makes any sense. I have checked to see if the coupling nut is out of line and I don’t think it is, where would the bearings be if they were to tight? I have been telling it to move in repietuer host by using manual co trip in increments of 10 mm. I don’t know how fast it is going and I am out of town right now so I can’t check. I haven’t changed it however from the default setting. Tomorrow I get back in town and I will try the grease, running it up and down with my fingers, and find how fast it is going.

The z-axis feed rate is set to 480 mm/min/ I have turned the thread rod along with my fingers all the way up and down without the pineapple coupler connected to it. With the pineapple coupler connected I can move I can barely move it sometimes not at all. I haven’t gotten hold of any white lithium grease yet but as soon as I do I will but that on the rod if you still think that that will work.

Sounds like you need to pull the center apart and re-assemble something is cockeyed.

There are feed rates, and Rapid rates you have to set them both. I have instructions with pictures and highlights in the basics page… 480 is pretty much top speed and the lowest power, maybe slow down a bit. But it should be extremely easy to do with your fingers so you gotta find what isn’t straight in your build first.

So now I have tried my best to line things up. I am able to move it all the way down now with my figures however when I go up it always gets hard to turn at about at 80mm. I have tried to move the z-axis with the motor and it does the same thing going down it is fine but it always gets caught going up at that same spot. I have noticed if I try to push through this spot by moving the rod it gets really hard to move and if I try to move it by motors the coupler turns but not the rod.

Do you have a bad threaded rod? Flip it over and try again, see if that helps. I had a failure rate of about 40%, that is why moving to T8’s was a smart business move for me.

If I needed to change to the T8 would all I need is the coupler?

And the T8 nut, some M3 screws, and a new xyz part, https://www.v1engineering.com/t8-leadscrew-compatible-parts/.


So I have flipped over my rod and it is a lot better. However some time when I go up in a different place every time this has happened and it has only happened like twice. The coupler will turn but the rod does not. This leads me to think that the coupler does not have a good grip on the threaded rod and I should print a new one of swich to the T8. Is this assumption correct?

Clean it real good to get the grease off and use some super glue or thread locker. If it is an alignment issue you will have the same exact problem with a T8.

Have you verified that you are not trying to move it to fast yet. As I have said a few times now, 480mm/s is a max speed with minimum power, you get a lot more power at a much lower speed.

This sort of issue is extremely difficult to help without actually touching the machine. It should always be extremely easy to move with your fingers, when in working condition connected to the coupler if it is not then you have an issue.

Ok so I have put thread locker on the end, put a small amount of grease spread evenly across the rod, and changed the speed to 380mm/min. This has seemed to mostly work. I made the z-axis go up and down about 20 times and it hasn’t stopped or done anything else. I few times though it has made a small and brief sound of it catching (or at least that it what I think the sound is) I happened only like two times although I wanted to stop it. Would I just put a tiny bit more grease on it? Or do you think it is fine?

I have just now found another problem. When I try to heat up my nozzle my printer tells me this,“Heating failed PRINTER HALTED Please reset” I am not sure what to do would you be able to help? Here is some pictures of the LCD screen.

I think you need to take apart the center and put it back together, there should be nothing but smooth motion there.

As for the heating, that is a safety feature, if the temperature does not change then it shuts down. Something is not plugged in correctly.

With out a bunch of pictures and more information I have no idea what you have going on there.

You really really should not start with 3D printing, you should do a few drawings like my instructions show so you can test all the mechanical aspects of the build, the extruder is a whole new layer of complications.

So I guess something was unplugged I unplugged and plugged everything and it works now. I will work on taking the z-axis apart and putting it back together again latter today. Is there anything that I need to absolutely make sure I am putting somewhere?

Just make sure the tension bolts are as loose as possible while keeping the rails square. I have never needed to tighten the 5" bolt, pretty sure one of my machines doesn’t even have a nut on it.

So I have finished taking it apart and putting it back together. It has worked really well I haven’t noticed any touching. I don’t think there is anything else left to do on my MPCNC. Thank you for all the help. My last question is about a light. When I turn on the print fan or heat up my extruder this light will turn on and I have even one time seen in blinking. I haven’t seen a light like this on any of my other printers can you tell me what it is for? Thanks!

It means the extruder heat circuit is powered.

Thank you for that. I tried to print just to see if it will move and I found when I load a object in repeteir host and push print with the extruder heated up it will automatically say print finished and I know sometimes that print might be to small to register so I scaled it up and it still did the same thing.