Z axis only goes down

I have two issues with the Z axis

1 - so I have my board communicating with Repetier host. cables are plugged in correctly but…
My Z axis only moves down.

I’m in manual mode and give the Z axis the positive and negative command. but in both cases it only goes down.

2 - In addition to that, when the Z axis moves there is a grinding sound. do I have something too tight? Out of alignment?

Does it go down when you send it up, or just stay put and make the crunchy sound?

You are probably skipping steps. What controller do you have? Did you get it from Ryan? It could be a wiring issue. Does the Z move smoothly by hand? And is the coupler tight?

It goes down when I send it up and makes the crunchy sound.

I did notice it plugs into the mini Rambo very loosly and the z axis plug was not fully seated. Could this be part of it? I’ll check that soon.

Everything is from Ryan

Coupler is tight. Z axis moves smooth by hand.

So it’s definitely the connection at the mini Rambo. I repluged the z-axis. Tried it again in the z-axis worked fine but I must have a loose y-axis. The y-axis is now a chattery.


So definitely the connections at the board. I found I needed to press a bit harder, plus I added a small dab of hot glue on the plastic parts to keep it from popping out; something we do on servo wire extensions for rc planes.

I raised the z axis up a bit and ran the crown test and ran fine.

Now on to more test and practice!!


Successful crown test


Same problem here,

@riptyde what was the connection error do you recall? I will double check my connection.


Wow, that was a few years ago. Looking back at my post I think it was simply that I didn’t have the connector on all the way and need to push them on more.

1 Like

Appreciate the input! :smiley: