Z axis completely off!

So I’ve bought the kit from here, so the drivers and firmware were all set up already.

The X and Y axis work great, however the Z axis is way off. When estl reads that my Z axis has moved 50mm in either direction, it’s really moved 25.

There is no slipping or binding occurring. I’m using allthread. One rotation moves the Z axis about 1.4mm if I move it by hand, which seems to be correct.

Any help would be much appreciated!

Are you using the EstlCAM firmware or the firmware I provide? How are you telling it to move 25mm?

I suppose I’m using the Estl firmware because I’m controlling it through that software.

I zero the Z axis, then bring it up (or down) one inch using the Estlcam controls. Instead of reading ~25.4mm, it’s somewhere in the 50-60mm range.

Did a test cut. Wanted to go through 1/4 plywood and set the depth of the cuts to ~7mm. The software displayed that it made it down to 7mm, however again, it only actually went ~3mm


Seems like the motor thinks it’s moving the axis more than it actually is. I’m brand new to the electronics side of this though so I can only guess…


That means your settings for that are incorrect. You would need to do the math to get the right numbers or do as large a move as your axis can handle, change the settings, measure to verify.

You will have an easier time using my recommended way and you can follow all my tutorials. To do that you will need to re-flash the firmware on the board. Estlcam is fine but you will be locking yourself into it, most of us use multiple software for various tasks, my firmware makes that the easiest to do.

I am pretty sure I put the correct setting on the estlcam firmware page, second post.


2x is suspicious. It might be that your steps/mm are off by 2x, or that your drivers are configured for 1/16th stepping instead of 1/32nd stepping.

I’m assuming this is a ramps board, so if you’re using drv 8825s, then you might be missing a jumper underneath the driver.

If you didn’t mean to run the EstlCAM firmware, the instructions are all meant to start with Marlin firmware, but using EstlCAM just to create the gcode.

Sorry 3rd post and you need to remove a jumper or two as well.






You guys were right, I had forgotten to put the Z in 1/4 stepping. Once I removed a couple jumpers, dimensions became normal. Thanks for the help!