Y Axis not moving

Hey guys,

I tried to use my machine to cut out a part today and all of a sudden the Y-axis isn’t moving. The X and Z are working fine. I’m having the same issue whether I’m using gcode or manual control.

I Purchased all parts from here. Rambo board and I’m running Windows 7 with Repetier.


I’d check the connections, to both motors and end stops if you have them. Are you wired in series? Dual end stop? How about a picture of the wiring and the board.

1 Like

A similar thing happen to me a few days ago with the minirambo board. I swapped the X and Y leads on the board to see if the problem stayed with the channel on the board or followed the wires and and motor. Turns out the problem was the channel on the board. I reprogrammed the E motor channel to be used in place of the Y motor. Takes some Arduino programming skills to do this.

I just tried flipping the X and Y connections on the board. This causes the Y axis to movie when I send X commands but the X then doesn’t move. This leads me to believe that the board is fine and the problem is either the cables or the stepper motors. Any suggestions for troubleshooting further before I replace both of those?


No end stops btw.

Not really sure how it’ll help but here’s some photos.

Just plug in steppers directly no wiring harness. See how that goes.


Derp! Oh yeah.


Well that hat worked like a charm. All steppers are moving now. Just need a new harness.


Thanks everyone!

Just double-check it there’s probably just a loose connection