X2 motor loses step at same position

Hello all,
It is my first post in this forum because I didn’t fond any answer to my problem…
I used my MPCNC since now a little bit more than 2 years and everything worked well since 2 days ago.
I have now a trouble with my X2 motor…
Between 0 to 150mm the motor loses lot of steps and after, between 150 to the end (650mm) there’s no issue.
I changed the driver drv8825 because I broke it when I tried to ajust the Vmax value. But nothing changed!
I disengaged the belt and no issue with steps loose. I think issue occurs only when there is to much load on motor and so maybe the motor has to be changed…
One more reason of why I think of motor trouble is that 2 weeks ago I tried to mill wood and after 5 to 10 minutes everything goes bad and for sure the MPCNC had to work in very bad conditions…
I want your point of view before trying to reverse two motors because I didn’t used electrical connector but directly welded wires and it is quite long job to do.
Hope my question is clear because I’m french hobbyist…
Thanks to read and help me!

Hey Arnaud, maybe the belt somehow lost or stretched the teeth at that point?

Hey Philipp, thanks for your answer.
I don’t think it is due to belt or pulley because I change the pulley with a new one and I reverse the belt (good side without steps lost where place on the side where there are steps lost ). Don’t know if I’m clear… :joy:
And the trouble doesn’t disappear!

Can you take pictures of the CNC please? That might help, because I don’t have another idea. :smiley:

Obligatory “check your grub screw” suggestion to make sure one of your pulleys isn’t slipping on the motor shaft, but I’d expect the issue to crop up at each direction change for that motor.

Even if the screws are nice and tight, I’d still be looking for something mechanical. Are the cables hooking or catching on something? Is there flex that could be causing an intermittent issue at an extension connection? A bad link in a drag chain? Is there a piece of debris stuck somewhere?

Hello Tom,
I checked all the screws on pulley and there was no issue with them. It was the first thing I checked because I already had this kind of issue previously on another motor.
I checked and disassembled all parts at the begining because I thought for a mechanical problem or a debris blocked in the mechanism but found no issue.
That’s why I think it is maybe the motor but not understand why it is Always at the same positions…

Below some pictures :

I wanted to share a small video but it seems not possible… If yes, please explain me how to do. Thanks! :wink:

Can you inspect the X2 motor wires to be sure one hasn’t fatigued at one of the welded (I assume you mean what I would call “soldered”) joints? If the problem only occurs for part of the length of travel it’s probably in the wiring rather than the motor. The motors are very simple collections of wire coils, magnets, and bearings - not a lot to go wrong inside them.

As far as videos go, I haven’t done it myself, but I think folks upload them somewhere that hosts them (like YouTube, etc.) then post a link to them.

You can’t post a video directly to the forum, but you can create a YouTube video and then post the link to the forum.

It seems you found my issue !
I touched and moved the cable chain during the X displacement and sometimes the default disappear! And another time it appears at different positions on X.
A long work to disassembled and checked all soldered connections awaits me…
I will give you the feedback in few days!
Thanks a lot for your time and all answers…

1 Like

Glad you’ve got a handle on the issue. Sorry you’ve got so much work ahead to get it fixed.

Finally I could found some time this evening and found very quickly the bad soldered connections and could repair it easily.
Now it works fine!
One more time thank you very much everybody for your very quick help and support!!!

1 Like