X-axis stopped homing on RAMBo v1.4 with command

Suddenly X-axis (X1-stepper motor) won’t home, but X2-stepper motor does. Both X1 and X2 will move using jog-function but as soon I hit homing for X-axis or G28, X1 will not move. Switching places with X1 and X2 connections on the board confirms no problem with stepper motor.
I’ve had this issues before but it was always resolved by turning the power off and on again 1 or 2 times. This time it won’t solve the issue. I’ve tried downgrading (Marlin firmware but it’s still the same. Been using Marlin 2.1.1 (515) for 6 months.
How is this possible?

RAMBo v.1.4 Dual Endstop
Repetier-Host 2.3.1

What does M119 say in a terminal in like repetier host?

With M119 it says X1endstop is triggered and others are open. Switched places with X2 endstop on control board but didn’t solve anything. It seems like X1 endstop is faulty.

You can recompile the firmware to have X1 use a different pin.

I have never actually heard of an endstop pin dying other than shorting it to the 5v pin on the opposite end.

Today I switched places with X1 and Y2 on the trucks and suddenly the (faulty) endstop started working again! smh…

That is good news. Must have been a bad connection somewhere.