x-axis not consistent

Hi all,

I tried to make some simple cuts tonight. I needed some shelves cut out of 5mm oak ply so I loaded a DXF from Fusion360 into Estlcam and created a simple part. I then used tile to repeat the cut 3 more times (see screenshot).

The actual cuts look terrible. The y-axis movements look pretty consistent in each part, but the x-axis movements are way off-- maybe 1/4" in some places. I’ve included some photos of the four pieces after I pulled them off the table.

I used the square check v2 from Thingiverse to get the machine square and then used the menu to move to my desired 0,0,0 and restarted the miniRAMBo to set the origin. Watching the x-axis movement, it did appear to sometimes ‘hiccup’ momentarily, although it was hard to tell. When it did, I couldn’t see if it was just the stepper stopping or if the belt was slipping, although I would find that hard to believe as I have the belts fairly snug. (Perhaps too tight? I never could tell how much ‘give’ they were supposed to have).

Thanks for reading and for your suggestions.

How far off from square is your machine? You should be able to easily set it square by hand. If you have to pull and hold it you might need to take it apart and put it back together more squarely.

I really can’t tell but those cuts are way off something is wrong for sure. My kit and firmware?

How does the crown test plot come out?

Something definitely is wrong. You’ll find it.

It looks like you’ve got the DOC set to 3mm, so it took two passes? Not many problems are that repeatable, so it would be good to know if it was two passes or just one.

Running an air cut (turn off the router and run the program in the air) might show off any binding. Use the same square technique, because as Ryan said, if it’s far off, and the motors are holding it square, that could cause binding.

If it was just a squareness issue, I would expect parallelograms. That pattern looks more like skipped steps.

Also check for loose lock screws on your motor gears. Check for loose wires. If one coil has intermittent connections, that can cause skipped steps like symptoms.


I just measured my machine and it’s 40.5" per side and 57" corner-to-corner. If it’s not square, it’s pretty close. When using the squaring tool, I manually slide the rails into place without much resistance and they seem to hold in place just fine. I then move +20mm in X and Y so that the squaring tools fall and move them out of the way.

It’s your kit and firmware, with just a couple changes to enable the laser on the miniRAMBo board– nothing that should change the regular cutting jobs. I haven’t tried the crown in a bit, but I will try that next.



Correct. There were two passes. The total cut was 6mm, as I was cutting 5mm ply (is 3mm DOC too much for a 1/16" bit? It’s about twice the cutting diameter). I agree that it seems to be skipping steps. I’ll try the air cut as well and check to see if everything is snug and wires are making good connections. I had made some bad connectors before and so I would definitely recognize the sound of the steppers grinding due to intermittent connections if it happened for more than a moment or so.


thank you both so much for your help!


Another thought: would the belts being too tight cause missed steps or binding? I recently removed these belt tensioners (https://www.thingiverse.com/thing:1833934) as they were starting to slip, and just went back to the cable tie method. It’s entirely possible I over-snugged the belts at that point. I’m very unclear on how loose or tight the belts should be. Is there a way to measure the tension?


thanks again.