X Axis fitment

right, but I didn’t skip the slot below when I put in the stepper drivers

1 Like

You are not supposed to.


1 Like

Damn I"m the worst.

Sorry. Dunno why that seemed out of place.

Must be pretty funny to everyone. I literally can’t get this stuff even when I’m sure I’m learning.

Just turn off notifications for my thread if you can. Thinking how annoying it must be makes me wanna kick my own ass for real.

The lowrider is really cool though so cheers for designing it bud.

There’s a community member here that goes by Bright. Be good to Bright!

Everyone learns and solves problems in their own way.

I won’t be turning off notifications because the threads are here for the community to provide help to oene another.

Keep posting as you go and we’ll keep helping. You are pretty close to having a functional LowRider.


We all learned this stuff at some point.

Slow down, read through every step, look at the pictures, try to enjoy it, post questions. That is exactly why we are here.

When you are up and running come back to the forums and help the next builder that gets stuck…you will be a pro in their eyes and they will never know you had issues.

You keep bashing yourself but the fact that you’ve decided to tackle this project, and you’re making consistent progress proves you’re not an idiot. This stuff is not intuitive and no one gets it right away. It isn’t dumb to learn. Please be nicer to yourself.


You’re almost there! Before long you’ll be building parts for that Road Glide in your workshop!

1 Like

Thanks man. Just feel like Ive taken too much of everyones time already. I have been working on it all day.

  1. I have movement.

  2. The info recognizes the lrdualendstop firmware and machine as v1lr3

  3. Just playing whack a mole now after a complete tear down today when i realized my z1 lead was upsidedown. #ughfml

Gere are some pics. Not getting any faults or anything but still just cruising right through my endstops. Having to rip the plug each time.

Problem#2 is I cant get pronterface or anything to connect. So just using the tft for now.

1 Like

They shouldn’t be directional.

Nobody is forced to help, we are all here to help don’t worry about us.


OK, so you can send M119s.

With the machine not running the router, and X and Y somewhere out in the middle of the machine, do this:

One endstop at a time, press and hold in the endstop. (or blue tape) and Run M119 before and during each endstop press. What do you get?

They say triggered i can see them light up correctly too. They just have ZERO affect in stopping travel

is this smehow the wrong boot?

I don’t think they’re supposed to except when homing.

1 Like

Ive tried both, but mainly just homing. But ya i tried all axis with my finger too

Full video of current status

If you have the Y or Z endstops switched, then the Y1 motor will touch the Y2 endstop, stopping the Y2 motor. But the Y1 motor will keep crashing through. Check that the endstop for Y1 is on the side of the motor connected to the Y driver and the Y2 endstop is connected to the motor wired to the E0 driver. Same for the Z.

If the motors are moving in the right direction, and you have the right answer in M119, and you have them wired to the correct motor, then there isn’t really anything else that can go wrong (when homing).

And the endstops are ignored unless you are homing. So don’t expect it to stop from a jog command.

One more thing- make sure that the axis doesn’t hit and bind on some other part of the machine before the enstops triger.

Edit- I wonder if the forum hiccupped… I swear there were posts last night about not needing to mess with firmware changes- but those are gone this morning. At any rate, don’t mess with trying to change or flash different firmware.

It can seem like they aren’t stopping movement for Y and Z if the Y1 motor is at the Y2 endstop or the Z1 motor is at the Z2 stop.

If they are moving the right way, try switchjng the Y1 and Y2 motor or the Z1 and Z2 motor.

At this point Ive done all those things. I probably have put over 10 hours into trying to figure this one part out.