What do these light flashing on Rambo board mean?

Hello. I have a Rambo board that I flashed with grbl. When I try to connect to easel and select the correct com port. These two light start flashing but it will not connect. Does anyone know what these lights mean? I am new to cnc router and I have an mpcnc. Not sure why it won’t connect.

In the top picture, those are a status and power LED. I believe that the power LED is the one closer to the USB port

In the second, those are labelled as Tx and Rx, and probably for serial data, though maybe for the CSP.

Note that you might be connected to the correct port, but if the baud rate is wrong, you won’t see anything useful on the line.

I have no idea what the correct rate would be for a GRBL flash. The V1 maintained firmware is Marlin, and would require a baud rate of 250000. Anything else isn’t going to connect properly.

I’d try different baud rates, start at something slow, like 9600, and work your way up the commonly available choices (9600, 19200, 38400, 57600, etc.) using a simple terminal program and keep trying to send a query to the board until something answers. Or else start looking through your GRBL source for whatever serial port rate you have selected, and try that. It’s also possible that you don’t have the communication serial port enabled, or you have a different port enabled. There are more than one, and an unenabled port isn’t going to respond at any baud rate.

Thank you for your response. I tried using different baud rates using universal gcode sender but none of them seemed to work. I read online that 115200 is the rate for grbl but that does not work either. It says connected but I can not control the cnc. You also mention “It’s also possible that you don’t have the communication serial port enabled, or you have a different port enabled” how would I check to see these? I also tried to use the setup wizard in UGS but it says "The setup wizard is not supported for this controller. I tried re flashing my board to grbl but it says it timed out.


If Easel says its connected then it is connected, your problem lies elsewhere. Is your power supply connected and working? Are your stepper drivers inserted the right way around? Is the on board fuse ok?

Which version GRBL did you flash?

When you use UGS you should see the console replies from your controller when connected - that indicates what is going on…

Easel never says connected. The carve button never changes color. Before I flashed the board with grbl I was able to control the cnc using repetier. So I believe the wires are correct. I’m am honestly not sure which grbl it is. I just googled grbl GitHub and downloaded the first option. Now when I try to upload grbl again I get an error message. I have included a picture of the error message. When I connect to UGS the only message in the console is that it is connect to the com at the specified baud rate. But I can not jog the machine. When I use the setup wizard it just says setup wizard is not supported for my controller.

That is the problem then. The Rambo isn’t the target platform for grbl, an Arduino uno and CNC shield are. You need to get a fork of grbl for the Rambo.

What is the reason for using grbl over Marlin on a Rambo?

I am trying to use easel and easel only uses grbl I believe. How can I get a fork of grbl for Rambo? I will honest with you I am not even sure what a fork is.

A “fork” is when someone makes a copy of the code, edits it, and the results are not incorporated into the main project.

In this case, grbl was copied and edited to work with the Rambo, but the changes were not brought back to the main grbl version. The consequence is that the software has a lot less testing (grbl has hundreds of thousands of users, the fork has significantly less, maybe a few hundred). Any updates or bug fixes on the main grbl may not be fixed in the fork. Bugs introduced in the edits on the fork may not be found.

Support in the main branch for many many boards (including the Rambo and skr pro) are a big benefit of Marlin.

I have not tried it, but I think there is reasonable support for exporting gcode from easel and use it with Marlin.

That said, there is a long post here where people have gotten the fork to work and others haven’t:

The code is called “grbl-mega-5x”. I am not sure which fork is the best, or if anyone is trying to keep it up to date.

Thank you. I will try to reflash with that version to see what happens. When I was flashing grbl originally I kept getting a timeout communicating with programmer. Is this because I was doing something wrong? If so are there ways for me to fix this?

The timeout happens if it can’t talk to the microcontroller bootloader. With the Rambo’s, the most typical problem is trying to flash it over USB, but not powering the 12V side. The Rambo needs 12V, even to flash.

Nothing needs to be erased or anything. It is usually pretty simple.

I always have the power plugged into an outlet as well. It’s never just running on usb. Just as a test I unplugged the usb but the board remained powered on. I thought maybe the power cable had issues.

I just tried to flash the grbl that support Rambo but every time I upload it after a few moments it gives me a timeout error. Is cnc router ing suppose to be this frustrating or is that just an added benefit to keep the heart rate up? After doing some research I keep coming across issues with boot loader. How could I check if that’s the issues? Also how can I re install a boot loader?

99.9% sure your bootloader is fine.

That is the timeout message that it can’t talk to the bootloader. Make sure you have the right com port. Make sure your fuses are good and you don’t have it on a conductive surface. Try a different USB cable.

No. This is extra frustrating. We try to make it simple. But the way we do that is with Marlin and not with grbl. Nothing wrong with grbl. But grbl on a Rambo is not simple.

But your timeout issues are not anything with grbl. So we have to figure those out first.

The Rambo’s have an atmega 2560 (same as an Arduino mega) doing most of the work and they have a 32u2 for the USB. I hope the first experiments didn’t manage to change the firmware on the 32u2. Although I don’t think that is possible without trying very very hard. That is the 0.1% chance.

Let me also say, you can get an Arduino uno with a CNC shield for very cheap. It will not do auto squaring, but if you want grbl, it is an easier way to do it.

I recently noticed when I plug the 12v power cable in there is a yellow spark. It only happens when I plug in the cnc power cable and not with any other plug. Is it possible that is what is causing the timeout errors when I try to upload grbl onto the board? I have ordered another power cable to test this but it won’t come in for a few days. Also. Would it be possible to flash marlin back onto the Rambo board and order the arduino uno with cnc shield to run grbl? Kinda go back and forth as needed?

It would be. But not if the Rambo is broken.

That doesn’t sound good. Where does it spark? Jumping across an air gap (even a small one) requires a lot of voltage. A lot of voltage can find other ways to get to ground.

1 Like

At the plug end. Not the board.

1 Like

I get sparks on a number of power supplies when plugging them in to the wall. I don’t think that’s likely to be a factor in your flashing difficulty.

Remember that only one program can “talk” to a particular USB peripheral at a time. When flashing, you’ll want to be sure that Repetier and Universal Gcode Sender are both disconnected from the Rambo controller. I used to forget to disconnect Repetier all the time when experimenting with settings on my 3D printer.

1 Like

If I just turned on my computer. Haven’t started repetier or UGS yet. Could they still be taking up the port? And if so how would I go about disconnecting them? Short of uninstalling them all together. Because I have had trouble uploading even when the only program I opened after starting my computer is the Arduino program. Nothing else.