What am I doing wrong?

I’m learning the ropes from a software perspective so this may be a dumb question…

I’m doing some helical drilling and the tool path is not what the preview suggests or what I was expecting. I made this video to better show what I’m dealing with:

As you can see, both ESTLcam and Repetier suggest the too will follow a spiral path from the middle of the hole. But the tool ends up following an odd pattern which results in a not-so-perfect hole…

On a side note, I’ve tried several times and on some tests the router travels way too fast during the cut… odd, it seems random when using the same settings over and over.

Any suggestions on either issue?

Have you tried Ryan’s crown test yet? You’re right though, that’s not right at all!

Yep, crown was perfect. Also the LCD side panels in foam came out good too… no issues there. Here’s an earlier video:


I wonder if Repetier is overriding the paths because of a bad setting somewhere…

Try the other option for arcs in estlcam.

In Estlcam, Setup, CNC Program, checkbox down at the bottom.

Thank you both, I will test that tonight.

So the Arc Commands option does indeed change things, however neither option produces the desired outcome.

Arc On: Odd path
Arc Off: 1/4 of the circle - correct path

Here’s a video to better explain it. I am carving a 20mm diameter hole, 1mm deep for the sake of testing:


That is no where near correct. I can only suggest double checking your estlcam settings vs mine. Something must be wrong with your gcode generation.

1 Like

Really appreciate it Ryan, I know I’m going to kick myself when we find the issue…

I’ve uploaded both GCODEs with ARC Commands on and off. Both appear to generate the correct tool paths when uploaded to ncviewer.com

Estlcam configuration settings to follow…

20mm-Helical-Drill-ARC-OFF.gcode (128 KB)

20mm-Helical-Drill-ARC-ON.gcode (31.2 KB)

So far it looks good, but not the same as you are seeing above.

[attachment file=“path r.PNG”]


Here are my Estlcam settings


ESTLcam-Settings.zip (616 KB)

The other thing I noticed is that when I start a job, the tool starts about 1mm higher than I had set the starting point. Not sure if this is a safety measure built into the system which is added to the depth of the cut, or if my cut is actually 1mm short as a result… It’s visible in the above video when the tool starts routing the hole above the foam.

…obviously a minor issue compared to the above but may or may not be related to incorrect settings somewhere.

What control board and LCD are you using, And how do you control it, meaning what program do you “start” the gcode from?

I just purchased the kit from your site a couple weeks ago (I’m the one with the faulty STOP switch that was an easy fix). So it’s the RAMBO board with I believe the only LCD option you had available on your site. I chose the dual endstop option. I did not change firmware or anything else on the RAMBO board…

I’m using Repetier Host to initiate the job. I was wondering how to use something else just to rule out a possible issue with Repetier… can I just upload the GCODE to an SD card and print from that perhaps?


The issue is your gcode. you have not done a zero offset because of your dual endstops. It all makes sense now. You are centered on zero, meaning it will not move negative, you will only ever get a pie shape that way.


1 Like

I just kicked myself…

So the gcode with the ARC Off did actually work correctly, it’s just that I was trying to set the starting point in the middle of the circle.

Is there a different way to initiate a job using the center of the work piece or center of a cut as the starting point?

Yes, not using dual endstop firmware. You can also turn off the softstops, if you update the firmware I have just added it as a LCD option in the menu.

1 Like

Thank you Ryan, I really appreciate your assistance!!

I’ll update the firmware as I believe I do have some use scenarios where I need to start from the middle of a work piece.

Your welcome!

If you are going to update, wait a few hours if you can I am literally doing some last minute firmware revisions right now.

I’m actually going to do a little more cutting as is before upgrading. Now that the ARC issue is resolved, I want to make sure everything else is running well before making any changes.