Weak Motors

So I’ve had this issue for a while now that occasionally one of my Z motors seems to be weak like its not getting enough current. When it happens seems to be random. I mess with stuff for a bit and it seems to start working again. Fix seems to have something to do with running an M502 then an M501 then a reboot but nothing in my config file has changed.

When its working normally I keep the current set @1100ma for both Z’s and it has no trouble pushing my hand up with about 5-10 lb’s of force. on the gantry. When the one Z fails it skips steps just trying to lift the gantry. If I up the current to 1400ma it acts like normal but may overheat. The other Z works fine.

Without load the motor works fine, no jittering like a loose wire would cause. If I cut the power I can easily turn the lead screw by hand. Grub screws are confirmed tight. TMC thermal protection doesn’t seem to be triggering.

TMC-2209 Drivers

Any ideas?

Using Nema 76oz from V1E, or something with same specs, Nema 17 76OZ/in Steppers – V1 Engineering Inc ? Cleaning and lubing my (LR3) leadscrews almost doubled the max Z speed I could move before stepper started skipping. Going from 12V to 24V helped too. Haven’t measured stepper temp difference between those voltages, and didn’t tweak current much if at all.

Downside is that the gantry crashes down when not powered, or is reset. May end up frustrated into editing firmware to do something smarter.

Are the TMC’s throwing any other codes like OL when this happens? Going randomly from tons of lift to almost no lift makes me think there is an intermittent connection somewhere… or perhaps a bad motor winding. Have you tried swapping Z motors to see if the problem follows the motor?

1 Like

I too have noticed the exact same thing. The Z is the only real issue I have on my lowrider

Yeah they are lubed and turn easily by hand. Gantry drops when unpowered

Not seeing anything come up in terminal window, M122 code not showing anything tripped and current values look good.

I swapped out controllers but not motors. I’m afraid I over locktited my grub screws (red) and they arent coming off without a heat gun.

This was my first thought but I don’t see how the motors would be running smoothly if a wire was loose. Normally a bad wire causes the motor to vibrate and make a distinctive sound.

Jeremy, probably better to make your own topic with details of your build. The root cause of this could be several things and having two people providing info can really get us lost.

Those error codes get cleared when the problem goes away. At least, when the motors get disabled/reenabled.

From the symptoms, it sounds like it could be a loose grub screw, an intermittent wiring issue, or the TMC driver dropping the current because it is getting too hot (you can see the setting in M122). But you said it was none of those :slight_smile:.

At least my mind followed in the footsteps of greatness .

It wouldn’t surprise me if the overheat issue is the thing. I think the TMC drivers are set to run at 50% when they overheat which would explain the symptoms nicely. That would put my current at around 550ma which would definitely be weak. I thought the M122 would show the error but maybe they wont.

Somewhat related: Does anyone know how to make the M122 not go into an endless loop. I’ve tried S0 and S1 but it just keeps looping status updates until I reset.

M122 alone usually printed once and stops.

The current current setting is in the print out. If it is throttling due to heat, it would show a lower number. It also prints when it changes the setting, IIRC.

A while back my printer would randomly ruin a print from skipped steps on Y… no distinctive sounds ever, or any other good reason to skip (like a really rough top surface etc). It was otherwise perfect, often going several spools between the skipped Y steps. I saw no TMC errors (now I learn why no OL flags… seems marlin should print that to terminal when it happens). I went on for months pulling my hair out over it. This included wiggling connectors etc. I even replaced ramps, the mega, driver boards lol… it was bad. Guess what it was after all? An intemittent dupont connector. I hate those things!

edit: Usually it’s just the internal spring contact that gets bent a bit and results in this. A poke with a tack in the right spot, and the spring will return to normal. Sometimes it’s also a good idea to tweak them with pliers slightly, to make them parallelograms. Duponts are not a great design at all, compared to JST anyways.

Yeah I started getting pigtails because my success rate with crimping them is awful. I don’t like them or trust them.

Even the pigtails man… read my edit.

I used to hate crimping them as well until i watched @DougJoseph video. I got the same crimpers he used and now im at about 98% success rate with them!

1 Like

Also, in the description of that video, I link to a video by teaching tech on how to crimp wire connectors, and that video was a great help to me, in addition to getting the good crimpers.

1 Like

Heres the link:

1 Like

This is a bit tongue in cheek.

Q: How do you know if you got the good crimpers?

A: They look like a T-Rex!

1 Like

So it happened again last night ,same motor, same symptoms. Checked alarms and wires and found nothing. VREF via digipots looks good. But running at reduced power on one Z motor, other is strong.

Turned up the current via M907 from 1300 to 1500 and saved via M500. Restarted my SKR 1.3 and all was working turned it back to 1300 and resaved. All is still good and I continued cutting. Ran for about 20 minutes without an issue.


Sounds frustrating. Already swapped drivers to narrow down if thar’s cause/contributing? Checked driver heatsinks are adhered well? My heatsinks got knocked off by wiring wrapped in the opaque enclosure, using transparent one now. Using thermal paste instead of relying on the sticky tape my cheap heatsinks came with. You in a hot climate/space?

I think I’ve already tries swapping drivers but maybe I didn’t I’ll see if I have a spare. Heat sinks are attached and diagnostic is not reporting them as hot.

Which Z stepper? Z1 left, or Z2 right? Wondering at what point @jeffeb3 or someone would recommend swapping stepper (forum advice i often see is that the stepper quality is usually reliable, wiring/connectors are usually the foe)? Or, you’d be frustrated enough into ordering a new stepper. Swapping adjacent Y axis and Z stepper is probably more of a time sink PITA than ordering new stepper?