Voltage loss at E0

Might have a strange one:

I have a dual endstop MPCNC. Both Y motors work, the Z motor works, and the X1 motor works.

But the X2, plugged into the E0 port does not. I’ve confirmed that I have the 510D firmware running.

Here’s where it gets really weird: I get 12-ish volts from the port when nothing is plugged in. As soon as the motor is connected, the voltage drops to zero. This only happens to the X2/E0 motor. All the others drop from their unconnected ~12 volts to ~2 volts when the motors are connected.
E0 unconnected:

E0 Connected:

X1 Connected:

It’s a Rambo 1.4, btw.

Try measuring the resistance of the motors with the meter. It could potentially be a short somewhere in there (inside the motor, in the wires to the motor, or at the connector). You’ll have to do that with the motors unplugged, of course, or you’ll be measuring the resistance of the driver circuitry as well.


Getting 3.2 ohms from all four pairings across the two X motors.

Worth pointing out that both motors work fine when plugged into the X port. And neither work when plugged into the E0 port.

The drivers don’t directly send voltages, they try to send a set amount of current. The pins they use, and the direction of the current varies with the number of steps.

So I don’t think you can really trust a voltage measurement on the motor pins, unless you are using an oscilloscope and measuring both coils.

Have you tried plugging a motor directly into the E0 port? My guess is that it is a wiring issue and it may be intermittent.

I tried this morning before heading to work for the day.

Result: E0 had no movement when the X2 motor was plugged directly in without an intermediary ribbon cable. X continues to move without issue, regardless of which motor I plug in or how many ribbon cables are used.

Can you try swapping the stepper drivers? You might have a bad stepper driver on X2/E0. Trade it with one of the others (make sure you power the whole system down first) and see if the problem follows the driver.

I wish. I’m not using external drivers. This is coming straight off the board.

Sorry - I had just read another post where they had a RAMPS setup.

Hmm, so there is voltage present with no motor, zero with… and coils apparently have reasonable ohms. Have you adjusted current on this driver yet? I’m thinking if you have current set very low this might happen. If not, I suspect the driver ic may not be working properly.

If its the driver IC, then I either need to buy a new board, or see if Ultimachine can repair it.

I did check again that it’s running 510D. I’m going to try reflashing with the latest 513D, and if that doesn’t work probably buy a new board.

Sounds like a good plan. I wasn’t sure if you verified all the motors are working first. Before replacing the driver/board, make sure it isn’t just a bad motor by plugging it into a known working driver first. I figure ultimachine would just send you a new board, vs trying to repair a broken driver. If you end up keeping the old board, don’t toss it away… it can likely be repaired with hotair and a new driver some rainy day.