Very slow homing - dual endstops

So… I lost all my starting/tool change/ending gcode that I fine-tuned over the last year. For some reason, Estlcam decided to reset all that code back to factory-fresh. Meaning… it has no useful settings.

I have the dual end-stops and the Skr Pro controller. Starting with a simple copy/paste from @Ryan’s code from here, and adjusting my z probe thickness accordingly, it mostly works. But, when it homes X and Y, it pauses for about 30 seconds after hitting each stop. It seems like it pauses for about 30 minutes, while I’m holding the z-probe.

Can I tweak the code to speed this up? It didn’t used to do this, so I know it’s possible.


I don’t know what would cause that. That gcode looks pretty reasonable.

Do you have any .gcode files made from your previous setup? On the lcd sd or anything? It would have your snippets in the gcode files.

1 Like

Last night, I found that the long pause occurs if the gantry is close to the x/y stop. If I move it away from each stop before starting the job, it doesn’t pause after touching the stop switch.

It should back up if an endstop is triggered when homing. If it is triggered and you home does it back up and take a long time or just not back up?

1 Like

When you first posted, I was clueless, but Ryan’s post pointed out a good possibility. We’ve seen on this forum were electrical noise triggers endstops. If that is happening while you are homing, you get a false trigger away from the endstop, then the homing sequence backs up (default is 5mm), and then very slowly the homing code retests. But since the false trigger was away from the real switches, you get a very slow movement for a long distance that eventually succeeds when the endstop switch is triggered.

If it is electrical noise, see this code in configuration.h:

 * Endstop Noise Threshold
 * Enable if your probe or endstops falsely trigger due to noise.
 * - Higher values may affect repeatability or accuracy of some bed probes.
 * - To fix noise install a 100nF ceramic capacitor in parallel with the switch.
 * - This feature is not required for common micro-switches mounted on PCBs
 *   based on the Makerbot design, which already have the 100nF capacitor.
 * :[2,3,4,5,6,7]

You can play with enabling and setting ENDSTOP_NOISE_THRESHOLD, or you could go with the electronic solution of a 100nF capacitor.

Sorry, I’ve been AFK for a few days. I’ll shoot some video later. It isn’t that the endstops are failing. They work just fine. But, if the gantry is only a couple inches from either endstop when I start the homing process, there are long pauses after either endstop switch is triggered. The “fix” or work-around is to move the gantry about 6 inches or more from either axis endstop before starting the homing process.