V1Pi v0.18.0

New version of v1pi released

I tested the no-hotspot and hotspot versions locally. I didn’t do a full smoke test, running complete gcode files. But I am confident it should work as well as previous versions.

OctoPrint has had some big updates to the polish and dependability. CNC.js is version 1.9.23, which isn’t that new, but it’s new to v1pi. The biggest updates are to the hotspot/raspap side, which is installing flawlessly and seems very snappy.

I haven’t tested it on a pi 2 zero W, because they aren’t in stock anywhere, but it is based on the latest images, so I have confidence it will work. Raspberry pi 4 should still work as well.

Of all the projects, this one has some big impact for people. I understand that, but the work for me is generally either: It works, and it’s just testing left, or something is wrong, and it is really hard to fix. I plan on keeping an eye on this project in the future, but always remember that octopi is an option (that is really well maintained) and I can’t be trusted with any kind of schedule for updates. It isn’t abandoned. But I want to be frank that I will not be putting this work ahead of sandify, or my own personal making projects.


Thanks for putting in the effort @jeffeb3. It is absolutely fair for you to choose where you spend your effort on your several volunteer projects. I can say that switching to Octopi was a very easy swap, as I did that in order to get some holiday stocking stuffers printed.

Honestly, I should probably invest in another Pi and have one dedicated to the Burly and one for the printer, but they’re literally 3 feet apart on the bench in my workshop.

Maybe I’ll order a Pi 4 to upgrade my RetroPie setup, and that 3B can “trickle down” to a dedicated cncjs image. That way I can say I have a plan, but not be under the gun to get it implemented since the chip shortage may have things on backorder for a while.


I have tried it on my zero 2 W while testing, but I have not tried it with the latest version just released

I can confirm in a couple of days time.


I ran V1Pi/CNC.js on a Pi ZeroW back when I was building my Printed R&P MPCNC and it was up to the task then…

– David


Heck yes!

I did get an octoprint error but cnc.js was good on the pi zero w.

The Pi Zero W is pretty slow, I am not sure if it is a viable option. I would guess a Zero 2 is probably the minimum option these days.

My Pi3B ran smooth as can be with no errors.


The Pi-ZeroW is slow. While it seems to work in a simple use case, it really isn’t suitable in a permanent setup. I seem to remember using Octoprint with a webcam and playing with timelapse at one time… and while the Pi-ZeroW actually did it, it really “bogged”… and a Pi-3B did much better.


The Zero W 2 on the other hand, seems like a perfect combination of two worlds! Specs good enough to run most stuff, but a size that is really sweet to accomodate. And the price is not bad either.


Octopi do not recommend the zero, but zero 2 is good to go

Please note that the Raspberry Pi Zero and Zero W are not recommended explicitly since severe performance issues were observed, caused by the WiFi interface when bandwidth is utilized (e.g. the webcam is streamed), negatively impacting printing quality. See also here. The Zero 2 however is recommended.


Yeah. It does work, but it is weak, and adding in cncjs and raspap isn’t going to make it easier. Add in some plugins and you’ll find it rough.

I haven’t tried cncjs alone on a pi zero (w original) in a long time. Maybe that would be fine.

1 Like

CNCJS needs nodejs but nodejs stopped support for the version of arm that the older pi’s use. So depending on which versions cncjs keeps supporting the pi zero might stop working one day


The Pi Zero 2 has the same processing specs as the 3B. Only difference is 512mb of RAM vs 1GB of RAM on the 3B. I am currently working on getting CNCjs installed on my dad’s pi zero 2. I may give Jeff’s image a try as well on my Zero 2 (if I can get it working again). I can tell you that octoprint runs great on it.

1 Like

I did a bad.
I had 0.17 installed on a Rpi 4. Everything has been working perfectly for a long time.
So of course I decided to update all the packages and then attempt to upgrade cncjs to 1.9.23 myself.
What could go wrong?

A couple of hours later I gave up trying to get cncjs working again.
Downloaded V0.18.0 (Thanks @jeffeb3 !!) and installed.
Seemed to work out of the box but…kept getting the server disconnect error in cncjs.
Get another microsd card. Download and image 0.17 to see if it’s an issue with 0.18
Same problem.

Short story long…
Switched back to 0.18, deleted all the 5G wifi connection entries in the wpa_supplicant.conf file and left in the 2.4G one.
Rock solid…
Turns out having the rpi under a workbench in the basement makes for dodgy 5G and cncjs doesn’t like that.


Pishop.us just emailed me that the pi w 2 is in stock, so I should have one for testing soon.

They want 9 bucks shipping on a 15 buck board you can only buy one of! Guess I am cheap. That seemed excessive

It is. But it is still $24 for a fun computer.

There are also scalpers trying to sell them for $50.

I don’t believe in the idea of the judgement day, in a literal way. (I know I know, liberal protestants…!) But when it comes to scalpers, I really hope that they’ll somehow have to answer for their lousy way of making a living!!


I don’t mind “arbitrage” in general. When someone goes to a particular guard to access store and sells on ebay or Amazon. That is a valuable service, IMO. But when they buy all the stock of something and that gives them wild profits, it is out of control. Especially when it is something in an emergency.

I’m curious what you find with your testing. I installed this version and Octoprint seems fine, but if I actually connect CNCjs, eventually I get this:


Sometimes I can click on reload and it comes back up, but at least once the whole tab locked up and I had to close it.

I haven’t tried it on the pi 2 yet. I have it sitting in my desk, but I haven’t started it.

IIRC, that problem is mostly due to a network connection issue. But I haven’t seen it in a while. Are you using the hotspot version?

I’m using the one without the hotspot (v1pi-v0.18.0-no-hotspot). Testing in the same room my P3B+ has been running OctoPi for a few years without any issues. Perhaps I’ll pull that out of my printer and test V1Pi on it to see if its a problem with my setup (network or otherwise) or the Zero 2 W.

Test successful. Ran through a 30 minute gcode file with no issues instead of locking up after a couple minutes. Put the SD card back in the new Pi2W and it also worked consistently. I don’t have a good explanation when it had problems all morning and even reimaged the card.

1 Like