USB Device Not Recognized. Device Descriptor Request Failed


I am trying to put the firmware on my ramps 1.4 and got this error on the computer “USB Device Not Recognized. Device Descriptor Request Failed” code 43.

I tried uninstalling

I tried updating to a generic USB Hub

I tried disabling power saving mode

any ideas?



any help would be greatly appreciated

Mac or PC, what software are you using? Port, baud rate, different USB cord? Unfortunately that error does not point to anything specific.

Hello it is on windows 10 I am using a usb port similar setup to what is shown on this site to program the firmware for the cnc

now not so funny thing was when I plugged the usb into the usb port and then plugged the ramps 1.4 board in it made several sounds then never again did it make sound. I wonder if I fried it. baud rate no clue.

Your not giving much info, the picture you uploaded is a blank arduino sketch.

What are you doing that you don;t think it is connecting? What program are you using that says that, if it is Arduino what are you trying to flash? You need to set the port and board type as well.

I have a page with step by step flashing instructions.

Ok I am trying to connect this ramp 1.4 to the Arduino Software to put the firmware on it.
I did step by step of your instructions the minute I plug the ramps 1.4 in while the Arduino software is open the computer pops up with the message “USB Device Not Recognized. Device Descriptor Request Failed” The Arduino software won’t let me choose a port it’s greyed out.

Here is the step by step: However I can never get here because of the message above.

How to flash firmware on the Ramps 1.4
Install the Arduino software and its drivers before you plug in your board.
Unzip the firmware you need from above
Open Arduino
Sketch-Include Library-Manage Libraries
Type “U8glib” in the search box, hit enter, select U8glib, and select the number with the highest version, Install. This has never been easier.
Tools-Board-Mega 2560
Open the firmware folder and select the current .ino file
The bottom of the window will say “done uploading” when it is finished


Looks like your board is dead, I have never seen that message before.

You think just the control board?

Take the ramps off and try the board by itself to see if the ramps is the issue, but it could be the ramps that killed the Arduino. Hard to say. I have had both happen many times.

I can say the control board got extremely hot leads me to believe it is toast for sure. I will try what you said as well

You can also get that with some clone Mega boards that use a different chip for the serial/USB. You have to install different drivers for them. What COM ports are shown in Device Manager when the board is plugged into the computer?

Turns out my mega board fried. That the reason for com port issue but why did my board fry is now the question. I ordered a new mega board and installed the firmware so I’m moving forward. I do have a question can you have both the USB port and power plug in use at same time? Seems the USB port supplied the necessary power to program thoughts?

You can have usb on the mega, and power on the ramps, but not usb and power on the mega.

1 Like