UNO and estlcam wont carve

Hi all,

I have a month in on building not one but 2 MPCNC machines. I am using UNO and CNC Shield.

It draws and engraves but can’t get it to carve.
After 3rd layer it goes crazy and plunges the z-axis farther than I have assigned in the estlcam software. I assign 4mm and it decides to randomly go 15mm and obviously the steppers cant handle that so that’s the end of that piece of work. So I do another one at 2mm and it fine just not deep enough… I run the same settings just 4mm and after the 3mm layer if goes crazy again and plunges 15mm at some point. Also when moving from one “part” of the carving to another it will just decide not remember the Z-zero and just cut in mid air 5-8mm above the stock. I almost smashed it to bits with a hammer but I figure I should at least ask for some help on here after spending (Oh lets say) 5 weeks 24/7 locked in my hobby room assuming that I will eventually get this thing working. NOPE!

I have looked everywhere on the forum but have not found anything similar. I am at a loss after playing with settings for over a month. I have watched every tutorial online regarding MPCNC and Estlam and I think I might be learning a little german.


Anyways, I know you are going to ask for pics and code and all that stuff… I just dont know what to show you.

Pics show it draws, it cuts parts, it carves 2mm (crown above) but when I use the same sketch h and just tell it to go let’s say 4mm it goes crazy after first 2 layers (same crown below)

Thanks in advance. Mike

test-L7Crown-outline430x250.gcode (47.8 KB)

Judging by the feedrates in that file, your firmware uses a different system of spped so 2100 and 480 are about 120x’s too fast.

Try changing Z to 8 and XY to 20 for your rapids.

Changed the Rapids to 20 and 8 and tried again. Same thing. At some point it goes crazy. See latest pic after updating rapid

Here is the new gcode file for the last pic

test-L7Crown-outline130x8020mmf.gcode (723 KB)

Your Z is still at 480, also 20mm/s is kinda fast try 12 for the other cuts. You are using an UNO from what I understand he has optimized his firmware but it is still just an uno. You might also want to decrease your micro stepping one notch just in case.

Thanks Ryan,

I’m obviously new.

Im not understanding how my feed rates are causing the z height to go from 2mm as defined by the tool and setup TO 15mm in the middle of a layer? The UNO engraves, and plots fine.

I assume that your comment, “it is just an UNO” as that I Should I just get the other board? I’ve already bought just about everything on your website… I might as well buy the board also.

BTW thanks for the great shipping times on all my orders. I do wish you had other shipping options though… I like paying extra for shipping next day air. :slight_smile:


Anyways… could it be my actual crown drawing. I am finding broken lines and loops in Adobe Illustrator? I am also noticing that it seems to happen in the same place on the crown. (Center). This is driving me crazy. It is so frustrating to see a nice piece transforming then it just goes haywire and ruins it.


If you are asking it to move faster than is possible by the processor it will crash in random ways. We had this happen with his firmware already if you want to look through older threads. Even in Marlin faster than 8.4mm/s on a 32nd stepping driver was too much for the Ramps stack.

Use my gcode for testing.

Your uno will work but you went out on your own, I don’t know any other uno users. you have to figure it out and I will try to help.