Unknown command M80/M 221 s100

Im having a problem with my MPCNC it was working fine then after sitting for few months, I tried to cut something and when I hit print the router turns on but wouldn’t move. Then I started getting the error M80 /
M221 S100. I can manually move the router, it triggers it on but it doesn’t move.

I have flushed the firmware and uploaded the latest firmware.

Please HELP

Those commands are from repetier host. And marlin doesn’t know what they are. They are for turning on the power and turning off the hotend. But you don’t have either configured.

That is a long way of saying you can safely ignore those warnings. They aren’t your problem.

So what is the problem? Have you tried running the premade gcode from the test crown?

1 Like

What happened was that it was in the middle of a cut and it plunged, I had to do an emergency shutdown, and after that it just wouldn’t move when I upload the gcode. I have not tried the test crown again.

1 Like

Try the test crown for sure. Just to make sure the machine isn’t broken.

But also, give us some details on what controller you have, some pics of the controller and wiring. Hopefully we can figure something out.

Thank you for your input, I ran the crown and the crown works just fine. as soon as I upload my design, the steppers start making this weird noise but not move, I’m assuming my Gcode or something is wrong.

If the test crown is working, then it may be something with your code. Have you changed your CAM at all?

Stepper motors “sing” a little when they’re moving. Maybe they’re moving but very slowly? This can happen if your machine thinks that it’s getting mm/min and you’re sending mm/sec. In this case, the machine is moving but 60x slower than you expect. If this was a normally slow movement anyway (Say, plunging Z) and you expected 3-5 mm/sec, and are instead getting 3-5mm/min, it takes a very long time to even see that it is moving, and the motors will sing at you while it’s happening.