Trying to flash the firmware onto the rambo v1.4 with a MAC

Hi everybody

I am trting to flash the firmaware for my lowrider with the rambo v1.4. And When I try to flash the firmware, it flashes all of it, or at least the bar gets complete. IT then guves me error messages. What should I do?

How are you trying to flash the firmware? What error are you getting? Do you have 12V power to your board when you are attempting to flash the firmware? There is a known problem with using the Arduino IDE to flash Marlin, so Platforml0 is the common/best choice. There is a non-compile solution using XLoader.

1 Like

So, I tried to flash the firmware on with platformio, but when I tried to run the machine, it was still running on the old marlin, is there something I need to do to make it work and run on the new firmware that I suppositly put on the rambo?

If you see the old version of Marlin, then the flash was not successful. Flashing completely replaces the firmware. Are you getting any error when you attempt to flash with PlatformlO? Is the board powered up with 12V when you flash it? Are you doing anything special/different with the board? You might try the XLoader solution. If XLoader fails also, then you likely have a USB issue of some sort. If so, start by swapping the cable.

1 Like

To answer all your questions, I plugged in power, I did everything how the website told me to do and I got a successful flash on the platformio. I am going to buy a new use cable, and try it with platformio and if it still doesn’t work I’ll try the Xloader

But thank you so much for your help. If I still can’t get it to work by trying both of these things, do I have to buy a new control board?

I would just give it another shot. When it is done, it writes it, verifies it, and then reads it again. I am thinking you just compiled it and didn’t actually send it to the board. The two buttons are next to each other. In my instructions I say to verify it…then send it so maybe you missed that step?

Ok, I’ll try

I did hit the wrong button, but when I tried to upload it with the upload button, it’s giving me the same error messages as the arduino program. These are the messages:

avrdude: stk500v2_ReceiveMessage(): timeout

Any ideas o what it is?

I get like five of these messages and then it says error, upload failed.

Make sure the power is plugged in and correct. Windows will usually give the USB chime when it sees it. If it doesn’t you can check the power, the two tiny fuses, another USB port and/cable. That covers 95% of the issues people have had.

Upload a picture of how it is set up right now helps to spot issues.

I am using a Mac, could that be influencing it?

Also, I checked everything you told me to check, but I don’t know how to see if the fuses are no good. Here’s a picture of the control board.

1 Like

This is an indication you have a communication error between the board and your computer. When the board is powered, you should see a lit green LED in this area:

I don’t know enough about the Mac to troubleshoot where the error is occurring. In addition to the green light, you can check the voltage on some pins:
Being careful not to short them, you can check the voltage between the pins in the red rectangle and the black rectangle. It should be around 5V. If you have voltage here and/or the green LED is lit up, then it is not a fuse/power issue.

1 Like

I highly doubt it is a mac problem it should be even simpler on mac than windows. But I don’t have a mac to know for sure.

1 Like

I changed the title, I am not sure if MAC makes a difference with, so hopefully a Mac user helps out. Just to be certain.

Thank you for your answer, but I just went to Best Buy. And they help me with the control board, and we checked the fuses and the USB cable. But none of them had a problem. So I am imagining that when I tried to power the board up for the first time, I know I burnt some thing because I didn’t put it in the right port. So could that be affecting the USB port in a different way? And if so is there any other way to transfer the firmware on To the control board? If there isn’t due I need to buy a set another control board?

If you put power to the wrong port it always pops one of the small fuses. Did you pull them out to test them? They are the little brown and gold fuses on the board, not the big automotive one.

We did not take them out, but I’m going to send you a picture of where I connected the power. Around that area is where some thing got burnt. So please tell me if I need to buy a new control board or if I can fix it?

The red circle is where I plugged in the power the first time

Shoot. I am not sure. Take the fuses out and check, if they are still good it must have killed the 5V regulator.

Ok, I’ll try

The pins you circled are, according to the label on the board, 5V Aux output pins. So if you hooked up 12V to these pins, then there is a potential that you burned something out. The fact that the old firmware will run on the board indicates that there is some hope. So if it were me I would do the following:

  • Hookup power and verify the board boots with the old firmware
  • Put XLoader and the firmware on a USB stick
  • Borrow someone’s Windows machine
  • Attempt to flash your firmware using a different USB cable

These steps pretty much eliminates all the other causes but the board like: lack of power to the board, bad USB cable, device driver issues on the Mac, PlatformlO issues. By using XLoader on a USB stick, you will not have to install anything on your friend’s machine.

Note how are you determining that the old firmware is running? If you are using some sort of g-code sender, then the USB is likely okay.

If it turns out to be the board, and if you want to go the extra mile to save the board, and you think that only the USB circuit is damaged you can hookup a FTDI module like this one to TX0 ane RX0 of your board.