Trouble shooting Banggood Laser

Hello Fellow CNC’ers. I have my MPCNC up and running finally. But I can not control the laser from the Rambo 1.4 board. I’ve read through more threads than I can remember, trying to find the answer to my problem. So that being said please be patient with me if I’ve overlooked it somewhere. Here is a run down of what my setup is running:

MPCNC with Rambo 1.4 (bought Nov 2018) not sure what version it is…

Fusion 360 with MPCNC laser plasma post processor running

Repetier-Host to produce g.code

Banggood laser 2.5w.

What I have tried:

I’ve Plugged the TTL/PWM wire in to the MX2 pins Pin 45, I tried using the (-,+) outputs on the MX2 pin-out along with the 45 pin and got nothing. I then switched the TTL/PWM wire and the (+) going to the laser in-case it was mis-labeled. This resulted in the laser’s cooling fan powering on but only at 1/2 power.

I’ve tried running signal from the MX2 -45 pin and using the 12v power supply, this gets power to everything but does not control the laser. It’s ether all or non and controlled by the on/off switch on the laser control board.

And I have turned the fan setting to 100% on the LED screen.

I did notice something wile writing this up… What is meant by "45 (PWM), your laser pin or PID speed. Controlled by M3

What I need: I don’t need halftone results right now. I simply need to be able to cut vector images without the “yellow tool path lines”.

Hello J Ramsey

A few basics first. Eye Protection. Make sure you keep your eyes safe. proper lenses are a must. If the machine is located where other people can just walk in make sure they are safe as well. Think about covering or enclosing the machine.

Ok, it sounds like you have a good start on your laser. I think you are missing a very simple step but I will get to that in a minute.

Your laser will need both the 12V power and the the TTL. You cannot power the laser from the Rambo like you mentioned earlier. The laser will need to have the 12 V power then your Rambo will control the laser output with the TTL wires. But it sounds like you sort of figured that out already.

So your laser should have 12 V power and the TTL wires should connect to the Rambo in one of two places. Either the Fan pins or the laser pin. I don’t have the Rambo board so I don’t remember which ones these are. But I’ll bet you do. The Fan Pins produce a 12 volt (TTL) control signal and the laser pins produce a 5 Volt (TTL) control signal. I believe your laser needs the 5 Volt control signal. I could be wrong. Please check any documentation you might have. If that is the case then you need to connect to the laser pins not the fan pins.

Last step. (Sounds like you are already at this point.) Test the connection. If you are connected to the fan pins then you can use the LCD or send the command M106 to turn the laser on. If you are connected to the laser pin then you need to send a different gcode command. This is what I think you asked about in your post. You will need to send M3. I would actually suggest M3 O010. That will only turn the laser on low. not full power. then you can turn it off with M5 I think.

Feel free to ask any other questions. Like "how do I send gcode commands etc. I don’t know what you do and don’t know so I am just trying to answer the question(s) you asked.


EDIT it might be fun make a Gcode file like this. Save it to the SD card and run.

M3 O005; Turn laser on low power

M0 Laser On Low; Show message on LCD

M3 ; Turn laser on Full power

M0 Laser On Full; Show message on LCD

M5; Turn laser off



1 Like

Aaryn, Thank you for the coding tip. I didn’t realize you couldn’t use the M106 with my setup. I’m new to coding, so correct me if I’m wrong but here is what I attempted…

Powered the laser with the provided 12v power source, Connected the TTL/PWM input to the MX2-45 pin. Then in after importing my file into Repetier-host, I opened the “Edit G-code” tab and replaced all “M106” with “M3”. I also replaced M107 with M5… I selected print and got the same result. No control over the laser pulse.

I then turned everything off and tried the Fan 1 and Fan 2 (+) output to TTL/PWM and still got nothing.

Not sure where to go from here…

And yes I am using eye protection and securing the area before use. Can’t be too careful.

Did you enable the laser and reflash the firmware? If yes, have you put a multimeter on 45 and neg to see if you can vary the voltage using the M3 S255 and then M3 S100 etc?

I was not aware you had to re-flash the firmware. Which version should I load?

M3 is not working correctly M106/7 is working better but have a look at the laser page for more details.

I’ve been too busy with work and side jobs to dig into this problem for the last few weeks. I jumped in last night and ran some prints/cuts with the laser disconnected (for safety) I used a volt meter to test for a signal from different pins. I never got a signal from the M45 pin. I used the (-) on the M block. It acts like the pin is not activating. Is there a firmware update I’m missing? Again I apologize for being a Newbie and missing some steps.


To be certain you should double check the firmware configs and reflash. Not all of them were set.

I am trying to get my Rambo 1.4 setup to run a laser (12 V power supply with 5 V PWM/TTL – I have remapped FAN_PIN to 45 [by editing the Marlin/src/pins/rambo/pins_RAMBO.h file] and attached wires to the MX2 pins 45 & (-) as shown in this image I reflashed the firmware and then put a voltmeter between pin 45 and the (-) pin – it reads a low voltage (60mV). This does not change when I send the command M106 S255… I’m not sure what I’m missing. Any suggestions?

I assume it makes sense to verify correct PWM signal behavior before actually plugging in the laser… So, I’m stuck here.


I just noticed the laser information here – does this mean that I should be using M3 instead of M106 to control laser power? Do I need to enable the laser in the configuration file? I have not found specific instructions on this – chances are that I’m not looking in the right place.

If you remapped the fan pin, then M3 won’t work. Make sure nothing else is set to pin 45.

1 Like

In the page referenced above(, regarding the Rambo v1.4 board it says the following:

“When using a laser or a PID controller the Pins on MX2 are available
45 (PWM), your laser pin or PID speed. Controlled by M3
31 Laser or PID, enable, Controlled by M5
23 not assigned yet, Shared with YMAX”

Is this not correct?

But you remapped it to the fan pin M106 controls the fan M3 controls the spindle pin.

1 Like

It is working now. The only thing that I did differently is to edit both of the RAMBO pin files in Marlin/src/pins/rambo (e.g., pins_EINSY_RAMBO.h and pins_RAMBO.h) where I reassigned the fan pin from 8 to 45. I don’t know if this has anything to do with why it works now, but it does work, so I’m going with it… Thanks for your help!

1 Like

What laser are you using. I am thinking about ordering one for my system soon. Would feel better about the purchase if I know there is at least one out in the wild working as intended. :smile:

I’m using a Banggood 450 nm 5W laser ( Once I got the Rambo board to behave as it should (I don’t know what I did special to make that happen…), the laser works as expected. I’m not impressed with the lens and the ability to focus the laser dot. I will be looking for a better lens. I also recommend getting better glasses than what I got as I read that the cheap lasers are quite dirty with their spectrum. I just ordered some new glasses that cover a wider range of frequencies. I don’t want to take any chances… All things considered, I think the laser will work out fine, especially if I can get a better lens. I’m not sure about it’s life yet – I guess it depends on what kind of duty cycle it is put through. Good luck!

Thank you for the reply. I have been researching and just can’t decide which laser to purchase. I have the Rambo 1.4a board. I will be looking for a pair of better glasses as well. Can’t be to safe. Did you have to reflash your board to work? I took a reading with my multimeter on pin 45 a few days ago and was getting nothing with the M3 or M4 commands. I figured I would purchase a laser and go from there. There is obviously a way for it to work and these forums seem to be a lot of help if it comes to that. Thanks again and happy cutting.

Sorry for the late reply, I just noticed your question… I did have to reflash the firmware because my laser (like many others) uses a 5v pwd/ttl signal. The Jtech laser uses a 12v signal and can be plugged in directly to the fan0 connection. The edit to the firmware is minor and documented elsewhere in the forum. It amounts to reassigning the pin for fan0 to another pin causing the control signal to be 5v instead of 12. The command to start the laser is m106 sXXX ( where XXX is an integer between 0 and 255 indicating the signal power). It took me a couple of tries to very this to work and I’m still not sure why it didn’t work the first time… since it’s working now, I don’t want to mess it up…

I did add a 12v fan plugged in to the fan1 port for fume exhaust. I added a “dryer duct” port through my wall and i exhaust the smoke outside. It works pretty good. The fan is turned on with the m106 command too, but the optional parameter P1 is added to specify fan 1 (versus fan0 where the laser is controlled from). That is, to turn on the laser, I use the command m106 s255 (or equivalently m106 p0 s255) and to turn on the exhaust fan I use m106 p1 s255.

I hope I answered your question somewhere in there…

Yes that answers all of my questions. Thank you for the reply. I think I have it all worked out in my head now. Just waiting on getting the laser in to start experimenting. Thanks again!

Great! When I got stuck, the forum helped me out. I have really been enjoying my (cheap) laser. It works surprisingly well.