Strange movements of Y2 motor MPCNC Primo

Hi Guys,

ive been using my mpcnc now for 3 days and have cut some stuff for about 3 hours in total. some hole pattern and some tools to clamp my stuff.

after the last job X movement is okay but when i move in the Y direction the Y2 motor starts making strange movements. ive disconnected the belts etc to check and connected the motor to Y1 to check but the same happens. Y1 rotates normally Y2 moves left and right but does not fully rotate.

ive replaced the stepper motor with a new one. ive replaced the wiring and replaced the TMC2209 drives for the Y axxis.

Checked with the M122 command to see if anything is wrong.
driver current is set to 1300ma and im using a 8amp 12V power supply.

im using NEMA17 2A steppers with BTT TMC2209 drivers on a SKR Pro 1.2
im using the TFT35 and had a SD card in the TFT screen to work from.
im using Stepperonline 17HS19-2004S1 and have a few spare.

Screen is using firmware: from nov21
SKR is using the latest dual endstop marlin firmware.

Took the belts off to check if the machine still is able to move freely and nothing is binding up checked the instructions and made sure everything is square again. took all bearings out and checked. but im thinking i have a bad SKR 1.2 pro. any other things i can to to check?

any pointer or ideas are welcome. can make a video of the motor movement if someone wants to see.

As a starting point, check the grub screws on the pulley. Loose grub screws are a pretty common problem on the forum. Also move the Y axis slightly electronically then reach out to Y2 and attempt to move it along the rail. The stepper should be engaged/locked. If it is not, you may have the wrong firmware installed. Another test is to swap the wires between Y2 and Y1 and test. Knowing if the problem stays with same motor or travels to the other side is helpful. A video might help spot the problem. A picture of your control board and your wiring might also be helpful.


When I move the Y2 to Y1 or any X output the problem moves with it.

When I use a different motor the same happens.

When I remove the extension wires the problem goes away. I have 1m long extension wires with 1 side a DuPont 4 wire connector and the other side the white small connectors that fit the motherboard. I have tried different extension wires but the same happens.

So I’m thinking a voltage drop on the extension cables?

YouTube video of the issue

PSU has a voltage regulator on it and is delivering 11.98v while machine is running i can adjust the voltage on the PSU side would it help to give it a higher voltage think the SKR can work with 12-24v any tips there still dont get why only 1 stepper output does not play along when extending the wires all other motors work fine when the wires are extended.

Voltage drop is not the issue. These are the cables Ryan has been shipping for years and used by many machines, and I don’t remember ever seeing on the forum an issue traced to voltage drop due to the wire. Your other motors using the same type of cable are working fine.

The problem is following that specific cable, so it sounds like you have a bad extension cable. Take a multimeter and check for continuity. May also be a loose connector in the cable, so even if continuity checks out, it does not mean you are getting a good connection to the motor.

If there is a break in one of the four wires in the cable, then only one of the two coils in the stepper motor would be energized. The behavior I see in the video is what I would expect if only one coil is being energized.

1 Like

Replaced motor and extension cables same keeps happening and tested with multimeter as soon as I use a shorter cable or no extension all is good.

As stated above, I don’t think it’s voltage drop (unless your MPCNC is unusually large). If you think it is voltage drop, can you put together a cable with larger conductors?

Any chance a connector is flexing when the machine is moving? There have also been (rare) occasions where the provided connectors are crimped on the insulation rather than on the conductor, resulting in unreliable/intermittent connections when things start moving. I’ve made a bunch of my own extensions and know I’ve done a poor crimp or two in my time. You need to get the pins out of the connectors in order to examine the connection point I’m referring to.

I want to summarize what you’ve tested.

  • You’ve swapped in a new motor, and the problem still occurs.
  • You’ve swapped in a new stepper driver, and the problem still occurs.
  • You’ve moved the extension cable to a new motor, and the problem moves to the new motor.
  • You’ve swapped to a different extension cable, and the problem still occurs.

I want to be absolutely clear here. When you swapped the extension cable to a new motor, that was on a different stepper driver. Correct? If the problem stays with the stepper driver socket, then I would suspect a bad solder joint on the SKR Pro board. We have seen bad solder joints on the stepper driver sockets. Last time it was the direction pin, so the motor would only run in one direction.

Do you have any motors that function correctly with an extension cable? If you use that specific cable, does the problem occur?

Did you purchase your stepper motors from V1, or did you purchase them elsewhere? If elsewhere, can you give us a model number.

You are doing all the right things to troubleshoot this problem. I’ve been active on this forum daily for the last few years, and this is the first time I’ve seen a potential issue related to the length of the wiring, especially since current extension cables sold by V1 use bigger gauge wires than the serial harness V1 sold in the past. The fact that no one else is having issues with wire length leads me to believe that something else is going on here.


No when I move the extension cable it’s fine on other motors just the y2 giving problems when I connect it with a extension cable

1 Like

Yes the other 4 work fine with extension cables only when I add a extension cable to y2 I have random issues

I did not buy the extension cables at v1 engineering. Thinking of doing that now.

thanks for all the quick and helpful answers guys! was thinking I forgot some setting to get the correct current or voltage at the motor. I have a ossiloscope so I could log and measure the signal at the stepper motor if needed just need to know what to look for.

Would using a 24v psu vs a 12v psu help somehow? Otherwise I’ll order a decent 24v psu to test

1 Like

Some results of my first cuts on the Mpcnc for entertainment

361 holes in the spoilboard before issues popped up:

And some tools to square / hold my workpieces:

If it is really a voltage drop problem associated with the extension wires you purchased, then running at 24V might help. In general, higher voltage only helps with very fast movements like you might want for laser engraving or pen plotting.

As for current, I think you have TMC2209 drivers installed. If so, and you set them up correctly with the bend pin, they are getting their current settings from the Marlin firmware, and the values V1 set up for current work well for most machines. I believe there is a bit of headroom in these settings, and you should be able to adjust the current using the display or using g-code.

A voltage drop most certainly could cause this… but if it was that then it would be ok going slower and only stall at higher speeds (due to how chipper drivers work). If the motor just skips steps with no acceleration from stop before, then it would have to be like a 10V drop (not happening at such low amps right?). So I vote there is an intermittent connection somewhere… on the y2 motor circuit somewhere. May be the jst connector on the pcb… could also be the motor driver socket DuPont connector. At least you know what to test to fix this.

1 Like

Thanks yes I calculated the correct stepper current and set them up in the firmware.

Just wanted to validate my thought process on troubleshooting this to make sure I did not mis anything important thanks for all the help. I’ll keep you guys posted on how I fixed it

Have you checked M122 after the problem happens, but before you disable the motors?

That juggling looks like an open connection to me.

The steppers are driven by current. The voltage is toggled very fast and the duty cycle determines the current to the motor. The driver is trying to reach the max current on the “desired coil”. But it gets more complicated because the desired coil is some fraction of each coil most of the time (because of the microsteps).

When the steppers move, they “fight back” with a reverse voltage. But when they are sitting still, that is near zero. If the wires were small and long, there could be a big voltage drop. And if your power supply was underperforming, then you could get in a situation where only a fraction of your desired current was reaching the motors. But it doesn’t make sense that this wouldn’t be able to move a motor shaft with a piece of tape on it.

It really looks like an intermittent wiring issue to me. I also would look closely at the driver socket and the wires.

The other slightly different thing is your current setting. 900mA is more typical. The limiting factor isn’t the motor or power supply ratings, it is the heat. The motors and motor drivers can get too hot. The motors will make the plastic soft enough to deform (keep the motors below 50C). The drivers will turn down the current to protect themselves. They may even briefly turn off.

M122 will tell you what they are doing. OT is over temp. OL os open loop. I bet you one of those flags is set when you’re having the issue.

1 Like

M122 show no problems it’s strange, I’ll check the motherboard connector for bad soldering tonight only last thing I can think of. Like I say only happens when i put any motor or wiring extension on y2 only happens when I put the proper jst connector on the board if I use DuPont style connector all is good! Thinking the white connector that clicks in place somehow makes bad connection

1 Like

Thanks wil put them back on 900ma and mount some fans on the motors