Steppers won't move. Archim 1.0a with new firmware

So I bought the whole MPCNC kit two years ago from V1, life got in the way and now I just finally put it together. Wired it all (Archim 1.0a with Dual wiring), and turned it on, zero movement on the steppers while in the Repetier-Host. I just flashed the firmware to the new thinking that was my issue, still nothing. I triple checked the fuses, the console is showing the triggered end stops when I press them and send the M119 code, so that part is working. I thought maybe the X/Y belts were too tight, so I tried to just move the Z axis since that moves really smoothly, still nothing there. Help a newbie please!

See attached pictures.

your pic looks like there is no power to the motors. You need to connect where the power comes in to the motor power spot also. Just a couple pieces of wire will do


This is a different board but the same idea for jumpering the power between the logic side and motors side


Shut the front door! I just tried this and they are working. That’s wild. It seems very logical, however I couldn’t find that in any of the instructions, my thought was the main power would distribute to the steppers. Awesome, thank you very much.