Steppers weird behavior.Z works, Y doesn´t, X locks

Hi there…now running into a weird issue with my ramps/steppers combination.

summary: I am testing all drives/stepper work correctly before final mounting them

Z works perfectly from lcd and pronterface or repetier.

Y doesn´t work at all

X locks

Attempted troubleshooting/checks/tests

. power is ok and driving the four terminals on the ramps board

. mega is correctly attache as far as I know.

.I am running latest firmware for T8 leadscrew with no hot end.

.no, I am not using any enstops :slight_smile:

. changed driver boards, and even the ramps one. No matter with combination of stepper/driver I use, I always got the same behavior… Z works, Y doesn´t at all, X locks and doesn´t move.

. amps are set at 0.7 on each driver, tried with more (up to 0.8) and less up to 0.45… behavior still the same

. I am using 17hs19-2004s1 steppers… accordinhg to the wiring specs… A is black A\ is green, B is Red and B\ is blue. Conneced directly to the ramps terminals I got this behavior.

.Firmware I am using is MPCN813_GLCD_T8, installed it several times just in case…

. all three jumpers are installed for the three axis on the ramps board.

. I sucked my brain fried checking this forum and the web to no avail.


Does anyone any useful hint or troubleshooting guide on how to tackle this… many many thanks in advance! happy to provide more information if needed…

Picture of your board wired up will help and what drivers?


Chances are high if you are not using my wiring harness that they are just wired wrong, colors mean nothing, you can not wire by color. Each company uses different colors.

Hi ryan… drivers are the DRV8825 ones… I am wiring the motors by their coil winding specs…tried to reverse the wiring on coil A to no avail.

The funny thing is that it always work correctly on Z axis, while it doesn´t at all for Y and locks in X. Same motor, same wiring, just in different axis connector… that is the thing that brakes my brain…


photo an wiring specs attached… thanks! my current setup is blue: 2b, red:2a; green:1a; black:1b



Those pictures are too small, probably thumbnails of the actual picture.


Try trouble shooting with 1 stepper plugged directly into the ramps. If it doesn’t work your ramps or arduino is bad. At this point bad ramps stacks seem to be at about 50/50 right now, that is why I stopped carrying them.

shit… I was trying plugging them directly to the board :frowning: so seems that something is wrong… and the behavior keeps happening… I tried with two ifferent ramps boards an behavior is still the same… might be an arduino mega issue maybe?

May I try a different firmware?

Luis S.

Swap drivers to see if they are the issue, firmware should not change anything at this point. From there it could be anything.

changed drivers… behavior continues :-(… bad mega then? because trying with two ramps seems too bad luck that they got the same error…no?

If you have changed the shield and it stays at the same port then yes bad Mega.

ok, ordered two more just in case… crossing fingers will keep you posted…

you know? replacement for the arduino arrived… and it works like a charm with the default stepper wiring! so all those hours of troubleshooting prying my hair off and you were rigth, the mega board was faulty. Well, a hard learnt lesson… el cheapo clones are not worthy. I invested a bit more on a genuine arduino board and can´t be more happy. Next step is to replace the ramps with a high quality one that I have discovered is assembled in europe an everyone is happy with :slight_smile:

next step: mouting the steppers and wiring… thanks a lot man! really apreciated!


Luis S

and happy new year too! :slight_smile:

1 Like

I had the same epiphany when I discovered how different the UltiMachine boards are. These boards are a few generations ahead of the ramps, and Johnny designed the ramps, just think of how much he/they have learned since then. If you are going to spend the money to buy better quality I highly suggest buying the current generation instead of just properly built old generation.

I gambled my business by not carrying Ramps anymore and I tell you what, the electronics related questions have almost disappeared as have failures. I went from a electronics troubleshooter back to a mechanical engineer doing R&D (and some programming).