Steppers Stalling VERY easily/ No power or torque

  1. Did you buy everything from here?
    a)If you didn’t or changed some things please don’t leave out any details.
    I purchased Nema17 Steppers from StepperOnline. They are rated @ 2A per phase and 2.8vdc per phase
    b)What firmware?
    Marlin NOLCD

  2. Are you using end stops?
    a)If so please disconnect them.
    b) If the problem is still there leave them disconnected while troubleshooting.

  3. Are you using all my recommended parts?
    Yes, using the 8825 drivers
    a) If not please list what parts you used.
    b) I am not against other peoples parts but most of them have not actually even been tested on a working machine. I am against people making “improved” parts when they have not even tried mine. Please, “don’t fix what ain’t broke”.

Doing the math that is suggested, I have 2.0A x 2.8VDC (per phase) = 5.6W Power but using 12VDC would be 5.6W/12VDC giving .48A x 2 steppers .96A needed. So I trim the pot to .48VDC on VREF to limit current to the 9.6. If I raise my current I do get more power but I can still stall pretty easily. At this point I can only think to increase my voltage. Anyone have any ideas?

Start at 0.7 and work up to .96a. Anything above 0.7v you should have a fan pointed at the driver heat sinks.

Not sure why you divided by 2 from the .96 I think that is in there from the pololu video for the a49 drivers. Steppers don’t need to be super exact. You can under and overpower them safely. The drivers can easily over power them so just keep upping the voltage until the steppers are warm to the touch after some use. Make sure they don’t get hot enough to soften the pla mounts.

Just to give you an idea. ours are shipped at .7 and work from .6 to 1v

Hey Vicious! First off, I love the ingenuity of your design and how much support you give! So, thanks in advance. Not sure what is going on, but it stalls just by normal motion. I even rewired with brand new wire (I had some old stuff from work first) to avoid chances of there being a short or something. At this point I’m out of ideas. I tried everything from .5VREF to 1VREF (1-2A limit) and same results minus the more power the more torque. I just don’t think these drivers can power these motors yet I can’t be the only one with these size motors but yet I can’t find anything in the 1100+ comments on thingiverse or going through the forum one post at a time. I feel like its a setting issue or something. I don’t know though.

I don’t normally have time to look up other equipment than the recommended.

Link to your exact steppers will help.
What is your step angle? Are your belts so tight it prevents movement? Do they work fine with no belts? When you say move 50 mm do they try and go 100? Are you using all three jumpers under you drivers? Is you power supply large enough? What size are your pulleys?

There is hundreds of questions if you didn’t buy the stuff from here.

I understand 100%.

Link to your exact steppers will help.

What is your step angle?
Are your belts so tight it prevents movement?
Well, to be honest, not sure. Maybe? I will check that too. ninja edit I can stall by grabbing the pull and no load (have to really grip but I can)
Do they work fine with no belts?
Will check now
When you say move 50 mm do they try and go 100?
Distance APPEARS (keyword here) to be right.
Are you using all three jumpers under you drivers?
Is you power supply large enough?
12V5A like you have in build sheet
What size are your pulleys?

There is hundreds of questions if you didn’t buy the stuff from here.
Understood. hopefully this post helps others but being so many have been built and no problems so far, clearly something I’m doing wrong. :wink:

Double check you have the pairs right everything checks out.

Make sure you are using my current firmware, the accelerations are a bit lower. How are you trying to move them what software at what speed? Load my test file from the import extruder post and see how they move using my settings.

Using the one on this page:

I open your file but can’t get it to run because it keeps wanting to heat extruder. I have tried editing the code and doing a dry run but apparently I’m missing something

edit* Found the .nc test file. moves the same. my next test I think is going to be to take the power supply off my other cnc router table and try running the motors a little hotter.

The steppers all running at the same time use very little power. if I remember right 0.3A. Steppers aren’t always moving so they aren’t always using power, they step. 5A is more than enough by far.
Did you take the belts off?
If they move crappy and weak with the belts off you have them wired wrong.

Took belts off, same. They move smoothly. Definitely have wiring right. Hmm this is interesting

So either your belts were too tight or your tension bolts are too tight. Give everything some slack and try again.

Sorry, should have watched my wording. They still stall if I grab the pulleys.

Hard to say. You can easily stall the stepper by hand. Unless I actually tried it we have no way to know if you are just expecting too much or if they are weak.

I understand. I’m going to do a video here today to show. I work on CNCs for a living and I have a CNC Wood router right now so my expectations are realistic. If it stalls just doing a rapid, it will never be able to do any carving or even drawing. Going to try and get it all wired today and then try a bigger PSU (though V really only affects speed). Another weird bit, the motors aren’t even getting warm, but the drivers sure are when pushing the limits. I will probably just end up upgrading to full stepper drivers and putting my linuxcnc box on it. I have a lot of projects for my wedding in April I have to get done. :smiley:

My drivers can do 1.2v before things get too hot with just one fan on them. If that doesn’t push your steppers you need need to find the issue. Your steppers should get hot with that much power, ours do. Even though your steppers are spec’ed as stronger, for some reason they use less power?

Did you loosen up all the bolts that control tension? I would find a way to put some belt on there hand hold it to verify it is actually going the right distance. These things would be so much easier if I could just swing by and have a look. Trouble shooting sight unseen is rough.

Is your z axis stronger, since it is only 1 stepper?

If the z is not stronger it is a stepsize, wiring, firmware, or friction issue. If it is stronger double check each stepper by themselves to make sure you don’t have a bad one, then triple check to make sure you are wired in parallel not series, and wired correctly.

First off, thank you for all your time. As someone that has a hard time finding said time to just take a breather, I know how valuable time is.

Second, here’s this :smiley: MPCNC Mostly Printed CNC First Run - YouTube

Before you ask, I’m not sure what was causing issues. I did so much at one time.

  1. Machine wasn’t square maybe?
  2. Belts too tight? (in my video I show the slack. does that look OK).
  3. Drives not tuned properly?
  4. Bearings not right? (speaking of, is there any adjustment?)
  5. I rewired everything 3 times, no joke. Used used cable, new cable 16/4 then went to 22/4 alarm wire.

Of course I have to travel next week, but will be throwing a dewalt on there Anxious to see how she carves. I do want to upgrade to 24VDC I think for speed (low low priority) and upgrading to a ballscrew. I have a few ideas on making a better drag chain setup for the machine. I need to contribute something now! I will keep this post up to date and maybe get a nice video to put on your playlist :wink: I will be dropping a donation your way if there is a place. Will be looking. I appreciate all your help and your time. Take care and and will probably hear from you again later!

Looks good right?! Is there anything wrong now?

Only that I didn’t buy the router or laser yet :slight_smile: Now I need to learn Estlecam and Repetier (which won’t take long with all the resources available) this weekend/week so when I get home I can get to carving my projects. Very excited!

Congratulations!!! You stuck with it, I bet it was frustrating as all hell. I had extruder issues that took me 3 months to figure out. When I figured it out I felt great!